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OnCommand Insight Plan features

OnCommand Insight includes planning features, which provide near real-time visibility into global
resource allocations, rule-based automated service tier management, and utilization and chargeback
data. Storage administrators can use these features to help in automating the storage request and
delivery processes.

The OnCommand Insight Plan features include:

• Capacity utilization reports by tiers and data centers.

• Chargeback reports that show historical storage consumption by business entity (tenant, line of
business, business unit, and project).

• An API to perform requests and requirements and see reservations.

These features offer the following benefits:

• Supports your request process by providing visibility into near real-time resource allocation.

• Assists with future demands by being able to identify existing utilization and outstanding
reservations.

• Reduces the time needed to provision services.

Note: OnCommand Insight assists with the implementation of storage policies and procedures,
but does not perform any task related to virtualizing servers or provisioning storage.

• Assists in the creation and enforcement of a storage tiering strategy.

• Uses the service information discovered by OnCommand Insight to organize requests for storage
resources.

OnCommand Insight product portfolio
OnCommand Insight is a suite of products that boost the quality and efficiency of your storage
environment by providing near real-time visibility, multi-vendor and multi-protocol support, and end-
to-end service-level views of your application storage path.

The OnCommand Insight portfolio provides the tools for you to manage your environment. You can
do the following:

• Optimize the assets that you have on the floor, according to space, performance, and usage
criteria.

• Optimize the business activities, such as application or storage service, on your assets.

The OnCommand Insight portfolio includes the following products:
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OnCommand Insight Assure

Helps administrators focus on maintaining storage service on their storage resources. Lets
administrators establish global, application, host, or path-based service policies and
manage the effects of change, risk, and service-level violations of those policies on
availability and performance.

OnCommand Insight Perform

Helps administrators focus on their storage resources. Collects and maintains service
performance information to help administrators reclaim under-utilized storage resources,
manage tiers, analyze storage virtualization efficiency, improve load balancing,
troubleshoot congestion and contention, and improve resource utilization to optimize
services.

OnCommand Insight Plan

Helps administrators focus on both storage resources and the services on those assets.
Provides administrators with an end-to-end view of resource order, the storage allocation
process, and trend usage so that they can manage resource reservations and forecast
consumption and resource needs. Administrators can report on costs for storage services
by business entity or tier and use this information for chargebacks on storage usage.
Business level roll-up reporting helps storage administrators improve capacity planning
and optimize consumption by application and tier.

OnCommand Insight Assure, OnCommand Insight Perform, and OnCommand Insight Plan use the
same integrated discovery component. This discovery component provides visibility into storage
availability, resource inventory, and host-to-storage access paths. Administrators can also gain
visibility into the path from virtual machines to arrays for organizations deploying VMware ESX
technology combined with VMware vCenter (VirtualCenter) technology.

The Inventory features are the foundation features for the OnCommand Insight suite and are used in
OnCommand Insight Assure, OnCommand Insight Perform, and OnCommand Insight Plan.

OnCommand Insight Assure, OnCommand Insight Perform, and OnCommand Insight Plan also use
the same report authoring tools and the same Data Warehouse platform.

What you can do with OnCommand Insight Plan
Using OnCommand Insight Plan, administrators can view the end-to-end storage resource order and
storage allocation process so that they can manage resource reservations and forecast consumption
and resource needs.

Administrators can do the following tasks:

• Accelerate data center consolidations. Relevant VM, storage system and network switch
information from multiple OnCommand Insight Plan instances can be aggregated into a single
view thus providing you with a global view of your asset usage.
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• Improve capacity planning by tracking incoming storage requests and capacity trending and then
supplying detailed information to support capacity planning.

• Simplify provisioning by checking plans for compliance with preset policies and when a
provisioning task is completed, confirming that all plan steps were executed correctly.

• Using OnCommand Insight Plan Data Warehouse, you can view capacity-related reports, such as
chargeback, consumption analysis, and forecasting reports.

OnCommand Insight Plan is not an automated storage provisioning tool. All requests are manually
implemented using tools other than OnCommand Insight. Also, using OnCommand Insight Plan does
not replace the need for storage policies and procedures; the product assists in implementing them.

How OnCommand Insight Plan can speed data center consolidation

OnCommand Insight Plan can accelerate data center consolidation, for instance in an acquisition.

By using these OnCommand Insight features, you can accomplish the following preparatory and
analytical tasks:

• Establish how much of each storage resource is being used in each acquired data center.

• Identify and compare technologies used in the parent company and acquired data centers.

• Document relationships between acquired applications and infrastructure components.

The resulting information helps you perform the following tasks:

• Generate a reliable, timely estimate of infrastructure and effort required for consolidation.

• Efficiently locate migrated applications and resources in the remaining data centers.

• Prioritize migration activities to reduce duplicated effort and minimize the time to value.

How OnCommand Insight Plan can improve capacity planning

By using OnCommand Insight Plan, you can deliver an accurate and timely capacity plan.

Use OnCommand Insight Plan to perform the following tasks:

• Manage reservations of different resources.

• Track outstanding requests for ports and capacity.

• Report costs associated with each reservation requirement.

• Record reservations for specific volumes, capacity, and ports.

• Register the fulfillment of resource requests.

The resulting information enables capacity managers to do the following:

• Quantify the demand for reserved resources.

• Forecast capacity needs based on past, current, and future demands.

• Perform chargeback for storage services.

• Optimize consumption by application and tier.
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How OnCommand Insight Plan can simplify provisioning

Storage administrators can use OnCommand Insight Plan to define service provisioning action plans
to allocate capacity for new or existing hosts and applications.

OnCommand Insight Plan checks plans for compliance with pre-configured rules, and when a
provisioning task has been completed, confirms that all plan steps have been executed correctly. This
enables storage administrators to provision applications quickly, correctly, and with minimal
intervention from senior staff.

What questions you can answer with OnCommand Insight
Plan

Using OnCommand Insight Plan, administrators can more effectively manage resource requests,
costs involved, resource requirements, and reservation status.

OnCommand Insight Plan helps answer these resource planning questions:

• What requests (for capacity and ports) are outstanding?

• What reservations for volumes, capacity, and ports are outstanding?

• Which requests for resources have been fulfilled?

• What are the costs associated with each reservation requirement?

• What is the demand for reserved resources?

• What violations have been levied against the reservations? (Requires the OnCommand Insight
Assure license)

Where to find more information about OnCommand Insight
You can find more information about OnCommand Insight on the NetApp Support Site and in other
OnCommand Insight documentation.

OnCommand Insight on the web

For comprehensive, up-to-date information about OnCommand Insight, use these NetApp web site
resources.

• OnCommand Insight product web site at
www.netapp.com/oncommandinsight

• The NetApp Support Site at: mysupport.netapp.com

• The OnCommand Insight data source Interoperability Matrix at mysupport.netapp.com/matrix.

Product documentation

You can access the OnCommand Insight guides at the NetApp Support Site to learn how to use the
product.

You can access the following documents from the NetApp Support Site at mysupport.netapp.com/
documentation/productsatoz/index.html:

OnCommand Insight Installation Guide for Microsoft Windows
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Describes the installation prerequisites and procedures for the web-based interface version
of OnCommand Insight.

OnCommand Insight Getting Started Guide

Helps new OnCommand Insight users set up and customize their installed system and
begin using it for improved efficiency.

OnCommand Insight Configuration and Administration Guide

Provides an overview of suite architecture, including instructions for starting your system,
discovering the logical and physical storage resources in your storage environment, and
performing administrative tasks.

Also, describes the configuration parameters and some installation procedures for data
sources used by OnCommand Insight and provides recommended methods of discovering
your storage environment for the OnCommand Insight deployment.

OnCommand Insight Inventory User Guide

Provides information about the tools and features of your SAN or NAS inventory
environment. The Inventory features are the foundation used by all other products in the
OnCommand Insight suite. After looking at the OnCommand Insight Getting Started
Guide, use this guide to learn about basic features common across all OnCommand
Insight modules.

OnCommand Insight Assurance User Guide

Provides an overview of how to use OnCommand Insight to analyze and validate your
storage network environment and to automate monitoring of operations, as well as
procedures for making safe changes without disrupting availability.

OnCommand Insight Performance User Guide

Provides an overview of how to use OnCommand Insight to reclaim underutilized
resources, manage tiers, identify multipath risks, and troubleshoot ongoing performance
bottlenecks.

OnCommand Insight Planning User Guide

Provides an overview of how to use OnCommand Insight to enable educated capacity
management decisions by managing the end-to-end resource order and allocation process.

Also, describes how system administrators can communicate storage capacity
requirements to SAN managers using OnCommand Insight Connect Applications web
access instead of the full OnCommand Insight feature set.

OnCommand Insight Reporting Guide

Describes reports from the centralized reports portal that support viewing critical
inventory and capacity-related information from the data warehouse.

Also describes the metadata model upon which OnCommand Insight reports are based.

Information in this guide is also available from the OnCommand Insight Data Warehouse
portal and in the OnCommand Insight Reporting Connection.

OnCommand Insight Data Warehouse Administration Guide

Describes a data warehouse repository that consolidates multiple OnCommand Insight
operational databases in an easy-to-query format.

OnCommand Insight Connect API Reference

Provides an overview of how to use the API interface to enable integration with other
applications, such as reporting and monitoring systems. Helps customers and independent
software vendors (ISVs) to develop applications using the OnCommand Insight API
interface.
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Defining workflow rules and policies

You can define rules and policies in Settings that enable you to take full advantage of Insight Plan
resource allocation features.

You can define rules and policies in Settings to define these resource allocation tasks:

• Automatically assigning tiers and service levels to your devices

• Tracking and reporting on costs associated with particular resources

• Setting the boundaries for resource reservations in your environment

Defining the necessary rules and policies can save time and provide you with beneficial information
for your reports. You need to define these rules and policies:

• Service levels

• Tier annotation rules

• Reservation policies

• Cost accounting

Managing tier annotation rules for automatic assignment
To assign annotations automatically to devices based on criteria that you define, you configure tier
annotation rules in Settings. Insight assigns the annotations to devices based on these rules, for
example, assign Tier 1 to all storage pools in a particular family.

About this task

Annotations set manually on an individual device take precedence over rule-based annotations
configured in Settings.

Configuring tier annotation rules for automatic assignment
You can define tier quality rules for volumes, internal volumes, storage arrays, and storage pools that
govern the automatic assignment of annotations to devices.

Before you begin

To configure these rules, the Insight Plan license must be installed.

Additionally, the tier annotation type values (for example, "Gold," "Silver," and "Bronze") should
already be defined (in Tools > Settings > Annotations > Types). Although you can edit the
annotation types while you are configuring the rules, it is a good practice to define the types ahead of
time.

About this task

The process of configuring annotation rules is the same for any of the tier annotation rules (volumes,
internal volumes, storage arrays, or storage pools). The following steps describe setting volume tier
rules.

Note: Annotations also include volume service levels and automatic storage tiering; however, the
criteria are slightly different.
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Steps

1. From the Insight Client menu, select Tools > Settings > Annotations > Rules.

The Annotation Rules view displays the list of existing annotation rule sets. You can add more
rules to the sets and edit the existing rules.
 

 

2. In the Annotation Rules view, select a rule set for the type of device for which you want to set
the tier and click Edit.

For example, select the Volume Tier Quality rule set to automatically assign a tier to volume
objects.
 

 

3. In the Manage Annotation Rules view, either select the rule and click Edit or click Add to add a
new rule.
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4. In the New Rule dialog box, enter the following:

Name

Enter a name that describes the rule, for example, Tier 1 Volume HDS. This name will
appear in the Manage Annotation Rules dialog.

Description

Enter a description that further clarifies the tier rule.

Set Tier on matching volume(s) to

Select an annotation value, such as Tier 2 Volume. These values were set in the
Annotation Type option.

5. In the Rule section, select the vendor for this tier.

6. Optionally, click one of the following and check the specific models or families that will
automatically receive this tier annotation.

By family

For the selected vendor, filtering by family displays all the families for this vendor in the
table to the right of this radio button. Selecting a family assigns the tier value only to those
storage arrays that match the selected family.

By model

For the selected vendor, filtering by model displays all the models of all the families in the
table to the right of this radio button. Selecting a model assigns the tier value only to those
storage arrays that match the selected model.

For all

For the selected vendor, this displays all models without any filters. Selecting all assigns
the tier value to all storage arrays for that vendor.

7. Optionally, select only the devices for this tier that match your criteria of volume type,
redundancy, disk type, disk speed, disk size, or vendor tier. In each tab, first check the option and
then select the specific attributes.

8. Optionally, click the Flash Pools tab.

With automatic storage tiering in place, storage pools, volumes, or internal volumes can be
automatically assigned to a tier according to whether those devices are associated with storage
pools using Flash Pool aggregate technology.
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In the Flash Pools tab, select the Match Volume with Storage Pools using Flash Pools option.

9. Click OK.

Setting up the reservation policy
The reservation policy lets you set the severity for available reservation violations. This policy is
applied to all reservations.

Steps

1. From the Client menu, select Tools > Settings.

2. In the Settings window, expand the Policies tree.

3. Select Reservations.

 

 

4. Select Warning, Error, or Ignore for each field. The violation severity can be set to error or
warning, or the violation can be ignored.

5. Click OK.

Setting costs for resources
You can associate a cost with a particular resource. OnCommand Insight automates the process of
tracking, recording and analyzing the costs you have defined.

About this task

Before generating financial information reports such as the SAN Utilization report, you need to
assign cost values to the tiers, service levels, and switch levels you have defined under Annotation
Types. See the OnCommand Insight Inventory User Guide for more information on defining
Annotation Types.

Steps

1. From the OnCommand Insight Client menu, select Tools > Settings.

2. In the Settings window, click Cost Accounting.
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3. Double-click on the cost values that appear in the far right columns to convert the field to an Edit
pane.

4. Make the desired changes to the values.
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Submitting and fulfilling storage requests

You can submit a request for storage capacity and resources through either the Internet-based
Request Portal or the OnCommand Insight Client. Only system administrators with full access to the
OnCommand Insight system can complete and fulfill the storage requests.

Anyone wanting to make a storage request can use the Internet-based Request Portal to describe the
storage capacity and port requirements to the SAN manager. This portal is available at this URL:
http://<hostName>/request-home/index.do.

To create a complete storage request, the administrator must be certain these three elements are
included:

• Request Form describing the storage needs and supplies information about the requestor and the
project.

• Target Specification defining hosts needed.

• Requirements Specification listing the number of switch ports, the number and the size of LUNs,
and the level of service.

In order to fulfill the completed requests, the administrator must create reservations using
OnCommand Insight with a Plan license installed.

Making storage requests through the Client
You create storage requests in stages beginning with the basic information at the top of the Edit
Request window. The host target and requirement specifications are added in the tabbed areas of the
Edit Request window.

Before you begin

You must have installed OnCommand Insight to use this request method. If you do not have access to
the OnCommand Insight system, you can submit storage requests through the Internet-based Request
Portal.

Steps

1. From the OnCommand Insight Client, select Planning > Requests.

2. In the Requests view, right-click and select Create Request or select Action > Create Request.

3. At the top of the Edit Request window, you must enter values in any field with a red line under
the field name. These are the required fields:

• Name is the title of the request describing the type of request.

• Requester is the name or job title of the person entering the request.

• Due Date specifies when the request must be fulfilled. This date is used to generate overdue
violations, so it should be a reasonable date within the scope of the project.

Example

This example shows the Edit Request window with only the required fields entered.
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4. Use the remaining fields at the top of the Edit Request window to specify how the request should
be fulfilled.

Selections in the following fields are not required; however, you can use them to set specifications
for your request and tie the request to your company's structure and processes:

• Data Center is the name of the data center where the new capacity is required. The menu
selections list your company's data center names entered into the OnCommand Insight
annotations.

• Business Entity is a tenant, line of business, business unit, and project selected from a list of
business entities defined in OnCommand Insight. Business entity is formatted in the drop-
down menu as <tenant>.<line of business>.<business unit>.<project>.

• Owner is the name or title of the person responsible for fulfilling this request.

• Email is the address used to send email notifications to the requester relating to this request.

• SAN is a list of the annotations defining specific devices in your storage environment.
Selecting specific SAN devices restricts reservations for this request to those devices.

Note: If no items are listed, the predefined SAN annotation was not set up in your
OnCommand Insight environment.

• Ticket is a code that your company uses to track capacity requests.

• Creation Date is the date the request is generated. This field is filled automatically.

After you finish

In the Edit Request window, click the Targets tab to specify the device for this request.

Request details in reports

Information about requests is sent to OnCommand Insight Data Warehouse. You can generate
predesigned reports or create your own reports using the reporting engine.

For example, capacity that has been requested is marked as "requested." This information is sent to
Data Warehouse where it can be included in reports to show how much capacity has been requested
as compared to how much is actually used.

Only requests for capacity and ports are sent to Data Warehouse for reporting. Information about
reservations is not sent to Data Warehouse.
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Selecting targets for storage requests

You need to indicate whether the storage request you are defining requires a new or an existing host
or is simply reserving space as it would for a planned migration.

Before you begin

You must first enter the basic request information at the top of the Edit Request window before
entering the specifications for your request in the Targets and Requirements tabbed areas.

Steps

1. In the Edit Request window, click the Targets tab.

2. Select one of these options:

• Hosts indicates that you are requesting additional capacity in existing or new hosts.

• Other specifies that this request is for general SAN resources not associated with specific
hosts—perhaps to reserve space for a migration planned for a later date, but independent of
hosts using the data. If you select this option, no other information is required to complete this
request.

3. If you selected Hosts, click one of these buttons and select the hosts for this request:

• Add Existing allows you to choose an existing host from a list of all of the hosts
OnCommand Insight currently monitors.

• Add by App allows you to choose an existing host by the applications that run on it.

• Add New allows you to add a host that has not yet been brought online and monitored by
OnCommand Insight.

Example

In this example, the Add by App option located four hosts that are currently running the selected
application.
 

 

4. After selecting the targets, click OK to add the host information.
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After you finish

If you specified host targets, click the Requirements tab to define your LUN and switch port
requirements.

Defining storage request requirements

If you selected host targets for your capacity request, the requirements for those hosts must also be
specified. You can specify required switch ports, the number of LUNs, the size of each LUN, and the
level of service.

Before you begin

A storage request must be created with the target hosts specified.

Steps

1. To open add requirements through the OnCommand Insight Client, select Planning > Requests.

2. In the Requests list, right-click on the request to which you want to add requirements and select
Edit Request or select Action > Edit Request.

3. Check the information in the request to be certain you are working with the request you wanted.

4. Click the Requirements tab and click the buttons to describe your hosts:

• Add LUNs allows you to enter the number of LUNs you need and the size of each LUN in
GB and to select the tier describing the level of service required. Best practice: In the Notes
area, describe your LUN requirements to be certain the administrator understands your LUN
requests. Click OK to save these selections in the request.

Note: If you need LUNs with different requirements to fulfill the request, enter one LUN
type in the fields and click OK to save it. Then click Add LUNs again to enter the other
type of LUN. For example, you might need LUNs required in two tier types, so each tier
has a separate entry in the request.

• Add Ports allows you to enter the total number of ports you need for the LUNs you
requested. Best practice: In the Notes area, describe how the ports should be assigned to the
groups of LUNs requested. Click OK to save these selections in the request.

5. When you are satisfied with the descriptions of the requirements, click the OK to save the
request.

At this point, the Estimated Cost for each of your LUN and switch port requirements might be
listed on the Edit Request window. If no costs are calculated and you want them to be, select
Tools > Settings and the Cost Accounting option to enter the correct values.

After you finish

The storage administrator needs to research the best way to fulfill the request and reserve the
necessary resources.

Submitting requests through the Web-based portal
System administrators who are not using OnCommand Insight can submit capacity requests through
the Web-based Request Portal to be managed in OnCommand Insight.

Steps

1. Log into the Request Portal using your OnCommand Insight host IP name in this URL:
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http://<hostName>/request-home/index.do

2. Click the Request Capacity link to display the Capacity Request form, as shown here:

 

 

3. You must fill in these fields, highlighted in yellow, to create a valid request:

• Request Name is the title of this request to make it easier to locate in the list of requests.

• Requester is your name.

• e-mail is your office e-mail address so that you can receive notifications about the request.

• Due Date is the date when you must have this request fulfilled.

4. From this point, you can complete the request by entering host target and requirements at the
bottom of the window. These selections have the same names and functions used to enter a
request through the OnCommand Insight Client. See the "Selecting request targets" and "Defining
storage request requirements" for specific instructions.
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Note: You cannot edit an existing request through the Request Portal. If a revision or change is
required, the requester needs to contact the administrator or use the OnCommand Insight
Client.

After you finish

Because reservations cannot be entered using the Request Portal, the SAN administrator must make
the reservations for your request using the OnCommand Insight Client.

Updating your Request Portal user name and password

If as the system administrator, you use both external Request Portal and the OnCommand Insight
system to work on storage requests, and you changed your user name or password in the
OnCommand Insight system User Management, you must manually change the same information in
the Request Portal configuration file.

Steps

1. Navigate to the configuration file:

<OnCommand Insight install dir>\conf\request-portal-default-config.xml

2. In the following section of the configuration file, change the username and password attributes to
match what you entered in the OnCommand Insight User Management:

<APIConnection>

<Server name="localhost" host="https://localhost:443/
OnCommandInsightapi" username="guest" password=" " />

</APIConnection>

Reservations
Reservations allow you to manage the space allocations of various resources from multiple arrays or
fabrics. The use of reservations prevents unavailable or inaccurate information from impacting the
SAN, prevents service interruptions, and protects resources that were previously reserved.

Reservation requirements ensure that reservations are set properly. Reservations are checked against
the reservation requirements to ensure there is no violation with the reservation. For example, if you
set a reservation requirement of tier Gold on a volume of tier Silver, a violation would occur. If a
reservation requirement is violated, the reservation must be deleted or edited.

Making storage reservations

The reservation process helps you to define the space allocation of different storage resources from
multiple arrays or fabrics and prevents unavailable or inaccurate information from impacting the
SAN. You can only make storage reservations through the OnCommand Insight Client.

Before you begin

In order to make resource reservations, you should check the capacity request to be certain it contains
this information:

• Request description and due date.

• List of hosts to be used for this request.
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• LUN and port requirements.

Steps

1. From the OnCommand Insight Client, select Planning > Requests.

2. In the Requests view, right-click the request to make reservations and select Edit Request.

3. If it is not already displayed, click the Requirements tab to see a summary of the request
requirements.

The requirements summary might include the estimated cost for the requests. In this example, the
requester is asking for more capacity for two tiers.
 

 

4. Check the Note column for any additional information about the request.

5. Click the Reservations tab.

6. To begin reserving resources, highlight a LUN or switch port requirement and click Add to select
the volumes, capacity, or ports options.

Result

OnCommand Insight lists all of the required physical tasks in the Pending Requests view. A check
mark displays before the resources indicating which requirements have been satisfied. The Pending
requests remain pending until they are physically implemented using native storage tools.
OnCommand Insight updates pending requests as it detects the required changes during normal data
collection.

Reserving a path to fulfill requirements

Based on automated recommendations, you can quickly select a volume and port to reserve storage
arrays.

Before you begin

The Edit Reservations dialog box must be open and the request requirements entered.
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Steps

1. Click the Reservations tab.

2. Select one of the requirements and click the Add.

3. Select the Reserve Path option and click OK.

Based on your previous selections, the list of possible storage arrays opens and the lists of
volumes and FC ports for those arrays open below.

4. Scroll through the list of storage arrays to locate recommended arrays. They are marked with a
gold star in the first column.

5. Select a storage array and then select recommended volumes and FC ports below.

6. Click OK.

Reserving storage pools to fulfill requirements

Based on automated recommendations, you can quickly select a storage pool to reserve capacity.

Before you begin

The Edit Reservations dialog box must be open and the request requirements entered.

Steps

1. Click the Reservations tab.

2. Select one of the requirements and click the Add.

3. Select the Reserve Capacity on Storage Pool (s) option and click OK.

Based on your previous selections, the list of possible storage arrays opens, and the lists of
storage pools for those arrays open below that.

4. Scroll through the list of storage arrays to locate recommended arrays. They are marked with a
gold star in the first column.

5. Select a storage array and then select one of the recommended storage pools below it.

6. Click OK.

Reserving volumes to fulfill requirements

You can reserve space from multiple arrays or fabrics to fulfill requirements. OnCommand Insight
lists all of the available storage arrays in the environment and then removes reserved volumes from
the list of available volumes.

Steps

1. In the Reservations section of the Edit Request window, select one of the LUN requirements
and click Add.

2. Select the New Volumes option to show the available storage arrays and volumes. Both sections
are shown in the Add Reservation dialog box.
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3. Select a storage array that meets the location criteria of the requirement and examine the available
volumes listed below. If no volumes are available for that array, no volumes are listed.

Note: The requirement you are fulfilling is displayed at the top of the window.

4. Select a volume name check box to reserve it.

5. Click OK to save the reserved volumes.

Result

The reserved volumes are removed from the list.

Fulfilling capacity requirements with general storage

If you want to reserve general storage capacity to fulfill a request requirement, you can select one or
more appropriate LUNs from the list of storage arrays.

Steps

1. In the Reservations tab of the Edit Request window, select one of the LUN requirements and
click Add.

2. Select the New Capacity option.

3. Examine the list of storage arrays to find a LUN with available capacity at the requested service
level.

4. Select the check box next to the appropriate storage array and enter the number of GBs in the
field at the top of the window.

Note: The requirement is listed at the top of the window so that you know what is needed.
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5. Click OK to save this reservation.

Adding general resources

If you want to add overall resources for a request, use the General Reservations to reserve volumes,
capacity, or ports as part of the overall reservation description. For example, when you make
requirements for the switch ports, you may need to set up an ISL.

Steps

1. From the OnCommand Insight Client, select Planning > Requests.

2. In the Requests view, right-click the request for which you want to make reservations and select
Edit Request.

3. On the Reservations tab list, select the General Reservations item in the list and click Add.

4. Use any of these options to add overall resources to help fulfill this request:

• New Volume(s) allocates specific free volumes for this request.

• New Capacity allocates general capacity on storage for this request.

• New Port(s) allocates switch ports for the LUNs selected with the New Volumes and New
Capacity options.

5. Click OK on the Add Reservation dialog box and return to the Edit Request window.

Verifying requirements

After you have reserved LUN and port resources, you can verify that the requirements are satisfied.

Steps

1. In the Reservations tab, look at the Satisfied column beside the individual resource selections.

2. If a reserved resource satisfies a requirement, a green check is displayed in this column, as shown
in this example. If the entire set of requirements is satisfied, a check is displayed for the request
node at the top of the tree.
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After you finish

Reservations that satisfy requirements might still create violations within the environment, so you
must also check for violations and make any required corrections in your reservations.

Reserving switch ports

You need to fulfill the port requirements described in the request.

Before you begin

If you have requirements for more than one type of LUN, be certain that you know how many ports
are to be assigned to each LUN type you reserve. That information was provided in the note attached
to the port requirement.

Steps

1. Select the port requirement in the Reservations tab. Click Add.

2. Select the switch to be used and check off the specific FC ports displayed below the switches in a
detail view.

3. Click OK.

After the volumes and ports have been reserved successfully, the Reservations tab shows green
arrows beside the requirements.

4. Check the Reservation Violations to be certain that the reservations have not violated any policies.

Reservation notes

You might want to add notes about the reservation decisions you made to fulfill a request. These
notes help anyone checking the request to see the reservation progress.

In the Edit Request window, click the Notes tab and enter information in these areas:

• Description is a summary of information in the note.

• Comments usually explains the research behind the reservation decisions.

• Justification provides the reason for making reservations that might be contrary to the requester's
choices. Some companies require all allocation decisions to include a justification.
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Managing requests

Requests for capacity and ports remain in OnCommand Insight unless they are removed. You can edit
requests, view all pending requests, check violations on them, and cancel requests. With the history
of capacity requests, you can project future allocation and identify a time when you will run out of
storage for a specific tier or data center.

You can do the following tasks related to managing requests:

• Check the status of the request.

• Identify any violations related to the request and correct them.

• Verify whether the request has been fulfilled and the physical changes have been made in your
storage environment and mark the request as completed.

• Project future allocation based on the history of capacity requests and estimate when you will run
out of storage.

• Cancel a request.

• Remove the request from the system.

Checking the status of pending requests
You can check the status of incomplete requests using the Pending Tasks view. You might want to do
this to see if changes were made to the physical setup of the equipment at the data center. After
changes occur to the physical setup of the equipment, OnCommand Insight updates pending requests
as it detects the required changes during normal data collection. Then, the request is complete and no
longer appears in the Pending Tasks view.

Before you begin

The request must have been created and storage resources must have been reserved using the
OnCommand Insight Requests and Reservations options (either in the Client or in the Request
Portal).

About this task

Reservations are complete when there is a corresponding change to the physical setup of the
equipment at the data center. After the physical setup of the disk shelves and storage systems occurs,
the reservation is complete and disappears from the Pending Tasks view.

Steps

1. From the OnCommand Insight Client, select Planning > Pending Tasks.

All pending reservations appear.
 

 

2. In the Pending Tasks view, sort the requests either by Request Ticket or Requester to see your
requests.
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Checking violations and making corrections
If there are issues with a request, if it is overdue, or if it violates specific policies, OnCommand
Insight displays those violations. For example, if a device is over-utilized, scheduled to come off
lease, or subject to a tier conflict, OnCommand Insight detects these violations. You can look at the
violations and determine the next course of action.

Steps

1. From the OnCommand Insight Client, select Planning > Requests.

 

 

2. In the Reservations detail view, select the request.

3. To view all of the reservations associated with a request, click the Reservations icon on the icon
toolbar below the detail views.

The Reservations detail view shows the reservations associated with the request.

4. Click the Reservation Violations icon on the icon toolbar.

The Reservations Violations detail view displays the violations associated with the request.
 

 

5. Do one of the following:

• If there are reservation violations, return to the Reservations tab, delete the reservations on the
ports or volumes, and select different ports or volumes for the reservation.

• If there are request overdue violations, check on the fulfillment of the reservation to ensure
that the change has occurred to the physical equipment.

• If there is a tier conflict, edit the request to select a resource that matches the tier requested.

• If a device is over-utilized or scheduled to come off of its lease, edit the request to select
another resource.

Verifying fulfillment of requests for storage resources or
ports

After you enter a request and reserve storage resources or ports, you can verify that requests have
been fulfilled in your storage environment. You might want to do this to complete the cycle of
requests, requirements, and reservations.

About this task

After changes occur to the physical setup of the equipment, OnCommand Insight updates pending
requests as it detects the required changes during normal data collection. Then, the request is
complete and no longer appears in the Pending Tasks view. In the Requests view, the Status field
automatically changes from Reserved to Allocated.
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After the physical changes have been made and you have verified them, you should change the
Request State to Complete.

Steps

1. From the OnCommand Insight Client, select Planning > Requests.

At this point all configurations have been set and storage is available to the host. OnCommand
Insight obtains this information during its regular data collection process.
 

 

2. In the Requests view, select the request and verify that the Request Status shows "Allocated."

3. In the Requests view, change the Request State to Completed by doing the following:

a. Right-click on the request.

b. Select Set Request State > Completed.

4. To view all of the reservations associated with a request, click the Reservations icon.

The Reservations detail view shows the reservations associated with the request.

Projecting future allocation needs
The Storage Capacity Planning by Timeframe report projects the future allocation needs based on the
history of your past capacity requests. Using this report, you can identify an estimated time when you
will run out of storage for a specific tier and data center.

About this task

You can make requests for system resources and later you can fulfill these requests by submitting a
reservation for those resources. The status and validity of requests is recorded using these
designations:

• New

• Not Yet Reserved

• Reserved

• Canceled

• Rejected

OnCommand Insight tracks these requests as they proceed from initial submission to selection of the
desired resources, and finally to the successful allocation of those resources.

Steps

1. Access the Reporting Portal.

2. Do one of the following:

• Select the Detailed Reports tab. Scroll to the Capacity Storage Reports section. You might
need to go to the additional pages to see more reports.
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• Select the Public Folders tab. Click the Storage Capacity link. Click the Dashboards link.
Select the Capacity Storage Reports folder. Click the Storage Capacity Planning by
Timeframe link.

Sample report

 

 

Cancelling a request
You can cancel requests even after they have been reserved. Canceling a request will de-allocate
reserved storage or ports. If a request was partially or fully implemented or reserved and resources
are no longer needed, cancelling can prevent orphan capacity reservations.

About this task

If you receive a message to cancel a request that has already been allocated because the resources are
no longer needed, you can de-allocate the reservation. If you cancel the request, changes must be
made to the physical equipment as well, which is done external to OnCommand Insight.

If you cancel a request and subsequently re-open it, the Request State changes to Open.

Steps

1. From the OnCommand Insight Client, select Planning > Requests.

2. In the Requests view, right-click on a request and select Create Request > Set Request State >
Cancelled or from the Action menu, select Set Request State > Cancelled.

The Requests view displays Cancelled in the State column.

3. In the Status bar, click the Reservations Violation icon.
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4. In the Reservations Violations detail view, note any allocated resources on the cancelled request.
Do one of the following:

• If no reservations have been allocated, consider the request successfully cancelled.

• If reservations have been allocated, edit the reservation and remove the assigned resources.

Note: If you want to delete a request completely, follow the "Removing a request from the
system" steps.

Removing requests from the system
Typically, requests for capacity or switch ports remain in the system. Information about these
requests are used in reports. However, you might need to remove a request. If you remove a request,
all reserved resources are also removed and are now available for others to use.

Before you begin

The request must already have been cancelled and "Cancelled" must appear in the State column on
the Requests view.

Steps

1. From the OnCommand Insight Client, select Planning > Requests.

2. In the Requests view, right-click on a request and select Remove Request or from the Action
menu, select Remove Request.

3. In the confirmation message, click Yes.
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Requests reference

This section describes the views displaying data relating to capacity requests.

Pending Tasks view
After a request is entered and the resources are reserved, the physical tasks associated with the
request are listed in the Pending Task view. OnCommand Insight updates pending requests as it
detects the required changes during normal data collection.

Navigation

From the OnCommand Insight Open menu, select Planning > Pending Tasks.

Column descriptions

If a task is shown in red in this view, there is a violation associated with it.

Task

Indicates the action required such as Allocate.

Type

Indicates what resource is being acted upon such as a Port or Volume.

Description

System identifier of the resource to be used to locate it for the physical change that is
required in the task.

Request

Title of this request defined by the requester.

Request Ticket

Identifying code defined by your company to be used to track capacity requests.

Request Target

Indicates the type of resource for which the request is made such as a Host.

Requester

Name or job title of the person submitting this request.

Owner

Name or job title of the person responsible for fulfilling this request.

Due Date

Date by which the request needs to be fulfilled.

Requests view
The Requests view lists all of the active capacity requests being processed and completed or
cancelled requests displayed for a set length of time. To view all of the reservations associated with a
request, select the request in this list and click the Reservations icon.

Navigation

From the OnCommand Insight Open menu, select Planning > Requests.
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Column descriptions

Click the icon in the upper right corner of this view to list only the New and Open requests.

Violations

Warnings that resources selected to fulfill a request are not the best choice in the
environment.

Name

Title of this request defined by the requester.

Ticket

Identifying code defined by your company to be used to track capacity requests.

Description

Information the requester entered to describe the request in more detail.

Requester

Name or job title of the person submitting this request.

Owner

Name or job title of the person responsible for fulfilling this request.

Due Date

Date by which the request needs to be fulfilled.

Creation Date

Date that the request was submitted.

State

Indicates the administrative condition of the request as Open, Rejected, Cancelled, or
Complete. You must manually change the state from Open to one of the other states using
the Set Request State option on the right-click menu.

Status

Indicates if the reservations were made for the requirements. If all of the requirements are
fulfilled with reservations, the status of the request is "Reserved." If no reservations or too
few reservations to fulfill the requirements were made, the status of the request is
"Incomplete." The status changes automatically from Reserved to Allocated when the
reservations are implemented in the physical equipment.

Completion Date

Indicates when data collection identified that the request was physically fulfilled.

Reservations view
To display the reservations for a specific request, you can examine the Reservations tab in the request
or use the Reservations view.

Navigation

From the OnCommand Insight Open menu, select Planning > Requests. Select a request in the
Requests view and click the Reservations icon to display the list of reservations for that request.

Column description

Complete

Displays a check mark to indicate that the reservation is complete. Reservations are
complete when there is a corresponding physical setup of the equipment at the data center.
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Type

Indicate whether the reservation is for a Port or a Volume.

Description

Specifies the port or volume that was selected for the reservation.

Creation Date

Date that the request was submitted.

Reservation Violations view
From the Reservation Violations view, the storage administrator investigates the different reservation-
related violations, identifies the problems, and makes corrections using the Planning features.

Navigation

From the OnCommand Insight Open menu, select Assurance > Reservation Violations.

Column descriptions

blank

Applicable with any presentation order other than No Grouping. Column that organizes
the data according to the selected grouping format.

Violation

Indicates the type of violation on the reservation. It can be Error, Warning, or Info.

Type

Identifies the resource problem generating the violation of the reservation.

Details

Additional information about the resource problem.

Request

Name of the resource reservation entered on the ticket.

Request Ticket

Code identifying the request in the system.

Device Type

The system element that has caused the request violation.

Device

Description of the system element that has caused the request violation.

Since

When the violation was identified.

annotations

User-defined terminology associated with the reservation violations including Violation
Severity and Note.
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Task planning

OnCommand Insight Plan helps you create plans to implement changes in your Fibre Channel
environment including consolidation and migration projects.

SAN change-management, when performed in the production environment, is a major contributor to
application downtime (planned and unplanned). Change-management processes require validation to
assure application availability and to maintain a validated SAN at all times.

Using the OnCommand Insight Plan planning capabilities, you can minimize application downtime.
You can simulate your plan to understand its effect on your service-level policies and validate
planned changes before executing your plan.

When a plan is implemented, OnCommand Insight checks the storage environment to find completed
tasks and note any incorrectly implemented tasks.

Creating a change plan
A change plan comprises a step-by-step set of distinct tasks to manage complex changes in your
Fibre Channel environment. Each change plan includes a series of ordered tasks required to complete
the project. Each task provides a work order for an employee to perform a specific SAN change.

Before you begin

To prepare for a new project, assemble a list of all of the changes needed for the operation. You might
want to record them in an Excel spreadsheet.

Steps

1. Create the change plan using the OnCommand Insight templates, imported tasks from Excel, or
adding individual tasks.

Note: The templates provide a convenient way to define the repetitive tasks required to add
storage to a host or to decommission a host.

2. To assist the network and storage engineers performing the tasks, you might add examples to
illustrate specific operations.

3. Use OnCommand Insight to pre-validate each task in the plan.

4. Change the plan State from Planning to Implementation.

This action switches on the OnCommand Insight tracking mechanism.

5. Generate task-validation reports and distribute them by email or as a hard copy to the network and
storage engineers, who are going to perform the tasks.

The engineers make the necessary changes using the vendor-specific tools available for your
SAN.

6. Check OnCommand Insight for the status of the tasks in the plan. (OnCommand Insight
automatically checks your environment for changes listed in the plan and notes whether they were
completed or performed incorrectly.)

7. Locate any deviations from the plan and resolve them.

8. Discover any violations and then investigate and resolve them.
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9. When all of the tasks have been successfully completed, change the plan State from
Implementation to Completed.

Starting a plan

You might use any of these methods to start a change plan for your Fibre Channel environment.

About this task

• Using a OnCommand Insight template to create a predefined plan for adding storage to host or
decommissioning a host.

• Importing task definitions from an Excel spreadsheet.

• Add an individual task as the starting point.

Steps

1. From the OnCommand Insight Open menu, select Planning > Plans and do not select any of the
existing plans.

2. In an empty area of the Task list main view, right click and select Templates and one of the two
predefined plans for adding storage to host or decommissioning a host or select Add Tasks From
Excel and select the file to import or select Task > Add task.

Importing tasks from a spreadsheet

You might want to import tasks into the OnCommand Insight plan from a spreadsheet. This is useful
to manage mass migrations. For example, if you add many new hosts weekly, the Excel-formatted
table allows you to import a list of corresponding tasks quickly.

Before you begin

Create an Excel spreadsheet listing specific tasks for a plan.

Steps

1. From the OnCommand Insight Open menu, select Planning > Plans.

2. To initiate the task import from a spreadsheet, right click on the Task list and select Add Tasks
From Excel.

3. Select the spreadsheet to import and click Open.

OnCommand Insight imports the task data, following these rules:

• Create a new task for each task that was not previously imported using the same Reference ID
(from a file with the same B1-B3 file-identifying data).

• Include in the same task all rows with the same reference number.

The import then generates the following action(s) for each new task, as appropriate:

• Add Host

• Add Hosts to Application

• Add HBA to Host

• Add Volume

• Add Volume Map
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• Add Volume Mask

• Add Zone

• Add Zone Member

• Connect Ports

• Authorize Path

4. In the event of an error (that is, a violation of one or more field constraints), OnCommand Insight
generates a report.

Each line in the report identifies the exact row in the spreadsheet that caused the violation. No
single error stops the validation process, so the error report provides a complete list of errors for
the file.

Guidelines for importing tasks

You can import tasks from a Microsoft Office Excel spreadsheet to have OnCommand Insight
generate tasks and actions based on them.

Each task must relate to a single host device and a single storage device (but the storage can have
multiple volumes). All lines with the same Ref number relate to the same task.

You can import the following types of tasks or operations:

• Add Host
Adds a new host, and then adds a path from that host to disk storage. The task name is generated
as Add new host host-name(host IP) to Storage storage-name.

• Add Storage to Host
Adds a new path from an existing host to disk storage. The task name is generated as Add storage
storage-name to host host-name(host IP).

• Add Tape
Adds a new path from an existing host to tape storage. The task name is generated as Add Tape
storage-name to host host-name(host IP)

• Host Decommission
Decommissions a host from the SAN.

The switches and storage devices referenced by the task must exist before tasks can be imported from
a spreadsheet; however, the Add Host and Add Storage to Host operations can add new volumes.

Spreadsheet format required for importing tasks

When you import a spreadsheet file, it must contain certain fields in B1, B2, and B3, respectively.
These fields serve to identify the file, and must be unique across all task-import files.

• Date, in mm/dd/yy format (09/30/10)

• Time, in hh:mm am/pm format (09:50 am)

• Name of the submitter (free-form text)

The rest of the file contains one line for each task or action being added or updated, as follows. Fields
are listed below moving left to right, starting with column A. All fields are required unless otherwise
noted below:

Field Description
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Ref Reference number for the task/project as it appears in the change ticketing/help
desk system, or any other number that identifies the change. Note: When the Ref
number displays in the main Task list, it shows up as the concatenation of this value
plus the task's objid. Use the same reference number on all rows (actions) that apply
for the same task. All lines with the same Ref value relate to a single host and
storage device.

By Name of the person in charge of completing the task. Include only in the first line
for the task (that is, with the first line that includes the task Ref number).

Ticket# Optional. Number of the task/project as it appears in the change ticketing/help desk
system or any other number that identifies the change.

Operation One of the following to identify the task action:

• Add Host

• Add Storage to Host

• Add Tape

• Host Decommission

For this type of operation, the only required fields (in addition to the identifying
information, Ref , By and Ticket# ) are the Host Name and Host IP. All other fields
are ignored.

Host Name Target host for the task, identified by name. Must be the same for all lines having
the same Ref number, or must appear in only the first line for a particular Ref.

Host IP Target host for the task, identified by IP address. Must be the same for all lines
having the same Ref number, or must appear in only the first line for a particular
Ref.

Adapter World Wide Name for the HBA adapter.

HBA
WWPN

World Wide Port Name of the HBA adapter. Must comply with one of these WWN
formats:

• hh : hh : hh : hh : hh : hh : hh : hh

• hh hh hh hh hh hh hh hh

• hhhhhhhhhhhhhhhh

Where h is a single (case-insensitive) hexadecimal digit.

HBA
Switch

Name or WWN to identify an existing switch that's connected (or will connect) to
the HBA.

HBA Port Switch port that is connected (or will connect) to the HBA port, formatted as: <
unique switch name >/< port number > Where the < unique switch name > provides
enough characters to uniquely identify the switch port. For example: R1-FabricA-
shelf1/21 The referenced switch port must exist already in the SAN. If the identifier
is not unique, the row will be excluded and an error message generated.

Fabric Optional. Fabric/VSAN where the HBA and storage port are connected (must exist
already in the SAN).

Storage/
Frame

Optional. Name of the existing storage device (only one per Ref number). You must
provide either the entire name, or enough of the name to uniquely identify the
storage device. If the name is not unique (so equally identifies two or more storage
devices), the row is excluded and an error message generated.
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Storage ID ID of the existing storage device (for example, Symmetrix serial number). You may
specify only one storage ID per Ref number.

FA specific device created for a customer Optional. Name of the existing FA for the
path. Must exist already in the SAN.

FA WWN WWN of the existing FA port (that is, storage controller).

FA SW Name or WWN to identify an existing switch that's connected (or will connect) to
the storage port.

FA Port Number of the existing switch port that's connected (or will connect) to the storage
port, formatted as: < unique switch name >/< port number > Where the < unique
switch name > provides enough characters to uniquely identify the switch port. The
referenced switch port must exist already in the SAN. If the identifier is not unique,
the row will be excluded and an error message generated.

Zone Name Name of the zone for the HBA and storage port.

Volumes Comma-separated list of volumes in the path (ALL for a simple disk device or a
tape). Do not include ranges (that is, use 00a, 00b, 00c, 00d instead of 00a..00d).
Must be the same for all lines having the same Ref number, or must appear in only
the first line for a particular Ref.

Application Applicable when the host is assigned to one or more applications. Application(s)
with which the host is associated (required when you specify the Volume Sharing).

Redundancy Desired redundancy level for the new path (Dual Fabric or DF), No SPF (or NS), or
None).

Host Ports Optional. Maximum number of host ports that can access the storage (tape device or
volume referenced by the task). Include only in the first line for the task (that is,
with the first line that includes the task Ref number).

Switch
Hops

Maximum number of switch devices the new path should traverses from host to
storage. Include only in the first line for the task (that is, with the first line that
includes the task Ref number).

Volume
Sharing

Optional. Level of volume sharing permitted by the host, as specified by the policy
(Any , No Sharing, or Application). If you specify this field, you must specify the
Application field as well.

Start Date Starting date for the task, specified in a field defined as having a Date format in the
spreadsheet. Include only in the first line for the task (that is, with the first line that
includes the task Ref number).

Start Time Starting time for the task, specified in a field defined as having a Time format in the
spreadsheet. Include only in the first line for the task (that is, with the first line that
includes the task Ref number).

End Date Ending date for the task, formatted as described for the Start Date, above. Include
only in the first line for the task (that is, with the first line that includes the task Ref
number).

End Time Ending time for the task, formatted as described for the Start Time, above. Include
only in the first line for the task (that is, with the first line that includes the task Ref
number).

Comments Optional. Text field, available for free-form comments. Include only in the first line
for the task (that is, with the first line that includes the task Ref number).
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Updating tasks in a spreadsheet

An imported spreadsheet task file can be used to update or delete task data.

Steps

1. To update tasks, modify the spreadsheet that was originally used to add tasks.

2. Import that spreadsheet again to update the changed tasks.

Note: Be certain that the identifying information in fields B1 - B3 are identical to the
information in the original file.

This method can also be used to delete task data by removing the task data and re-importing the
spreadsheet.

After you finish

OnCommand Insight imports the changed task data using the following rules:

• Delete tasks that were previously imported from a file with the same B1-B3 file-identifying data,
but that are missing from the current file.

• Modify (meaning, redefine) tasks that were previously imported from a file with the same B1-B3
file-identifying data, and that are also included in the current file.

• Include in the same task all rows with the same reference number.

Adding tasks

Each plan is composed of one or more tasks, which are in turn each composed of one or more
actions. If you want to create a task in an existing plan, select the plan in the Task List and use the
Add Task option.

About this task

The Task List displays your defined plans, in the order in which they were specified.

Steps

1. From the OnCommand Insight Open menu, select Planning > Plans.

The Task List main view opens.

2. To add the task to an existing plan, select that plan in the list.

3. Right click and select Task > Add task.

4. Define the task including a specific task name, any dependency, and the start and end dates.

5. Click OK.

The task becomes part of the selected plan. If you need to edit or delete it, select the appropriate
option from the Task menu.
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Pre-validating tasks

Pre-validating the plan tasks allows you to predict the violations that will be generated upon
completion of the task or to identify conflicts with other tasks related to volume allocations.

Steps

1. Use the drop-down menu to pre-validate the integrity of the task manually. With the task selected,
right-click Validate Task.

OnCommand Insight pre-validates the task and refreshes the Plans view. The first indication of
the validation status is visible through the color of the corresponding row in the Task List: Review
the Pre-Validation column in the Task List to see the validation results: Failed indicates a failure
and Passed indicates a successful task validation.

• Red indicates that if the task were performed, new violations would be introduced to the SAN.

• Blue indicates that implementation of the task would not result in a new violation.

2. Use the Future Violations detail view to review future task violations. As necessary, analyze
these violations using the Analyze Violation tool from the right-click menu. This tool only works
on a single path, so expand (+) the Future Violations list to display each path you want to analyze.

3. Use the Errors detail view to look for action-related errors. Each error listed has an identifying
action number to the left, which ties it to the Actions-list step number (#).

4. Use the Future Changes detail view to review actions that have not yet been implemented,
including future violations those actions will create.

5. Generate a Task Pre-Validation report and share the URL with other OnCommand Insight users to
share the task, actions, and completion status with those users.

Adding actions to the plan

The available action types are predefined, and each type of action requires that specific data be
supplied in order that OnCommand Insight can pre-validate the effects of the action on your existing
SAN.

About this task

For example, when the action requires the addition of a storage controller, you need to provide the
number of ports on the new controller, its name, and the name, and IP address of the storage device
where it will be installed.

To add predefined actions to tasks, follow these steps:

Steps

1. From the OnCommand Insight Open menu, select Planning > Plans.

2. Select a plan in the list.

3. Click the Task Actions icon to display the Action detail view.

4. Position your cursor in the empty area of the Action detail view and right click.

5. Select Add action and select one of the predefined actions from the pull-down menu.

Each action type includes features to implement the action easily in the plan.

• Parameters - used to configure the action including variables.
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• Validating - information on how OnCommand Insight tracks the action.

• Prerequisites - requirements that must be fulfilled before the action can be evaluated during
task pre-validation.

• Implicit actions - additional activities that occur when the action is include in a plan.

This example shows the Task List with the Task Action detail view below.

 

 

Action types in plans

Tasks can include different types of actions.

Each action type includes features to implement the action easily in the plan. Each device entered
into the action parameters must be defined in OnCommand Insight, either as part of the SAN
environment, previously in the current task, or in a task that is executed before the current task (that
is, a task on which the current task depends).

Action Type Description

Add Controller to
Storage

Add a new port controller to an existing storage array with these parameters:

• # of Ports - Number of ports on the controller. Click Add once for each
port, and then specify the WWN for that port. Click Remove to delete a
selected port.

• Controller - World Wide Name (WWN) for the controller.

• Storage name (IP) - Storage array for which you are adding the controller,
identified by name and IP address. Select the device from the list of
available devices.

If the controller was removed and is now being added (all in the same task),
this action restores the controller's ports, port connectivity, volumes, and
volume mapping/masking.
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Add Controller to
Tape

Add a new controller to an existing tape device with these parameters:

• # of Ports - Number of ports on the controller. Click Add once for each
port, then specify the WWN for that port. Click Remove to delete a
selected port.

• Controller - World Wide Name (WWN) for the controller.

• Tape name (IP) - Tape device for which you are adding the controller,
identified by name and IP address. Select the device from the list of
available devices.

If the controller was removed and is now being added (all in the same task),
this action restores the controller's ports and port connectivity.

Add HBA to Host Add a new host bus adapter (HBA) to an existing host with these parameters:

• # of Ports - Number of ports on the HBA. Click Add once for each port,
then specify the WWN for that port. Click Remove to delete a selected
port.

• HBA Adapter -World Wide Name (WWN) for the HBA adapter.

• Host name - Host where you are adding the HBA, identified by name and
IP address. Select the host device from the list of available devices.

If the HBA was removed and is now being added (all in the same task), this
action restores the host's ports, port connectivity, volumes, and volume
mapping/masking.

Add Host Add a new host using this parameter:

• Host name (IP) - Name and IP address to identify the host. You'll be
prompted to enter these values separately.

If the host was removed and is now being added (all in the same task), this
action restores all the host's ports, port connectivity, volumes, and volume
mapping/masking.

Add Hosts to
Application

Adds one or more selected hosts to an application group, optionally defining
a new application group for this purpose with these parameters:

• Hosts - Name to identify the hosts being added. Select one or more hosts
from the list of available hosts.

• Application - Application to which the selected hosts should be assigned.
Choose an existing application from the drop-down list, or enter a name
to define a new application.

Add Ports to
VSAN

Add one or more ports on a Cisco switch to a virtual SAN (VSAN) with
these parameters:

• # of ports - Number of switch ports being added to the VSAN. Select one
or more ports from the list of available switch ports.

• Switch name - Name of the switch whose ports are being added (filled in
automatically after you select the ports, above).

• VSAN - VSAN to which you are adding the new ports. Select a VSAN
from the list of fabric/VSANs.
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Add Storage Add a new storage array using this parameter:

• Storage name (IP) - Name and IP address to identify the array.

If the storage array was removed and is now being added (all in the same
task), this action restores all the device's ports, port connectivity, volumes,
and volume mapping/masking.

Add Switch Add a new switch. If you plan to generate blade/ports (for switch cards),
specify the switch parameter first because this information is required for
port generation. If you plan to generate blade/ports (for switch cards), specify
the Switch parameter first, because this information is required for port
generation. You can use these parameters:

• # of ports - Number of blades/ports on the switch. Click the appropriate
tab to identify the switch ports individually.
Blades (to add switch cards) - click Add once for each blade on the
switch and then fill in the unique numeric blade number and the number
of ports per blade.
Ports - click Add once for each port on the switch and then fill in the
WWN to identify each port. If you identified the switch already,
OnCommand Insight pre-fills each port WWN with the WWN of the
switch, followed by a dash and a port number. Click Generate to
automatically add the ports for each blade. OnCommand Insight
calculates the ports based on the switch WWN and blade numbers,
assigning each blade port a unique WWN.

Note: You must enter the switch name and WWN before generating
ports.

• Switch - Name and WWN to identify the switch being added and an
indication of whether the switch is VSAN-enabled. If enabled (checked),
the policy is determined by the VSAN, and you can add switches (Add
VSAN action) then switch ports (Add Ports to VSAN action). Once you
have a VSAN-enabled switch you can add VSANs to it. Each VSAN can
be added to one or more switches. Then you can add ports to the VSAN
(on those switches). Each group of VSANs with the same WWN and
name merge to create one fabric. This serves as a mean of isolation.
Switch devices that do not support VSAN have one large fabric for all of
the ports.

• Policy - Applicable only if the switch is not VSAN-enabled. Policy
settings that apply for the switch (for example, Domain ID and Priority).

Add Tape Add a new tape device using this parameter:

• Tape name (IP) - Name and IP address to identify the tape device.

If the tape device was removed and is now being added (all in the same task),
this action restores the device's previous connectivity.

Add Volume Add a new volume to a storage array with these parameters:

• Volumes - Volumes to be added. Click Add once for each volume, then
specify the volume name. Click Remove to delete a selected volume.

• Storage name - Name of the storage array for which you are adding
volumes. Select the device from the list of available devices.
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Add Volume Map Add mapping between a volume and a disk storage port with these
parameters:

• Volume - Name of the volume for which you are adding mapping. Select
a volume from the list of available volumes. The drop-down list includes
the status of each volume. This helps to better understand if this is the
right volume (that is, whether this volume is masked and/or reserved by
other tasks).

• Storage name - Storage array where the volume is defined (filled in
automatically after you select a volume, above).

• Port - Port, on the storage array, to which the volume is mapped. Select a
port from the list of available ports on the selected volume.

• LUN - Logical Unit Number used by the host to access this volume.

Add Volume Mask Add masking between a volume (disk storage port) and a host with these
parameters:

• Initiator (and WWN) - Host port or adapter (node) to which the storage
volume is masked. Select an Adapter or Port from the list of available
adapters/ports. Both are identified by WWN in the list of available ports
for each host. The host name is filled in automatically after you select an
adapter/port.

• Volumes - Name of the volumes to be masked to the host adapter or port
identified above. The drop-down list includes the status of each volume,
as detailed below, as well as an icon that is appropriate to that status (for
example, masked or available). This indicates if this is the right volume
(that is, whether this volume is masked and/or reserved by other tasks).
no text (available volume) - The volume is not masked, either by the
current SAN configuration, or by a planned action.
Already Masked - The volume is masked (that is, in use by the current
SAN configuration), as noted by the text that follows the status.
Reserved - The volume is masked by another action or task in the plan, as
noted by the text that follows the status.
Already Masked and Reserved - The volume is masked in the current
SAN configuration, and the volume is reserved by at least one other
action or task (as noted by the text that follows the status).

• Storage name - Storage array where the volume is defined (filled in
automatically after you select a volume).

• Port - Name of the storage port (on the named array) from which the
volume is accessible to the host initiator.
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Add VSAN Allocate one or more VSAN-enabled switch devices to a new or existing
VSAN with these parameters:

• VSAN - Indication of whether the VSAN is new. Mark the New or
Existing check box. If new, enter an ID between 1 and 4094, and a unique
VSAN name. If existing, select the VSAN from the list of available
VSANs.

• Switches - Switch(es) that will be a part of this VSAN. Choose one or
more switches from the list of available switches.

• Policy - VSAN policy settings (Domain ID, Priority, Merge Control, and
so forth). Refer to your VSAN documentation for detailed information
about these settings, as necessary. If you select more than one switch, this
field is always "default policy."

This action creates the VSAN and/or fabric if it does not exist already.

Add Zone Add a new zone to a fabric with these parameters:

• Zone name - Unique name to identify the zone.

• Fabric/VSAN - Fabric/VSAN where you are adding the zone.

Check this definition against the zoning configuration information received
from the switch. The fabric to which the zone is added must be defined in
OnCommand Insight as part of the SAN environment. If the zone was
removed and is now being added (all in the same task), this action restores its
members.

Add Zone Member
(by Switch Port)

Add a particular switch port to a zone with these parameters:

• Port - Port to add to the zone. Select a port from the list of available
switch ports.

• Switch - Name of the switch whose port is being added (filled in
automatically after you select a port).

• Zone - Zone where you are adding the new member. Select a zone from
the list of available zones.

• Fabric/VSAN - Name of the fabric/VSAN where the selected zone is
configured (filled in automatically after you select a zone).

Add Zone Member
(by WWN)

Add a new zone member, identified by World Wide Name (WWN) with
these parameters:

• WWN - WWN to identify the member being added to the zone. Select a
member from the list displayed when you click this parameter - a host
adapter port, switch port, and generic device port.

• Device - Device type and name (filled in automatically after you select
the zone member).

• Zone - Zone where the new member will be added. Select a zone from the
list of available zones.

• Fabric/VSAN - Name of the fabric/VSAN where the selected zone is
configured (filled in automatically after you select a zone).
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Authorize Path Set policy for one or more paths. Defines a host policy for one or more paths
that connect a specific host server and its data residing on a storage device
(disk volume or tape). You can use these parameters:

• Host - Name of the host for the policy. Select a host from the list of
available servers.

• Storage name (IP) - Name of the storage device where the data for this
path resides. For a disk array, select one or more volumes.

• Attributes for the new host policy- Attributes for the new host policy.

Connect Port Verifies that some (any) device is connected to a particular device port. This
action is useful when you plan to connect a particular switch port to a port
WWN, but that port WWN is currently unknown. With the action in place,
you can track the State check-boxes (Ports detail pane) to see when the
connection is actually made. You can use these parameters:

• Port - Name of the port to check for a connection.

• Device - Name of the device where the port is defined (filled in
automatically after you select a port).

Connect Ports Connect two ports using these parameters:

• Port 1 and Port 2 - Ports that you want to connect.

• Device - Name of the device where each port is defined (filled in
automatically after you select each port).

Disconnect Ports Disconnect two ports using these parameters:

• Port 1 and Port 2 - Ports that you want to disconnect. The second
(connected) port displays automatically after you select the first port.

• Device - Name of the device where each port is defined (filled in
automatically for both ports, after you select the first port).

Edit Authorized
Path

Edits the host policy for one or more paths use these parameters:

• Update authorized path - Click the no paths selected link to view the
table of currently authorized paths and scroll through the list to select the
path you want to edit.

• None redundancy - Click to view the policy parameters that can be
changed, and then select the new policy attributes for the path.

Enable zone
configuration

Enables zone configuration, whereby the task validation process uses a zone
that is set for a particular fabric/VSAN defined within the management
console, but that has not yet been activated. By using this action, the
validation takes into account all underlying changes including added/
removed zones and zone members.

This action is useful to pre-validate zone-configuration changes that are
entered from a switch management console (but not yet applied).

• Zone configuration - Fabric/VSAN from which to load the zone
configuration information.
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Remove
Authorized Path

Removes a host policy.

• Remove - Click the no paths selected link to view a list of hosts for
which a policy is defined, and then select the host you want.

Remove Controller
from a Storage

Removes a port controller from a storage array using these parameters:

• Controller - WWN of the controller you want to remove.

• Storage name - Corresponding array name (filled in automatically after
you select a controller).

Remove Controller
from a Tape

Removes a controller from a tape device using these parameters:

• Controller - WWN of the controller you want to remove.

• Tape name - Corresponding tape name (filled in automatically after you
select the control).

Remove HBA
from a Host

Removes an HBA from a host using these parameters:

• HBA - WWN of the HBA adapter to remove.

• Host - Corresponding host name (filled in automatically after you select
the HBA).

Remove Ports
from VSAN

Removes one or more ports on a specific switch from a VSAN. The
parameters are -

• Remove ports - Ports to be removed from the VSAN. Select one or more
ports from the list of available switch ports.

• Switch name - Name of the switch whose ports are being removed (filled
in automatically after you select ports).

• VSAN - VSAN from which you are removing the ports (filled in
automatically after you select ports).

Remove Volume Removes one or more volumes from a storage array using these parameters:

• Volumes - Volumes to be removed. Multiple volumes, if specified, must
be defined on the same storage array. The drop-down list includes the
status of each volume.

• Storage - Name of the storage array where the volumes are defined (filled
in automatically after you select the volumes).
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Remove Volume
Map

Removes the mapping between a volume and a storage port using these
parameters:

• Mapping - Mapping to be removed. All other parameters display
automatically after you select a volume map.

• Volume name - Name of the volume whose mapping is being removed
(filled in automatically after you select a volume map).

• Storage name - Storage array where the volume is defined (filled in
automatically after you select a volume map).

• Port name - Port, on the storage array, for which the volume mapping will
be removed (filled in automatically after you select a volume map).

• LUN name - Logical Unit Number used by the host to access this volume
(filled in automatically after you select a volume map).

Remove Volume
Mask

Removes the masking between a disk volume (storage port) and a host using
these parameters:

• Masking - Volume mask to be removed. Select a mask from the list of
available masks. All other fields display automatically after you select a
mask.

• Initiator - Host port for which the masking is being removed (filled in
automatically after you select the mask).

• Through port - Storage port for which the masking is being removed
(filled in automatically after you select the mask).

• Storage name - Storage array where the volume is defined (filled in
automatically after you select a mask).

• Volume - Name of the volume that is currently masked to the host port,
and for which the masking is being removed (filled in automatically after
you select a mask).

Remove VSAN Removes a VSAN from one or more switch devices using these parameters:

• Zone member - Member to be removed from its zone. All other fields
display automatically after you select a member.

• Zone - Zone where the member is currently defined (filled in
automatically after you select the member).

• Fabric/VSAN - Fabric/VSAN where the zone is currently defined (filled
in automatically after you select the member).

Remove Zone Remove a zone from a fabric using these parameters:

• Zone - Name of the zone being removed.

• Fabric/VSAN - Fabric/VSAN where the zone is currently defined (filled
in automatically after you select the zone)
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Remove Zone
Member

Remove a member from a particular zone using these parameters:

• Zone member - Member to be removed from its zone. All other fields
display automatically after you select a member.

• Zone - Zone where the member is currently defined (filled in
automatically after you select the member).

• Fabric/VSAN - Fabric/VSAN where the zone is currently defined (filled
in automatically after you select the member).

Shutdown Host Shut down a host.

• Host name (IP) - Host device to be shut down, identified by name and IP
address. Select the device from the list of available hosts.

Shutdown Storage Shut down a storage array.

• Storage name (IP) - Storage device to be shut down, identified by name
and IP address. Select the device from the list of available storage arrays.

Shutdown Switch Shut down a switch.

• Switch name (WWN) - Switch to be shut down, identified by name and
WWN. Select the switch from the list of available switch devices.

Shutdown Tape Shut down a tape device.

• Tape name (IP) - Tape device to be shut down, identified by name and IP
address. Select the device from the list of available devices.

Changing the plan state

After validating your plan tasks, you need to change the plan state to Implementation so that
OnCommand Insight can track the changes your employees make to your Fibre Channel
environment.

Before you begin

Create your change plan and validate the tasks.

Steps

1. Click the OnCommand Insight Open menu and select Planning > Plans.

The Task list main view displays all of the change plans.

2. Select the plan you want to change.

3. Right click and select State > Implementation or Completed.

When the plan is in the Implementation state, OnCommand Insight begins tracking progress on
the tasks.
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Planning to add storage to a host
OnCommand Insight provides a template listing the common tasks required to add storage to a host.

Steps

1. From the OnCommand Insight Open menu, select Planning > Plans.

2. From the Task List view, right-click and choose Templates > Add Storage to Host.

This template provides pull-down lists and other tools to select the details for the task.
 

 

3. Fill in the task identifying information at the top and any comments you wish to associated with
each task.

4. To define an action for an existing task, complete the task identification fields (top-most pane)
with the same information contained in the original task.

The action is then added to the existing task.

After you finish

Validate the tasks and change the plan status to Implementation when you are ready to begin the
work.

Using the Decommission Host template to reclaim host
resources

You can use the Decommission Host template to generate a task and the task's required action in
order to disconnect a host from the SAN and reclaim its resources.

Steps

1. To use the decommission host template, from the OnCommand Insight Open menu, select
Planning > Plans.

2. Right click a line in the Tasks main view and select Templates > Decommission Host.

3. Enter a Task Name and Owner.

4. To make this new task dependent on a previously created task, select that task name from the
Depends on list.

5. Enter a Start time and End time so that all of the network or storage engineers performing the
tasks know when their work needs to be completed.

6. To add comments, click the Comment link and enter text in the lower pane.
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7. Click the No host selected link to display the list of hosts.

8. Select a host from the list.

The selected host name displays, as shown in this example:

 

 

9. Click OK to generate a set of actions to decommission the host, including disconnecting ports,
removing zones, and removing masking.

The plan is shown in the Tasks main view.

Note: If the actions are appropriate for the current time but might be invalid later, Insight
displays a warning.

10. Right-click the task that you generated in the Tasks main view and select Validate task.

11. Click the Tasks Actions detail view icon to display the data for your environment relating to this
task.

12. To expand or modify the generated list of tasks, right-click an action in the Tasks Actions detail
view and select one of these options to make changes to the task list:

• Add action

• Edit action

• Delete action

• Disable action

• Enable action

• Move up

• Move down

Tracking tasks
To check whether the planned actions were performed correctly, incorrectly, or not at all, view the
Task Actions detail view for the plan.

Steps

1. From the OnCommand Insight Open menu, select Planning > Plans.

2. Select the plan you are tracking.
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If the Status field for the plan indicates that the plan is "Not completed," one or more of the
actions have not been performed or were not successfully completed.

3. Click the Task Actions detail view icon to display the list of Actions for the selected plan, as
shown in this example.

 

 

4. To see the status of the individual actions in the plan, examine the check box before each task for
these status indicators:

• A green check indicates that the action was performed successfully.

• A red "X" indicates an error during the execution of the action (for example, host not
physically added).

• An empty check box indicates that the action has not been executed.

5. To review all user actions in OnCommand Insight, use the Audit feature.

Auditing system and user activities

If you want to track down unexpected changes, you can view an audit trail of Insight system and its
user activities.

About this task

Insight generates audit entries for any user activities that affect the storage network or its
management, including the following:

• Logging in

• Authorizing or unauthorizing a path

• Updating an authorized path

• Setting global policies or thresholds

• Adding or removing a data source

• Starting or stopping a data source

• Updating data source properties

• Adding, editing, or deleting a task

• Removing an application group

• Identify or changing the identification for a device

Steps

1. From theInsight Open menu, click Configuration > Audit.

The Audit view appears.
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2. Position your cursor over the Details column to see the complete text.

Exporting tasks to a CSV file
You can use the export to a CSV file facility to import plans from the Task list main view if you want
to use the information in another program besides OnCommand Insight.

Steps

1. Click the OnCommand Insight Open menu, select Planning > Plans.

2. To export the plan tasks from Insight, select File > Export Task list Table.

3. Identify the plan rows and columns you want to export from the Task list main view.

4. Click Browse to select a CSV file or create a new file in a directory.

5. Click Open to load the selected file.

6. Click OK to export the selected data.

Planning tasks reference
Insight helps you create plans to implement changes in your Fibre Channel environment, including
consolidation and migration projects. These tasks are performed by your employees and tracked in
Insight.

Task List view

The Task List view shows all of the plans currently available for Fibre Channel environments. This
view summarizes active and completed plans.

Navigation

You can access this main view in one of the following ways:

• Click the Open menu and select Planning > Plans.

• Click the Plans tab at the top of the client.

Column descriptions

The specific columns displayed in this view depend on your OnCommand Insight license. All of the
possible columns for this view are described.

ID

Internally generated ID (read-only).

Ticket

Number of the plan/project as it appears in the change ticketing/help desk system or any
other number that identifies the change.

Name

Name of the plan entered when the plan was created.

Owner

Name of the person responsible for the plan.

State
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The phase of the plan development and execution:

• Planning - You are planning and entering the task.

• Implementation - You have begun execution of the plan. In this state, OnCommand
Insight checks the task against outstanding violations and marks the violations as
Planned if they are found to correlate to the task.

• Completed - The plan is completed but remains for historical tracking purposes.

Status

This column lists the processing status of the task:

• Not completed means that one or more of the task actions have not been performed or
were not successfully completed in your monitored environment.

• Completed means the task has been finished in your monitored environment.

• Failed indicates that the task could not be validated as Complete or Not complete
when the task was right-clicked and Validate was selected.

Pre-Validation

Tasks have passed integrity tests or not.

Template

Name of any template used to create the plan (Add Storage to Host or Decommission
Host).

Start Date

Plan start date.

End Date

Plan end date.

Flag

If there are violations associated with a task, an icon displays in this field. If a task is
acting on a path that has a violation, the task is considered associated with the violation.

Task Actions view

The Tasks Action view lists the sequence of actions required to complete the task selected in the Task
List. These actions should be executed in the order that they appear at the table.

Navigation

To display the Actions list for a specific plan, click the Open menu and select Planning > Plans.
Select a plan in the Task List, and click the Tasks Action icon.

Column descriptions

The tracking data for the actions in the selected plan are listed in this detail view.

#

Number indicating the order in which the actions should be performed.

State

The check box containing one of these status indicators:

• A green check indicates that the action was performed successfully.

• A red "X" indicates an error during the execution of the action (for example, host not
physically added).
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• An empty check box indicates that the action has not yet been performed.

Description

Action type with device details.

Owner

Name of the person responsible for performing the action.

Errors

Number of errors related to the action.

Errors view

This plan view lists any errors made in planning the tasks.

Errors differ from future violations because they refer to problems that do not affect access paths, but
that still prevent a successful implementation of the task (for example, trying to connect a cable to a
port that is not free).

Navigation

To display the Actions list for a specific plan, click the Open menu and select Planning > Plans.
Select a plan in the Task List, and click the Errors icon.

Descriptions

The action plan errors are listed in this view.

Action

Planned action that will cause an error but does not affect the access paths.

Description

explanation of the problem that will result from the planned action.

Future Violations view

This plan view lists any access-path violations that will occur at the end of the completed task, if not
resolved before implementation.

Use the Analyze Violation tool to examine the future violations. This tool only works on a single
path, so expand (+) the Future Violations list to display each path you want to analyze.

Navigation

To display the Actions list for a specific plan, click the Open menu and select Planning > Plans.
Select a plan in the Task List, and click the Future Violations icon.

Descriptions

Each access-path violation, that will occur at the end of the completed task, listed in this view
contains this information.

blank

Applicable with any presentation order other than No Grouping. Column that organizes
the data according to the selected grouping format. The number in parentheses indicates
the number of violations reported in each (grouped) row.

Violation Type

Description of the violation using one of the predefined violation types.

Host

Task planning | 55



Name of the host from which the violating path originates.

Storage

Name of the storage device where the data for this path resides.

Storage Alias

User-defined storage identification.

Volume

Name of the volume where the data for this path resides (applicable with disk storage
only).

Capacity (GB)

Size of the volume, in gigabytes.

Application

Applicable if the violating path's host is assigned to run specific applications. Name of the
application(s) to which the reported host is dedicated.

Application Priority

Applicable if the host is assigned to run specific applications.

Tenant, Line of Business, Business Unit, Project

Columns listing the business entity components associated with the violation.

Host Ports

The names of the host ports that will be involved in the future violation.

Storage Port Count

The number of storage ports that will be involved in the future violation.

Hops

The number of FC switch devices that the path traverses from the host to the storage.

Sharing

Level of volume sharing permitted by the host, as defined when the path was authorized.

Host Fabrics

Comma-separated list of fabrics to which the host is connected (fabric name if available;
otherwise the fabric WWN).

annotations

User-defined terminology associated with the violation including Note and Violation
Severity.

Future Changes view

This plan view lists the changes that will be created as a result of the ordered execution of the task
actions.

Navigation

To display the Actions list for a specific plan, click the Open menu and select Planning > Plans.
Select a plan in the Task List, and click the Future Changes icon.

Column descriptions

The changes that the actions will make are listed in this detail view.

Action

The action that will result in the change.
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Event

The change that the action will make.
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Streamlined switch migration planning

SAN administrators are frequently required to migrate from existing switching infrastructure to
newer switches while maintaining the storage services provided to the applications. This effort
usually requires iterating over thousands of configuration parameters residing in different devices,
fabrics, scripts, storage management tools, and spreadsheets and then cross-referencing them in order
to construct and identify the storage service. This manual process is prone to human error and often
so time-consuming that it adds weeks to the overall migration time line. OnCommand Insight
provides automation tools to streamline and improve the quality of this process.

To perform a switch migration quickly and efficiently, a SAN administrator is expected to fulfill
these requirements:

• Maintain ongoing business operations during the migration process by avoiding application
disruption and downtime.

• Gain visibility to the risks and impact associated with the migration process in order to be able to
mitigate them.

• Assure that the post-migration storage service quality is at least at the same level that it was prior
to the migration.

• Maintain control during and after the migration by overseeing all changes that are being
performed in the SAN environment to successfully implement the migration.

OnCommand Insight has developed tools that automate the migration process, significantly reducing
the time frame required to complete the migration. Then OnCommand Insight provides a post
migration quality check.

Note: OnCommand Insight does not perform any switch migration activities for you. You must use
vendor storage tools and your own internal procedures to carry out the migration. OnCommand
Insight is providing visibility into the switch migration process so that you do not have to run
multiple storage tools in order to determine host redundancy prior to the migration.

Switch migration phases
The OnCommand Insight switch migration process provides automation tools to assist SAN
administrators in the three phases of switch migration.

• Preparation Phase - In this phase, a SAN administrator is required to identify all storage
services that are affected by the migration including access, redundancy, performance and
recoverability. OnCommand Insight allows the administrator to capture ALL paths that will be
affected by the migration. Then the administrator can use OnCommand Insight to simulate the
changes in the environment to understand the migration impact for each service in order to avoid
any disruptions to ongoing business operations. These automation features streamline the
preparation phase.

• Migration Phase - Once the preparation is done, the administrator performs the actual migration
using vendor storage tools and corporate procedures. This process needs to be monitored and
coordinated by multiple internal departments and often third parties.

• Post-Migration Phase (Quality Assurance Phase) - Following the migration phase, the SAN
administrator is required to ensure that all of the storage services maintained their quality level.
This is done by comparing the current quality level of each storage service to its previous state. In
this phase, it is required to iterate again over the same configuration parameters that were done in
the pre-migration phase.
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Setting up a switch migration
During the Preparation Phase the administrator defines the switch migration and then sets up a
migration task and associates switches with this task.

About this task

To prepare for the switch migration, you need to identify all storage services that are affected by the
migration including access, redundancy, performance, and recoverability.

OnCommand Insight allows you to capture all paths that will be affected by the migration and
simulate the impact of the changes on your environment. You can also provide a timeframe for the
migration to take place within the simulation to better identify and manage the migration task.

You begin to define the switch migration in OnCommand Insight by creating a migration task:

Steps

1. Click the OnCommand Insight Open menu and select Planning > Migrations.

The Migration Tasks list displays all of the switch migration plans created in OnCommand
Insight.

2. Right click anywhere on this list and select Add Task.

3. In the dialog box, create a migration task by entering this information:

• Name of the migration task (required)

• Owner is the name or title of the person responsible for this migration. (optional)

• Start Date is the expected start date of the migration. (optional, but used for tracking
purposes)

• End Date is the expected completion date for the migration. (optional, but used for tracking
purposes)

• Comments (optional, but often used to provide special instructions)

The system fills in the Ticket number automatically.

4. Click Next to display the list of switches in the OnCommand Insight inventory.

5. You can filter the list using the Fabric/VSAN column so that the switches you see are based on
the fabric you intend to migrate. Click the check boxes to select the individual switches that are
targeted for this migration.

6. Click Finish.

This places the project summary into the Migration Tasks list with the project State set to
"Preparation."

After you finish

Check to be certain that the switches listed in this plan are included in the list of OnCommand Insight
data sources so that they can be accurately monitored during the migration.
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Analyzing switch migration simulation results
Based on the information in your switch migration plan, OnCommand Insight identifies all of the
affected paths and the part of the fabric that will be removed, and simulates the proposed changes.
Administrators use this information to correct foreseen violations, make environment changes, and
alert business units about potential outages.

Before you begin

Be certain that your OnCommand Insight SAN path policies are up to date for the affected switches
and create a switch migration plan in Planning > Migrations.

About this task

OnCommand Insight uses the information in the switch migration plan to simulate the proposed
changes in your environment, and displays the simulation results in the Affected Paths and Impact
views.

Steps

1. To see illustrations and associated details of the affected paths, click the Topology icon.

Switches marked with a red "X" are the switches selected for migration, as shown in the example
below. When you are migrating an entire fabric, all of the switches in the Topology view must be
marked with a red "X."

2. Select the switch migration project summary in the Migration Tasks list and click the Affected
Path icon to display a list of all of the host to storage paths associated with the switches that are
intended for migration.

3. To prevent problems, review the foreseen SAN violations identified for any of the affected paths
and clear significant violations before beginning any migration tasks.

4. OnCommand Insight simulates the impact that migrating the selected switches will have on the
paths associated with the switches. Click the Impact icon to review any violations with their
migration risks, as shown in this example.
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One of the most common path violations is "Path outage," as shown in this example.

5. For any High risk migration violations such as an outage, the administrator should evaluate this
risk and might propose a workaround to avoid it. If a workaround is added to the plan,
OnCommand Insight simulates the revised plan, shows the effect of the revision, and adjusts the
risk level.

6. Applications with their priority are shown in both the affected paths and impact information. The
administrator needs to analyze the violations associated with high-priority applications so that
preparations can be made in the affected business units to deal with any outages during the
migration. The potential business impact of lower-priority application violations also needs to be
assessed.

After you finish

Use the affected paths and impact information to alert business unit managers and administrators
about potential disruptions.

Switch migration risks identified during simulation

When you create a switch migration plan, OnCommand Insight automatically runs a simulation of
this plan and displays data describing the affected paths and indicating a level of risk for the planned
migration. It is important to understand these risks and take steps to resolve potential problems before
performing the actual switch migration.

If a migration risk for a host is considered High, you need to identify the possible cause for this risk
and take corrective actions. Missing redundancy is a common cause for the High risk warning. If you
do not or cannot correct this SAN path violation before migration, the host will not have access to
any of its storage. If this cannot be corrected before the migration, it is important to notify the
business unit and/or system administrator that downtime will occur as part of this migration.

However, a High risk may be reported for a host that does not have any current SAN path violations.
This occurs when the Redundancy Policy for the host is set as "None." After the migration
simulation, the Affected Paths view shows no current violation because no redundancy is normal for
this host, but the risk still exists.

Best practice: Analyze any High risk identified during migration to be certain that you understand
the reason for the warning and correct any problems before performing the switch migration.
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Checking host policies

If you have a High risk warning for a planned switch migration and no current SAN path violations
for the affected host, you need to check the policies for the host.

Steps

1. Select Assurance > SAN Path Policies.

2. Select the affected host from the SAN Path Policies view.

3. Click the Properties icon to list the policies for this host.

If the Redundancy field lists "None" as the value, the selected host was created with a discrete
policy that does not require redundancy.

4. To verify that conclusion, select Inventory > Hosts and select the host from the list.

5. Click the Topology icon and select Enclosure from the Topology menu.

You might want to move the mouse pointer over the items in the topology diagram to display
details describing each.

Result

A host without SAN path violations might still be a high-risk migration candidate because of a lack
of redundancy.

Analyzing switch migration violations

When examining violations for the planning switch migration, you can display detailed SAN path
violation data to resolve potential migration problems.

Steps

1. Select a violation listed in the Affected Paths or Impact views.

2. Right click and select Analyze Violation.

3. In the Analyze SAN Path Violation dialog box, note the description of the violation type on the
Summary page and click the Details tab.

4. To display unfiltered details for this path violation, remove the check in the Selection filter box.

5. Click items in the list at the top to highlight the elements affected in the zone and port definition
panels below, as shown in this example.
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6. Use the data to determine what needs to be changed in the switch migration plan to remove the
violation or manage the condition.

Adding data sources before switch migration
Prior to starting the production migration, you must add all relevant data sources for the new
switches. For example, when migrating from McData to Cisco, you need to create new data sources
in OnCommand Insight for the Cisco fabric.

Before you begin

Before adding a new type of data source, read the instructions for preparing to add a data source and
the accompanying vendor information.

Steps

1. To add a data source for the target environment, select Configuration > Data Sources.

2. Select Action > Add Data Source to open the wizard that guides you through the process of
adding a new data source.

Monitoring switch migration
Before performing the migration tasks, use the Migration Tasks list to set the State to "Migration in
Progress" and record the start day and time. When the migration is being performed, the
administrator might capture path data and audit system user actions.

Before you begin

Open Insight and check to be certain that the new switch is included in the data sources list.
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Steps

1. Select the project information in the Migration Tasks main view. Right click and select Set State
> Migration in Progress. This state captures the environment status prior to the migration to
serve as a comparison point after the migration.

Note: After you change the task state to "Migration in Progress," the only migration task
attributes you can modify for this task are the Comments and the State.

2. Right click the project information and select Set Migration Start Time to pinpoint the start day
and time to use during the post-migration phase.

3. The administrator or engineers can begin the switch migration tasks.

4. Add the Data Source for each new switch and be certain that they were acquired without any
failures.

Successfully acquired data sources are required for accurate monitoring of your storage
environment.

5. During the migration, the administrator might right click on the project information and select
Capture Paths to update the paths that the system is monitoring. The Capture Paths feature only
records data if a new path is introduced to the system after the migration task has been created.

6. To monitor all user actions, the administrator clicks the Open menu and selects Admin > Audit.

7. For a long migration project, you might want to monitor changes in the Quality Assurance detail
view. Click the Quality Assurance icon below the Migration Tasks list for this view.

Verifying switch migration
During or after the migration, you can use the Quality Assurance information to monitor and verify
the switch migration tasks.

Before you begin

You need to change the project State in the Migrated Tasks list to "Migration in Progress" and set the
project start time to provide the Quality Assurance data. This is based on a comparison between the
current real time and the time that the user set as the "Set Migration Start Time."

Steps

1. When you want to review the success of your migration project, right-click the switch migration
project summary in the Migration Tasks list and select Set State > Quality Assurance.

2. Click the Quality Assurance icon.

This detail view shows the actual, not simulated violations, in the Pre-migration Violations
column.

3. Check the Completed column. If the migration process is successfully completed, all elements
have a green check.

Precisely, this means that the path is in an equal or better state than during the pre-migration
status.

4. If the Completed column contains a red mark, the path has not been migrated or the migration
resulted in a violation such as Missing Redundancy. Check the Switch Removal Violations
column for these migration violations.

5. Make the necessary changes to correct any switch removal violations.
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6. If you want to review vendor supplied information about the migrated switches, click the
Migrated Switches icon.

Switch migration reference
The switch migration planning facility provides a main view summary of the switch migration tasks
with topology and detail views for a selected task.

Migration Tasks view

The Migration Tasks view displays the information entered for the switch migration when it was set
up along with an actual start date and time.

Navigation

To display the Migration Tasks list, click the Open menu and select Planning > Plans or the
Migrations tab at the top of the client.

Column descriptions

These switch migration details are displayed in this view.

Name

Name of the switch migration project entered during the set up phase.

Owner

Name of the person or the job title of the person who is responsible for managing this
project.

Start Time

Date and time the switch migration is planned to begin.

End Time

Date and time the switch migration is planned to end.

Ticket

Work ticket number assigned to this project.

State

Current status of the project such as Preparation, Migration in Progress, or Completed.

Comments

Any additional information about the project added during the project set up.

Actual Start Time

Date and time that the project state changed to "Migration in Progress."

Affected Paths view

The Affected Paths view shows all devices and elements associated with each path, including the
host, storage array, volume, migration risk, application, application priority and business unit. The
detail view indicates whether there are any outstanding violations on these paths. Best practice: Fix
these violations prior to the migration.

Navigation

To display the Migration Tasks list, click the Open menu and select Planning > Plans or the
Migrations tab at the top of the client. Select a switch migration plan in the Migrations Task list, and
click the Affected Paths icon to see a list of all of the paths affected by this migration plan.
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Column descriptions

These path details are displayed in this view.

Host

Name of host from which the path originates.

Storage

Name of the storage device where the data for this path resides.

Volume

Name of the volume where the data for this path resides (not applicable for tape devices).

Current Violations

Types of SAN path violations that will occur (for example, Missing Active Host Ports,
Missing Redundancy, Path Outage, Single Point of Failure, Switch Hop Count,
Unauthorized Path, and Unauthorized Sharing).

Migration Risk

The migration simulation describes the risk as High, Low or None and provides more
information in the Impact view.

Application

Name of the application assigned to this host.

Application Priority

Critical, High, Medium, or Low priority was assigned to this application when it was
linked to the host.

Tenant, Line of Business, Business Unit, Project

Columns listing the business entity components associated with the path.

Impact view

OnCommand Insight simulates the impact of removing the selected switches on the paths associated
with these switches. This impact is displayed as a path violation. If changes to the plan correct a
potential problem, the violation is removed from this view.

Navigation

To display the Migration Tasks list, click the Open menu and select Planning > Plans or the
Migrations tab at the top of the client. Select a switch migration plan in the Migrations Task list, and
click the Impact icon to see a list of all of the paths affected by this migration plan.

Column descriptions

These migration impact details are displayed in this view.

Host

Name of host from which the path originates.

Storage

Name of the storage device where the data for this path resides.

Volume

Name of the volume where the data for this path resides (not applicable for tape devices).

Impact

Types of problems that will occur when removing the selected switches (for example,
Missing Redundancy or Path Outage).

Migration Risk
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Each impact has a risk associated with it. The risks are defined as follows:

• High Risk indicates that the path will be in an outage state during the planned
migration. The risk needs to be evaluated and a workaround may be proposed to
address that risk. If a workaround is implemented such as adding additional HBAs to
the host, then the Impact Detail changes to reflect the new state of the host.

• Low Risk indicates that there will be no downtime risk during the migration.
However, there will be a lack of redundancy during the planned migration. This is the
expected behavior in most instances.

• None indicates that there will be no migration impact on the path. This risk could only
occur if you have three or more HBA ports in a host connected to three or more
different fabrics.

Application

Name of the application assigned to this host.

Application Priority

Critical, High, Medium, Low priority assigned to this application when it was linked to
the host.

Tenant, Line of Business, Business Unit, Project

Columns listing the business entity components associated with the path.

Quality Assurance view

This detail pane lists Pre-Migration Violations and Switch Removal Violations for post-migration
verification. If the migration process has occurred successfully, all elements show a green checkmark
in the Completed column.

Navigation

To display the Migration Tasks list, click the Open menu and select Planning > Plans or the
Migrations tab at the top of the client. Select a switch migration plan in the Migrations Task list, and
click the Quality Assurance icon to see a list of all of the paths affected by this migration plan.

Column descriptions

The post-migration verification details are displayed in this view.

Host

Name of host from which the path originates.

Storage

Name of the storage device where the data for this path resides.

Volume

Name of the volume where the data for this path resides (not applicable for tape devices).

Pre-Migration Violations

Types of violations that existed prior to the migration (for example, Missing Active Port
Hosts and Single Point Failure).

Switch Removal Violations

The system shows either the simulated violation or the real violation (Missing
Redundancy, Path Outage). The simulated violation is shown while the switch is
connected. The current (real) violation is shown when the switch is disconnected.

Completed
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If this column contains a green check, the path has been successfully migrated. A
successful migration means that the current status of the path is equal to or better than to
the pre-migration status. The pre-migration status was captured when the user entered the
"Set Migration Start Time." If this column contains a red "X," the path has not been
successfully migrated.

Last Update Time

The last date and time an action was performed on the path.

Application

Name of the application assigned to this host.

Application Priority

Critical, High, Medium, or Low priority was assigned to this application when it was
linked to the host.

Tenant, Line of Business, Business Unit, Project

Columns listing the business entity components associated with the path.

Migrated Switches view

This view shows which switches were selected for this migration task and the current status of those
switches. This information is taken from the device itself.

Navigation

To display the Migration Tasks list, click the Open menu and select Planning > Plans or the
Migrations tab at the top of the client. Select a switch migration plan in the Migrations Task list, and
click the Migrated Switches icon to see a list of all of the paths affected by this migration plan.

Descriptions

The migrated switch status is displayed in this view.

Name

Switch name, as provided by the SAN manager at the switch console.

IP Address

IP Address assigned to the switch.

Vendor

Name of the manufacturer of the switch.

Model

Manufacturer's model number for the switch.

Firmware

Version of the firmware running on the switch.

Port Count

Number of licensed ports on the switch.

Status

Current status of the switch as reported by the switch itself. Refer to the manufacturer's
device documentation for an explanation of these values.

Fabric/SAN

Fabric/VSAN on which this switch is configured to operate.

WWN

World Wide Name of the switch.
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How to send comments about documentation and
receive update notifications

You can help us to improve the quality of our documentation by sending us your feedback. You can
receive automatic notification when production-level (GA/FCS) documentation is initially released or
important changes are made to existing production-level documents.

If you have suggestions for improving this document, send us your comments by email to 
doccomments@netapp.com. To help us direct your comments to the correct division, include in the
subject line the product name, version, and operating system.

If you want to be notified automatically when production-level documentation is released or
important changes are made to existing production-level documents, follow Twitter account
@NetAppDoc.

You can also contact us in the following ways:

• NetApp, Inc., 495 East Java Drive, Sunnyvale, CA 94089 U.S.

• Telephone: +1 (408) 822-6000

• Fax: +1 (408) 822-4501

• Support telephone: +1 (888) 463-8277
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