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Accessing the web UI
After you install OnCommand Insight, you must install your licenses and then set up Insight to
monitor your environment. To do this, you use a web browser to access the Insight client (web UI).
Steps

1. Do one of the following:
•

Open Insight on the Insight server:
https://fqdn

•

Open Insight from any other location:
https://fqdn:port

The port number is either 443 or another port configured when the Insight server was
installed. The port number defaults to 443 if you do not specify it in the URL.
The OnCommand Insight dialog box displays:

2. Enter your user name and password and click Login.
The following table shows the default user name and password. Change these defaults as soon as
possible after installation:
Data

Value

Default user name

admin

Default password

admin123

If the licenses have been installed, the data source setup page displays.
Note: An Insight browser session that is inactive for 30 minutes is timed out and you are
logged out of the system.
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Accessing the Insight Java UI
You use the Java UI to manage many of the features associated with storage inventory.
Steps

1. In a supported web browser, open Insight on either the Insight server or from any location using
the URL.
2. Do one of the following:
•

Log in to the web UI, and click

on the Insight toolbar.

•

Without logging in to theInsight web UI, click Launch Java UI in the Login window.

3. Log in to the Insight Client.

Insight Java UI accessibility
The original Insight Client (Java UI) provides accessibility features to help people with disabilities
use the software. User hearing or speech is not required to use the software.
Insight includes the following Java UI accessibility features:
•

•

Menu options can be accessed using a combination of the Alt key plus a letter (accelerator).
◦

For example, to access the File menu, click ALT+F.

◦

For example, to access the Find feature, click CTRL+F.

Illustrations in the product documentation include text (as Alt text) that screen readers can read.

Insight logs
Insight supplies many log files to assist you with research and troubleshooting. The available logs are
listed in the log directory. You might want to use a log monitoring tool, such as BareTail, to display
all of the logs at one time.

Maintaining Insight
Whether you are new to Insight and have a new system to set up, or your system has been operating
for some time, you must take steps to maintain smooth operation of Insight and your network. The
key maintenance concept is that changes in your network usually need to be accommodated in
Insight.
These are the most common maintenance tasks:
•

Maintaining Insight backups

•

Updating expired Insight licenses

•

Coordinating data source patches

•

Updating the Insight version on all acquisition units

•

Deleting removed data sources from Insight
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Related concepts

How you can manage device information on page 27
Insight logs on page 8
Related references

Storage Arrays view on page 157
Switches view on page 163
NPV Switches view on page 145

Creating a support report for troubleshooting assistance
If you encounter an error in any main view of the Insight Client , you can have OnCommand Insight
create a support report that collects your data and log files and then places them in a .zip file, which
you can then send to technical support.
About this task

This feature creates an archive file that contains the following:
•

Your description of the problem

•

Details of the data that you selected

•

All OnCommand Insight log files

•

An OnCommand Insight screen capture

Steps

1. From any main view, right-click and select Create Support Report.
2. In the Create Support Report dialog box, enter the subject of the error.
3. In the Description box, enter what you were doing and what data you were accessing.
For example, you might want to enter the data in the rows or cells that should display or enter
steps needed to reproduce the error.
4. Click Create Report.
OnCommand Insight creates a .zip file (ASUP_db_name_unique_number.zip) and stores it in
the OnCommand Insight download folder and displays it in the default web browser.
5. In your web browser, depending upon your browser's default settings on actions with .zip files,
choose to save or open the file.
After you finish

Send the support archive (.zip) file to technical support.
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Determining your OnCommand Insight license information
You can quickly determine the OnCommand Insight licenses that you have installed, identify the unit
measured for the license, and identify the number of licensed switch ports that you have towards the
OnCommand Insight license.
Identifying OnCommand Insight license information
You can determine the licenses that you have installed and specific details relating to your licenses
using the About OnCommand Insight option on the OnCommand Insight Client Help menu. The
About dialog box lists the installed licenses. This information is often needed when contacting
NetApp Support for assistance.
Steps

1. From the OnCommand Insight Client, select Help > About.
2. Click the License tab.
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Basics of working with views in the Insight Client
You can manage the Insight Client (Java UI) views in different ways and can set preferences that
affect the display of the views.
About this task

You can do the following in the Insight views:
•

Open, close, and rearrange views.

•

Display data in views, select data, and see more details.

•

Filter, group, and search for data in views.

•

Show or hide columns, change column order, change column width, or sort column data.

•

Position the mouse pointer over a column header to display a tool tip describing the contents of
the column.

•

Use icons at the bottom of the Insight views to open detail views.

•

Copy data from views for use in other documents and spreadsheets.

•

In some views, select data and right click to display a menu of options.

You can control the display of views by configuring options in the Tools > Settings option in Insight.
For example, you can control the number of views that appear, and set whether views close
automatically.
Related tasks

Customizing OnCommand Insight display and feature settings on page 40

Insight Java UI views
The Insight Client (Java UI) includes main and detail views.
The Client displays data in the following types of views:
•

Main views
Main views appear at the top of the Client view. Main views include Paths, Changes, Switches,
Hosts, Storage Arrays, Tapes, Generic Devices, and Zones. You can access main views from the
Open menu or from the navigation pane, which, if enabled, appears on the left.

•

Detail views
From the main view, you can select one or more rows and see additional details in the detail views
at the bottom. To see details for the selected row, click a detail view icon in the icon bar at the
bottom of the Client view.
Note: When you click on a view to work with the data in it, the color of the title bar of that view
changes to show that it is the focus of current activity.

Related tasks

Reviewing storage inventory on page 26
Viewing the environment in Topology maps on page 71
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Asian language support
OnCommand Insight displays Asian language characters, such as Korean and Chinese, that conform
to Unicode. Asian language characters are supported in OnCommand Insight windows, views, and
reports.

Data display changes based on selections
Each time you select a resource in a main view, OnCommand Insight displays related data in the
center Topology view and any detail views that are open. Additionally, each time you select a
different device icon in the center Topology view, the data in the detail views changes.
For example, if you are viewing the Hosts view, the Topology view, and two detail views at the
bottom of the window, the data that appears in the Topology view and the detail views changes based
on the row you select in the Hosts view.

Working with Insight Java UI views
You can open one or more Java UI views from the Open menu or from the navigation pane (which, if
enabled, appears on the left), move backwards or forwards to another view, rearrange the tabs of the
main views, and see a list of all open views.

Viewing inventory in a main view from the OnCommand Insight Open menu
You can use the OnCommand Insight Open menu to view inventory information grouped by types of
devices.
Steps

1. In the upper left corner of the OnCommand Insight Client, click the OnCommand Insight Open
menu icon

.

2. In the Open menu, click on the Inventory name to see a list of the main views:
•

Hosts

•

Virtual Machines

•

Datastores

•

Paths

•

Switches

•

NPV Switches

•

Zones

•

Storage Arrays

•

Tapes

•

Generic Devices

3. In the Inventory group, click on a view name to display that inventory information for your
OnCommand Insight environment.
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Working with tables and data in OnCommand Insight views
On OnCommand Insight views where data is displayed in tables, you can manipulate the data and
columns.
About this task

You can perform the following tasks on the data and columns in tables in OnCommand Insight views:
•

Filter the data in tables so that you see only what you need to see.

•

Group the data in tables so that you see groups of rows. This might be helpful if you want to
group data by business unit or data center location, for example.

•

Search for data in tables.

•

Position the mouse pointer over a column header to display a tool tip describing the data in the
column.

•

Show or hide columns for a customized view of data. Many columns are hidden by default and
you can choose which columns you want to view.

•

Change column order.

•

Change column width.

•

Sort data differently in each column.

•

Expand and collapse rows in tables so that you see condensed or expanded versions of the data.

•

Select rows for further inquiry. When you select rows in main or center views, the data in the
detail views changes to reflect the selected resource.

•

Refresh data in views.

Filtering data in tables
You can use a filter on table data to limit the data that appears in the table.
About this task

When a filter is in effect, the icon changes to indicate that a filter is in effect. The following table
shows the icons and how they appear.
Icon

Definition
Paths view icon without filtering applied.
Paths view icon with filtering applied.

The title of the view shows the filtered row count compared to the total row count. For example,
Paths 18/20 might appear to show the filtered count of 18 out of the total count of 20.
You can use a combination of text and symbols as filtering criteria. The following tables explain.
Table 1: Text filters
Filter criteria

Description

text

Displays only those rows whose column value matches the text.
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Filter criteria

Description

"text"

Displays only those rows whose column values exactly match the text in
quotes.

text | text

Displays only those rows whose column values contain either text
string. The vertical bar | symbol represents an OR operation.
For example,
ABC | XYZ

displays only those rows that contain either
ABC

or
XYZ

.
- text

Excludes those rows whose column values contain the specified text
preceded by a minus sign.

A | B -C

Displays only those rows whose column value contain A or B, but not
C.

Table 2: Numeric filters
Filter criteria

Description

number

Displays only those rows whose column value equals the number.

number..number

Displays only those rows whose column value is between the specified
range.
For example, entering
50..100

in the volume capacity column displays only those volumes with
capacities between 50 and 100 GB.
<number or >number

Displays only those rows whose column value is less than or greater
than number.

Steps

1. Right-click the column heading and select Set Filter.
2. To see help text that explains how to enter filter criteria, hover over the filter box that appears in
the column heading.
3. In the filter box, enter the filter criteria and press Enter.
4. To view the filter criteria, position the mouse pointer over the Filter icon.
5. To clear the filter from the column, right-click on the column heading again and select Clear
Filter.
6. To clear all active filters in the view, towards the right of the view, click the Clear Filter icon.
7. To use the Filter icon as a way of filtering, do the following:
a. In the far left of the column header, click directly on the Filter icon.
The Filter icon is visible only after you click the column header.
The following image shows the Filter icon on the Policy Type column.
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b. Do one of the following:
•

In columns that have a set of predefined values, in the drop-down list of values, select a
value to display only those rows that contain that value or select All to display all rows.

•

For all other columns, enter the filtering criteria and press Enter.
For example, in the Hosts Name column, enter "central" to display only those hosts with
"central" in their names.

Result

After setting a filter, a Filter icon appears in the table heading indicating that the table data has been
filtered. If you specify an invalid filter, the Filter icon appears in red. A Filter icon also appears on the
column heading.
Grouping data in views
You can classify and group the data in a view table so that you can interpret the data in groups that
you specify. For example, you can group switches data by fabric.
Steps

1. In the right of any view, click the Grouping drop-down list.

2. Select a data grouping.
3. To remove the grouped display from the table, select "No Grouping" from the Grouping dropdown list.
Note: You can also group data according to annotation groups. Using annotation groups, you
can assign custom business-specific categories to resources and then group the resources by
those categories. For example, on the Hosts view, you can group the data by names of your data
centers so that you can see all resources for each data center.

Example of grouped data
The following example shows the Zone Members detail view with the Zone grouping.
If you do not group data, the data appears on one row per resource. On the other hand, if you
do group the data, OnCommand Insight adds a column to the left of the table with grouping
information. The number in parentheses after each grouping level represents the number of
items reported in that grouped row.
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Searching for data in views
You can search for data in any columns on a main or detail view.
Steps

1. In any main or detail view, use one of these methods to display the Find box below the view:
•

From the main menu, select Edit > Find in This View.

•

Click the magnifying icon at the top of the view.

•

Press Ctrl+F keys.

A Find box displays at the top of the selected view. You can search in both main and detail views.
2. In the Find box, type search criteria for any column in the table.
The search facility automatically locates the first instance that matches the entered criteria.
3. Click the Up or Down arrow indicating either Find the previous occurrence of the phrase or
Find the next occurrence of the phrase.
4. To find the previous or next occurrence of the phrase, click the Up or Down arrow again.
Showing or hiding columns in tables
You can show or hide any column from a main view or detail view. Many columns are hidden by
default.
Steps

1. To hide just one column, right-click on a column header and select the Hide Column option.
2. To hide multiple columns, in the upper right of any view, click the Customize icon.

3. In the Table Customization dialog box, do one of the following:
•

To display a column, check the box in the Visible column.
To hide the column, clear the check box.

•

To select the default columns visible for that view, click Restore to Default.
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•

To select all the columns at once, click Select All.

•

To clear all the columns at once, click Select None.

4. Click OK.
Changing column order
You can change the order in which the columns appear in a main view or a detail view.
Steps

1. From any view, click on a column.
2. Drag the column either to the right or left.
3. To restore the default column order, do the following:
a. Just above the view to the right, click the Customize icon.
b. In the Table Customization dialog box, click Restore to Default.
Changing column width
You can change the width of the column to fit in all of the longest entry automatically in the column
or reduce the width to show less data.
Steps

1. To show the entire longest entry in a column, right-click the column header.
2. Select the Size to Fit option.
The column adjusts automatically to the width required to display the longest entry in that
column.
3. To reduce the width of a column, click on the bar to the right of the header text.
The cursor changes to a double-sided arrow.
4. Drag the bar to the left.
An ellipsis (…) in a cell means that the column is too narrow to show all of its content.
Sorting data in columns
You can change the sorting order of the columns to either ascending or descending and create
additional sorting orders.
Steps

1. In any view, right-click the column header to display the sort menu and select one of these
options:
•

Set Sort Ascending

•

Set Sort Descending

a. To apply this sorting order to multiple columns, hold down the Shift key.
b. Click the header of each additional column that you want included in this sort order.
2. To change the sort order of another column, right-click that column header and select one of the
Append options:
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•

Append Sort Ascending

•

Append Sort Descending

The number displayed at the end of the Append option indicates that the selection would the
second or third sorting order applied to the view.
3. To return to the default sort order, without holding the Shift key down, click any other header.
Expanding and collapsing rows in tables
You can expand all detailed rows in a table at once by using the Expand All Groups icon.
Alternatively, to expand individual detailed rows within a parent row, click the plus sign next to the
parent row.
Steps

1. To expand data, do one of the following:
•

To expand all detailed rows at one time, click the Expand All Groups icon above the table.

Note: The Expand All Groups icon is visible only in some tables.

•

To expand selected rows, click the plus sign to the left of the parent row.

2. To collapse data, do one of the following:
•

To collapse all detailed rows at one time, click the Collapse All Groups icon above the table.

•

To collapse selected rows, click the minus sign to the left of the parent row.

Selecting and deselecting rows in tables
Selecting rows in tables changes data in related views. You can select consecutive or nonadjacent
rows.
Step

1. To select a row or rows, do one of the following:
Option

Description

Click left mouse button and
drag down the table.

Selects a range of consecutive rows.

Hold down the Shift key and
click the first and last rows in
the range that you want.

Selects a range of consecutive rows.

Hold down the Ctrl key and
click individual rows.

Selects nonadjacent rows.

Press Ctrl+A.

Selects all rows.
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Refreshing data in views
You can refresh data in views when you want or need OnCommand Insight to refresh it automatically
after any change.
About this task

Using the Tools > Settings option, you can configure OnCommand Insight to refresh data
automatically or suspend this automatic refresh. In normal circumstances, you should set
OnCommand Insight to refresh data automatically. However, sometimes you might want to suspend
the refresh.
Steps

1. To refresh any view at any time, press F5.
2. To configure OnCommand Insight to refresh data automatically after any change, do one of the
following:
•

Click the Auto Refresh icon in the lower right of the OnCommand Insight main.

•

Select File > Auto Refresh.

OnCommand Insight retrieves and displays updated data in the view.
Related tasks

Setting preferences and defining your environment on page 43
Reviewing percentage data
Any table column that displays percentage data includes a progress bar in addition to the numeric
value.
About this task

You can display or hide the progress bars.
Steps

1. Open a view with a column showing percentage data.
2. Compare the percentage progress bars to determine the differences quickly.
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Disabling the percentage bar display
The percentage bar display is set by default. If you want to see only the numeric value of the data,
you can change this option in the Settings.
Steps

1. From the Client menu, select Tools > Settings.
2. In the left tree of the Settings view, select General Preferences.
3. Click the Display bars in percentage columns box to remove the check.
4. Click OK.
Copying data from views
You can copy data from cells in a OnCommand Insight view or text in a row into the Microsoft
Windows Clipboard.
About this task

You can copy text from cells or rows as follows:
•

To copy just the text in one cell, double-click on an editable cell and select the text.

•

To copy a row of data, select the row.

•

To copy multiple rows of data, select multiple rows.

•

To copy the entire table, select all rows.

Steps

1. Open any OnCommand Insight view.
2. Select the data in the table.
3. Press the Ctrl+C keys to copy the data into the Windows Clipboard.
The raw data, without any units or percent symbols, are copied into the Clipboard. Using just
numbers for the values makes it more convenient when pasting the data from the Clipboard into a
spreadsheet and to use in formulas.
Exporting data to a file
You can save the data from any view that shows data in tables to a comma-separated (CSV) file.
About this task

When you export CSV files, you can choose the following options:
•

Include all or just some of the rows in the view.

•

Include the header row from the Excel file.

•

Choose to use UTF-8 format for non-Latin languages, for example, Chinese characters. Excel is
able to detect the unicode characters.

Steps

1. From the Insight Open menu, select any menu option, and select a device option, such as Hosts.
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The device information appears in a main view.
2. Go to any view, including a detail view.
3. Select File > Export <view_name> Table...
4. Select whether you want to export some or all rows and columns.
5. Select whether you want to include a header row in the export.
6. Select whether you want to use UTF-8 format.
7. Name the export file and browse to the location where you want to save it.
8. Click OK.

Opening a main view from the Go To View menu
To display any main view quickly, use Go To View menu.
Steps

1. To display the Go To View pop-up menu, open Client and press Ctrl+G. This menu lists all of the
OnCommand Insight main views in addition to the inventory views that are listed at the top of the
menu.
2. To search in this menu for a different view name, begin typing the name of the view.
OnCommand Insight displays the first instance of a view name beginning with the letters you
typed.
3. Click the name of the view and press Enter to open the selected view.

Navigating among Insight Java UI views
Using the tabs of each main view, you can move to the next view, move to the previous view, and
rearrange views. You can also use the Go to View (Ctrl+G) shortcut to display a list of and access
main views.
About this task

With the Settings option, you can also control the number of main views that can appear.
Steps

1. To switch to the next main view, press Ctrl+Tab.
2. To switch to the previous main view, press Ctrl+Shift+Tab.
3. If you open more main views than can appear on the view bar, backward and forward arrows
appear at the end of the tabs. Click on the arrows to go backwards or forwards in the views. To
see a list of main views, click on the Show List control at the end of the tabs.
4. To rearrange the main views, click a tab and drag it to the left or right.
5. To close a main view, in the main view tab, do one of the following:
•

Click the "X" on the corner of the tab.

•

Right-click on the main tab to display a pop-up menu and select Close Tab.

6. To close all main views except for the one you are viewing, right-click on the main tab to display
a menu and select Close Others.
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Related tasks

Setting preferences and defining your environment on page 43

Displaying details
From a main view, you can select a row and display its details. This additional information is listed in
views at the bottom of the page. The information in the detail view changes based on the row you
select. You can open one or more detail views.
About this task

A detail view might be blank if there are no entries relevant to the selection in the main view. For
example, if you select a host in the Hosts main view that does not use masking, the Masking detail
view is empty.
Steps

1. In a main view, click on a row to select it.
2. Do one of the following:
•

On the menu bar, select View > Detail views and select the detail view or views that you want
to display.

•

At the bottom of the view, click an icon representing the detail view you want to see.
Positioning the mouse pointer over an icon displays a tool tip description of the detail view.
This example shows examples of icons for inventory views:

Hosts main view and corresponding detail views
The following illustration shows an example of a host selected in the Hosts main view,
Topology view in the center, and the virtual storage and backend volumes information in detail
views:
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Related tasks

Viewing virtual machine data and utilization on page 83
Viewing paths in your SAN or NAS environment on page 102

Closing one or all Insight Java UI detail views
You can close one detail view at a time or you can close them all at once. You can close detail views
using the Close X in the upper right corner of the view or use the View > Detail Views > Close All
Detail Views option.
Steps

1. To close one or all detail views, do one of the following:
•

To close all detail views at once, select View > Detail View > Close All Detail Views.

•

To close a specific detail view, select View > Detail Views and clear the view that you want to
close.

•

To close a specific detail view, click the X on the right side of the view.

2. To close a detail view using a pop-up menu, right-click on a detail view icon in the Detail Views
toolbar to select it and do one of the following:
•

To close the selected detail view from the pop-up menu, select Close.

•

To close all other detail views except the one you selected, select Close Others.

•

To close all open detail views at the same time, select Close All.

The Insight Java UI status bar
The status bar at the bottom of the view shows a message about the currently selected object, the
current user, a time stamp, the status of the Auto Resolution (AR) option, and a status of the
automatic data refresh option.
The following image shows the status bar at the bottom of the Client view:

Using the status bar, you can perform the following tasks.
•

Review connection and progress information.

•

Log in as another user.

•

Check operation progress.

•

Configure Auto Resolution (AR) and view AR enabled status.

•

Automatically refresh data in views.

The following table describes the information that appears on the status bar.
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Data

Description

Connection

Displays connection information between the Insight Client and
the Server. When the Client is receiving data from the Server,
green arrows appear between the Client and the Server. When the
connection is lost between the Client and the Server, a red NOT
sign appears between the Client and the Server.

Progress

Displays a scrolling progress bar when the Client is busy
performing a task. If you position the mouse pointer over the
progress bar when it is in progress, the description of the current
task appears in a tool tip. To display details about what the client
is doing for that task, you can double-click on the progress bar.

View selection description

Shows a full description of the item currently selected in a view.
This is a particularly useful reference when multiple views are
open.

User identification

Displays the user login name such as "admin."

AR

Shows the status of the Auto Resolution (AR). This feature
attempts to resolve unknown host ports.
Double-click this to display the Tools > Settings option where you
can enable or disable Auto Resolution.

Auto Refresh

Enables or disables automatic refresh of all views. With this
option set, OnCommand Insight automatically refreshes the view
and updates the time stamp indicating when the change is acquired
by the OnCommand Insight Server.
If automatic refresh is disabled, OnCommand Insight does not
refresh the views when a change occurs. However, you can press
F5 to refresh a view.
You can also enable or disable the automatic refresh by using the
File > Auto Refresh option. See "Refreshing data in views."

Time stamp

Indicates the exact time for which information is displayed in a
format that matches the user's location. OnCommand Insight
stores all past changes and events and can provide an accurate
change-level image of the environment at any time. OnCommand
Insight updates the time stamp when a change is acquired by the
OnCommand Insight Server.

Related tasks

Logging in from the status bar as another user on page 24
Refreshing data in views on page 19

Logging in from the status bar as another user
Using the status bar, you can log into the OnCommand Insight Client as another user. This is a quick
way of logging in.
Steps

1. From the OnCommand Insight Client status bar, click the login name. In this example, the login
name is admin.
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2. In the OnCommand Insight Login dialog box, enter your user name and password.
3. Click OK.

Refreshing data automatically
OnCommand Insight can automatically refresh data in all views. You can enable or disable the
refreshing of data on all views. You might want to disable the refresh option temporarily to increase
performance. You can set this option from the Client status bar or from File > Auto Refresh.
About this task

Each time the OnCommand Insight server acquires new data, OnCommand Insight shows an updated
time stamp in the status bar.
Step

1. Do one of the following:
•

From the OnCommand Insight Client status bar, double-click the Auto Refresh icon (double
arrows).

•

From the OnCommand Insight Client menu, select File > Auto Refresh.
A check mark next to the Auto Refresh option indicates that the option is enabled.
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Reviewing storage inventory
You can view information about the devices and zones in your SAN or NAS environment. You can
view inventory lists, select a device from the list, and display the details for a selected device.
OnCommand Insight gives you visibility across multivendor environments.
About this task

OnCommand Insight provides the following types of information across your environment:
•

Paths between end points
See “Viewing paths in your SAN or NAS environment.”

•

Generic devices
Use when identifying devices. Generic devices are Fibre Channel devices (including hosts, ports,
HBAs, disk storage, tapes, and switches) that OnCommand Insight could not identify during the
identification process. As soon as they become identified, they are no longer considered generic
devices.

You can select a device and show its details that display in the following detail views:
•

Applications

•

Acquisitions Units

•

Backend Volumes

•

Changes

•

Data Sources

•

Datastores

•

Devices

•

Disks

•

Event Log

•

FC Ports

•

File Systems
Requires a Plan license installed. See OnCommand Insight Planning User Guide for the Java UI.

•

Hosts

•

Internal Volumes

•

iSCSI Sessions

•

Masking details

•

Network Portals

•

Paths

•

Qtrees

•

Quotas

•

Shares
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•

Storage Pools

•

Virtual Machines

•

Virtual Storage

•

VMDKs

•

Volumes

•

Zone Members

•

Properties of each device

Related tasks

Viewing paths in your SAN or NAS environment on page 102
Viewing virtual machine data and utilization on page 83

How you can manage device information
You can select a device from an inventory view and manage the data for that device. You can set
annotations on a device that let you subsequently filter or group devices in a list, export device data,
and perform other tasks on devices, depending on the device type.
After you select a device, you can perform the following tasks on most devices:
•

View the properties for the selected device. The Properties view provides additional detail about a
specific device.

•

Ensure that a device is marked as inactive. A device becomes marked as inactive when
OnCommand Insight obtains inactive status information from the device or when you remove the
data source corresponding to the device.

•

Delete an inactive device from the OnCommand Insight database.

•

Undo identification on a device. Do this to remove the identification of a device that was
identified manually. The device becomes listed as a generic device.
Note: You cannot undo the identification of a device that was discovered through data source

acquisition.
•

Set annotations on a device. You might want to categorize devices by annotations such as data
center, geography, project, floor, rack, birthday, tier, or end of life. You can then filter or group
data in views by the annotation.

•

Clear annotations from a device.

Searching for storage arrays
You can locate information about storage arrays using the search facility. For example, suppose the
administrator receives an email from Australia's Wasteland Rehabilitation project in Sydney
indicating that their Gas Control application is responding extremely slowly. The administrator asks
for the name of their server, and the representative thinks it is "Sym" and that the IP address has "21"
as the last numbers. With that information, the administrator can locate the storage array quickly.
Steps

1. In the Search box at the top of the Client window, type the characters describing the host.
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The search begins immediately. In this example, the administrator enters sym 21, and the results
show the best match to be the Sym-Perf host at IP 192.168.7.21.

2. Select an item from the search results to display information in the Storage Arrays view.
In this example, the selected storage array is highlighted, and the administrator notes that it is a
backend volume with much lower capacity than many of the other storage arrays.

3. Scroll across the storage array information to check the name of the data center and see if there
are entries in the Last Report Time column or the Hot annotation.
If the date and time in the Last Report Time is 72 hours or older, the data source health for that
device is worth investigating. It may have stopped or failed. If "Yes" is in the Hot column, the
array has reached high utilization based on the preset threshold.
In this example, the host is "hot" and probably over-utilized.
4. Right-click an item of interest in the Storage Arrays view and select the type of analysis option
that is appropriate for any potential problem.
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After you finish

From this point, the administrator uses the information provided from the analysis to make changes
in the resource allocations or another adjustment to eliminate the problem.
Related concepts

Maintaining Insight on page 8
Related references

Storage Arrays view on page 157

Viewing inventory lists in views
View inventory lists of all the hosts, switches, zones, storage arrays, data stores, tapes, and generic
devices in your environment. Insight provides lists of this inventory in views.
Steps

1. From the Insight Open menu, select Inventory.
2. From the Inventory menu, select a device type.
For example, the storage arrays are listed in this view.

3. Different types of devices have different options to act on items selected in the views. All of the
Inventory views have the options to perform any of these actions:
•

Filter the devices on this view to show only a subset of items by clicking on a column header
and clicking the Filter icon.

•

Show the data organized by a category, for example, application or volume, by selecting the
category from the Grouping drop-down list. Grouped information appears on the left most
column and the number that appears indicates the number of hosts reported in each group.

•

Search for data, show or hide columns in tables, change column order, change column width,
or refresh data.

Related tasks

Filtering data in tables on page 13
Working with tables and data in OnCommand Insight views on page 13
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Viewing all hosts
You can identify the hosts that Insight detects in your environment. A host can be a client, a server,
both a client and a server, a manager, or a managed host. The host can provide centralized control of
the network.
About this task

You can view hosts in both your SAN and NAS environments. For NAS environments, you can view
hosts as defined by their usage of NAS shares.
Steps

1. From the Insight Open menu, select Inventory.
2. From the Inventory menu, select Hosts.
3. Click icons below the Hosts main view to display the Topology view and detail views, as shown
in this example:

4. Optionally, do any of the following:
•

Filter the devices on this view to show only a subset of items by clicking on a column header
and clicking the Filter icon.

•

Show the data organized by a category, for example, application or volume, by selecting the
category from the Grouping drop-down list. Grouped information appears on the left most
column and the number that appears indicates the number of hosts reported in each group.

•

Delete Inactive Device: Removes the host from your environment, typically after you
decommission it.

•

Delete Inactive Adapter: Removes an inactive host adapter from the host.

•

Undo Identification: Removes the identification for a host that was identified manually.
Note: You cannot undo the identification for devices that are discovered through data
source acquisition.
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•

Set Application: After you define applications with their business entities, associates the
applications with the hosts on which they run.

•

Set Business Entities: Associates the business entities (tenant, line of business, business unit,
and project) with this resource.

•

Automatically Add Applications: Automatically adds hosts to applications based on a host
naming pattern.

•

Set/Remove/Modify items for both FC and iSCSI host policies: Sets, removes, or changes
the policy that governs alerts, which are set on this resource.

•

Host Virtualization Policy: Excludes the selected resource from the global virtualization
policy. You can set a policy that monitors for active/passive volume multipathing, for identical
volume access for hosts in a virtual cluster, and for identical volume LUN for virtual cluster
hosts.

•

Register: Registers a host so that you can focus on hosts you want. After you register a host,
the Register pin icon

appears in the host row.

•

Create Request for Host(s): Allows you to request storage space on the selected hosts and
associate that with an existing request or generate a new request. This requires the
OnCommand Insight Plan license.

•

Analyze: Shows the performance information for the selected resource. This requires the
OnCommand Insight Perform license.

•

Edit/Set/Clear Annotation: Allows you to edit or assign a predefined or custom category to
this resource so that you can later group the resources by the annotation. For example, you
might want to group all resources in a specific data center or tier. The Clear option removes
the annotation from the resource.

Related tasks

Working with tables and data in OnCommand Insight views on page 13
Related references

Hosts view on page 131
Registering a host
To identify the hosts which you need to watch, you need to register them. These hosts are typically
the servers for which you receive regular reports. After you register a host, you can filter the list of
devices to show only those values that are relevant to the hosts with which you are registered.
About this task

You can register any number of hosts.
Steps

1. From the Open menu, select Inventory > Hosts.
2. Do one of the following:
•

In the Hosts main view, right-click on a host row and from the pop-up menu, select Register.

•

From the Actions menu, select Register.

Insight picks up your user information and displays a Registered icon next to that host.
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3. To filter the list of hosts to show only the hosts with which you are registered, from the Hosts
main view, do one of the following.
•

Click the Registered column.

•

At the top right of the Hosts main view, click the Show Registered Only icon.

Related references

Hosts view on page 131
Associating applications with hosts for customized grouping
You can associate applications, such as email, finance, and human resource (HR) applications, with
hosts. You might want do this so that you can display hosts that service the same applications
together in reports. A group of hosts assigned to an application is an application group.
Before you begin

Before you can assign applications to devices, the applications must be defined (in Tools > Settings
> Annotations > Types). As part of the definition, the target resources for the annotation must be
assigned. For example, if you set the target resources on the application annotation just for virtual
machines, you do not see the application annotation as an option for hosts.
About this task

An application is assigned to a host using an annotation, similar to the process used to assign
business units, location, and project annotations to devices.
A host can be associated with multiple applications. Also, an application can be associated with
multiple hosts.
To assign an application to a host, use one of the following processes:
•

Let Insight use your host naming pattern to assign applications to hosts automatically.

•

Assign an individual host to an application.

Adding hosts to an application automatically
You can have Insight add hosts to an application automatically based on a host naming pattern. This
feature enables you to add hosts to an application at one time; Insightdoes not continually monitor
hosts and automatically add them to applications.
About this task

Insight creates application groups by extracting the application name from one or more selected host
name patterns. To do this, you define a regular expression. Insight finds application names that match
the criteria in the expression.
For example, with host names formatted as:
<host_name>_<application_name>

you would enter the following regular expression to extract the application names from all hosts:
.*_(.*)
Steps

1. From the Open menu, select Inventory > Hosts.
2. Do one of the following:
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•

Select Action > Automatically Add Hosts to Application.

•

Right-click on a host and select Automatically Add Hosts to Application.

3. In the Automatically Add Hosts to Application dialog box, in the Application extraction
Regexp field, enter a regular expression that will be used to find the matching host names.
Insight displays a list of matching host names and the application name extracted from each.
4. Click on the host or hosts that you want to add.
Note: Only those hosts that you selected are added. This option works on the current selection,
not the entire list of hosts.

5. Click OK.

Viewing all switches
You can identify all switches detected in your environment. This view applies to Fibre Channel
switches only. Inactive switches appear in black text; active switches appear in blue text.
Steps

1. From the Insight Open menu, select Inventory.
2. From the Inventory menu, select Switches.
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3. In addition to the standard options available for Inventory views, you can perform these
operations on selections:
•

Delete Inactive Device: Remove the switch from your environment, typically after you
decommission it.

•

Delete Inactive Ports: Remove an inactive port from the switch.

•

Manage Storage: Launch a third-party management console or user interface for the selected
switch. If the third-party management console is not configured, this option is disabled.

Related tasks

Working with tables and data in OnCommand Insight views on page 13
Related references

Switches view on page 163

Displaying inventory details
You can view details about a device or resource in your environment. From any of the Insight Client
main views, you can select a device or resource and display its properties in detail views that appear
at the bottom of the window.
About this task

The information in the detail view changes based on the resource row that you select in the main
view. You can open one or more detail views.
The details view might be blank if there is no information relevant to the selection in the main view.
For example, if you select a host in the Hosts main view that does not use masking, the Masking
detail view is blank.
You can see information about the following items in detail views:
•

Applications

•

Backend Volumes

•

Changes to the environment

•

Data Sources

•

Datastores

•

Disks

•

FC Ports

•

File Systems

•

Internal Volumes

•

iSCSI Sessions

•

Masking

•

Network Portals

•

Paths

•

Qtrees
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•

Quotas

•

Shares

•

Storage Pools

•

Virtual Machines

•

Virtual Storage

•

VMDKs

•

Volumes

•

Zone Members

•

Properties of the selected device

Steps

1. From the Insight Client main view, click on a row to select a resource.
2. Do one of the following:
•

From the Insight Client menu, select View > Detail views and check the detail view or views
that you want to display.

•

At the bottom of the Insight view, click an icon representing the detail view you want to see.

Different icons appear depending on the main view shown.

Viewing internal volume details
You can find information about volumes that are used internally in storage devices. Only some
storage devices have internal volumes.
About this task

An internal volume displays the logical layers in storage devices that are not externally accessible as
SAN volumes or NAS shares. Internal volumes might act as logical layers underlying both storage
services, but are above the storage pool layer. Internal volumes are carved from storage pools and
exposed to hosts as NAS shares or LUNs (Insight volumes). Insight represents NetApp volumes as
internal volumes.
Steps

1. In a main view, click on a row to select a device.
2. Do one of the following:
•

From the Insight Client, select View > Detail views and check the Internal Volumes detail
view.

•

At the bottom of the Insight view, click the Internal Volumes icon.
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Viewing path details
You can see details about a selected path, which is the logical relationship between a host server and
its data residing on a storage device. The Paths view is available as a main and detail view and shows
both SAN and NAS NFS paths.
Steps

1. To display a Paths view, use any of these methods:
•

From the Insight Client menu, select Inventory > Paths.

•

From the navigation pane, select Inventory > Paths.

•

To display the detail view from a main view, click the Paths icon below the main view.

2. Select a path of interest and use the right-click to perform additional analysis or set a policy on
the path.

Related references

Paths view on page 147

Viewing qtrees
You can view qtrees associated with storage arrays, storage pools, volumes, virtual machines, internal
volumes, or shares. Because qtrees allow selective disabling of CIFS opportunistic locks (oplocks),
which is beneficial for certain database and critical data applications, you can use this view to
determine whether oplocks are enabled.
About this task

To perform capacity management in Insight, quotas must be set on the qtrees. You might also want to
look at the Quotas detail view.
Steps

1. From the Insight Client, display the Paths, Storage, Hosts, Violations, or Virtual Machines main
view.
2. In the main view, click on a row to select a resource.
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3. Do one of the following:
•

At the bottom of the window, click the Qtrees icon.

•

From the Client menu, select View > Detail views and check the Qtrees detail view.

The Qtrees detail view displays qtree information.

Related tasks

Identifying quotas set on qtrees on page 37
Related references

Qtrees detail view on page 150
Benefits of qtrees
By using qtrees, you can partition data and take advantage of different backup strategies, security
styles, and settings.
Using qtrees provides the following benefits:
Backups
You can make backups more modular (by backing up each qtree), add flexibility to backup
schedules, or limit the size of each backup to one tape.
Security styles
Using qtrees enables the use of different security styles across projects without requiring
other projects to use the same security style.
CIFS oplocks setting
If you have a project using a database that requires CIFS oplocks to be disabled, you can
set CIFS oplocks to Off for that project's qtree, while allowing other projects to retain
active CIFS oplocks.
Identifying quotas set on qtrees
You can view the capacity or file number quotas set on qtrees. Using quotas, you can identify how to
partition your data.
Steps

1. From the Insight Client, display the Paths, Storage, Hosts, Violations, or Virtual Machines main
view.
2. In the main view, click on a row to select a resource.
3. From the Insight Client menu, select View > Detail views and check the Qtrees detail view.
4. In the Qtrees detail view, select a qtree.
5. Do one of the following:
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•

At the bottom of the Insight window, click the Quotas icon.

•

From the Client menu, select View > Detail views and check the Quotas detail view.

The Quotas detail view displays quota information.

Related references

Quotas detail view on page 153
Quotas on qtrees
You can view the capacity or file number quota that is set on qtrees.
Quotas are used in NAS environments to do the following:
•

Limit how much disk space or how many files can be used by the quota target.

•

Monitor the disk space usage and the number of files that are being used when no limit is
specified.

•

Notify users or administrators when their disk or file usage becomes high.

To perform capacity management in Insight, quotas must be set on the qtrees.
You can view the following types of quotas on qtrees:
Space quota
Limits on the amount of usable space.
File quota
Limits the number of files that can be created on a NAS share or qtree.
A quota can be attached to one of the following resources:
•

A specific qtree or all qtrees

•

A specific user or all users

•

A specific user group or all groups

Viewing device properties
View details about a particular device. For example, from the Hosts main view, select a specific host
and view its details.
Steps

1. From the Insight Open menu, select Inventory and select a device option.
2. In the main view, click on a device.
3. Do one of the following:
•

Select View > Detail Views > Properties.

Reviewing storage inventory | 39

•

At the bottom of Client view, click the Properties icon.

•

Right-click on the selected device and select <device> Properties.
This displays the information in a separate window, allowing you to view the properties of one
device while looking at another.

Exporting data to a file
You can save the data from any view that shows data in tables to a comma-separated (CSV) file.
About this task

When you export CSV files, you can choose the following options:
•

Include all or just some of the rows in the view.

•

Include the header row from the Excel file.

•

Choose to use UTF-8 format for non-Latin languages, for example, Chinese characters. Excel is
able to detect the unicode characters.

Steps

1. From the Insight Open menu, select any menu option, and select a device option, such as Hosts.
The device information appears in a main view.
2. Go to any view, including a detail view.
3. Select File > Export <view_name> Table...
4. Select whether you want to export some or all rows and columns.
5. Select whether you want to include a header row in the export.
6. Select whether you want to use UTF-8 format.
7. Name the export file and browse to the location where you want to save it.
8. Click OK.
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Customizing OnCommand Insight display and
feature settings
You can customize OnCommand Insight to increase efficiency or to match how you want to work.
You can define whether you want to view an overview Dashboard of the environment, configure the
way you access views, and use the Settings Data Sources option to identify data collection. You can
also customize display views and general settings that control OnCommand Insight features.
About this task

You can customize OnCommand Insight in the following ways:
•

Define the OnCommand Insight display using:
◦

The OnCommand Insight Dashboard, a window that provides a quick overview of your
environment and access to key features.

◦

The OnCommand Insight navigation pane, which enables you to access OnCommand Insight
views quickly.
The navigation pane appears on the left.

•

Use the Settings Data Sources option to enable or disable data collection for a specific set of
licensed Insight features.

•

Configure Tools > Settings:
◦

Set general preferences that affect OnCommand Insight behaviors such as whether
OnCommand Insight restores all open tabs when restarting, whether OnCommand Insight
displays a confirmation when exiting, and how many main view tabs you can have open at any
one time.

◦

Enable and configure OnCommand Insight to identify hosts automatically using its automatic
resolution (AR) option.

◦

Set up policies that monitor configuration.

Customizing the OnCommand Insight layout
You can customize the layout of OnCommand Insight and your access to views by enabling the
OnCommand Insight Dashboard or the navigation pane (on the left of the Client view) or both.

Obtaining a quick summary with the Dashboard
The OnCommand Insight Dashboard provides a summary of your environment. Administrators can
see when there are changes in the environment or problems with data sources. The Dashboard also
provides links to information shown, such as Changes. From the Dashboard, you can click on an item
to display that view.
About this task

When OnCommand Insight acquires statistics about items listed in the Dashboard, item labels appear
in bold text. For example, when OnCommand Insight acquires data about the number of switch ports,
the value appears in parentheses following the label and the label itself appears in bold text.
The Dashboard provides links and statistics for the following:
•

Daily SAN Path Violations
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If you installed Assure, the Dashboard also displays the count of violations against policies. Click
this to view the list of violations.
•

Daily Changes
The list of changes in your environment that might affect the performance and availability of
devices in the environment.

•

Switch Ports
The number of switch ports counted. Click this to display the Switches main view.

•

Generic Device Paths
Fibre Channel devices that have been discovered by OnCommand Insight but not yet identified
using manual or automatic resolution are shown as “generic devices.” Click this to display the
Paths view for these generic devices.

You can customize the Dashboard in the following ways:
•

You can view the Dashboard as a pop-up window or display it at the top of the navigation pane,
which appears on the left if enabled.

•

You can customize the information that appears on the Dashboard.

•

You can set whether it always appears on top of other views, which enables you to work on other
applications yet view OnCommand Insight status.

Displaying or hiding the Java UI Dashboard
You can configure Insight Java UI to display or hide the Dashboard. You can view the Dashboard as a
pop-up window or at the top of the navigation bar, which appears on the left.
Step

1. From the Client menu, do one of the following:
•

To view the Dashboard as a pop-up window, select View > Show Dashboard.

•

To view the Dashboard in the navigation bar, select Tools > Settings. Check Use Navigation
pane in the General Client Preferences section.

Customizing the OnCommand Insight Dashboard
You can customize the Dashboard to show only the data that you want and you can configure the
Dashboard to show on top of other views.
Steps

1. From the OnCommand Insight Client, select View > Show Dashboard.
2. In the Dashboard, right-click on any area inside the window to show a pop-up view.
3. To display data on the Dashboard, check the data item.
4. To display the Dashboard on top of other views, check Always on top.

Gaining quick access to main views with the navigation pane
You might find it helpful to use the navigation pane to access OnCommand Insight main views.
When enabled, the navigation pane displays on the left side of the OnCommand Insight window. You
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can access all of the licensed OnCommand Insight features and display the associated main views
from the navigation pane.
Steps

1. From the OnCommand Insight Client, select Tools > Settings.
2. On the left, click General Preferences.
3. Select Use Navigation pane.
4. On the navigation pane, click on the line representing a licensed set of features, such as
Assurance for violations or Performance
The main views for that license type are listed in the navigation pane.
5. Click a view name.
The view displays on the right.

Saving view preferences in a profile
You can set column filters, set grouping options, select the detail views that appear, and adjust
columns on a view to the way you prefer to see the data in the view. You can then save your
preferences in a profile. When you return to the view, you can display the view with your customized
settings simply by selecting the view profile. This option is available only for those who log in as
superusers.
About this task

Each view can have one or more profiles.
You can adjust and save the following settings to create a customized view:
•

Filter selection

•

Additions or removal of columns

•

Column width

•

Column sorting

•

Grouping selections on the view

•

Detail views that display for the selected main view

•

Width and height sizing of the view

Steps

1. Open or close detail views, select grouping options, set column filters, add or remove columns,
size the view, and set the column width and sort.
2. To save these selections as your profile, select View > Save Profile.
3. Enter a name for your profile in the dialog box.
4. Optionally, check to make this profile available to all Insight users.
5. Click OK.
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After you finish

You can save multiple profiles for the same view and switch between them to follow different use
cases easily. To view a list of the Insight profiles, select Tools > Settingsand Profiles from the tree.

Managing profiles for custom views
You can set the filter, set grouping options, and adjust columns on a view to the way you prefer to see
the data in the view. You can then save these settings in a profile. When you return to the view, you
can display the view with your customized settings simply by selecting the view profile. You can
share profiles with others or delete profiles.
Before you begin

You must have already created a profile on a view to see the profile listed here.
About this task

You can share profiles with other Insight users. There are two types of profiles:
•

User profiles: Profiles that you do not share with other Insight users.

•

Shared profiles: Profiles that you share with other Insight users.

You can remove only those profiles that you own.
Steps

1. From the Insight Client menu, select Tools > Settings.
2. In the left tree of the Settings, click the Profiles option.
3. To share a profile with other users, click the profile in the User Profiles tab and click Share
Profile. Insight requests confirmation; click Yes.
Insight removes the profile from the User Profile tab and moves it to the Shared Profiles tab.
4. To remove a profile, click the profile and click Remove.

Setting preferences and defining your environment
You can set general preferences, set Auto Resolution (AR) preferences, set global and SAN path
policies, set thresholds at which alerts and violations are triggered, and configure annotations.
About this task

You can set the following types of preferences using the Settings option:
•

Auto Resolution (AR) preferences: Using the AR feature, Insight can identify devices in your
environment, determine device types, and associate devices to a host. You can enable or disable
this option and you can configure the AR schedule and settings.
You can also enter domain names that can be appended to a host name when using DNS Lookup
to resolve the host name.

•

General preferences: Configure how you want Insight to handle the display of data when closing
Insight, the display of the navigation bar (on the left), the display of progress, the number of tabs
that can be open, and the identity of tabs that open at startup. You can also set whether you want
to truncate device labels in the Topology views.
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•

Policies: You can set policies that govern minimal requirements for the availability, thresholds,
performance, and security of a path. You might specify an individual policy for a special host
environment or an individual path that has an ongoing relationship to a specific volume.

•

Profiles: Configure a view and save the settings in a profile.

Setting general preferences
With the general preference settings, you can configure how you want Insight to display the main
views and topology labels. You can also configure when to log out automatically.
Steps

1. From the Insight Client menu, select Tools > Settings.
2. In the left panel of the Settings dialog box, select the General Preferences option.

3. Configure the following settings:
•

Pop-up progress dialog
Select this to display a Progress dialog box automatically whenever a task such as loading
data for a view takes longer than 1.5 seconds to complete.

•

Confirm when exiting OnCommand Insight
Select this to display a prompt that requests confirmation when exiting the Client. Clear the
check box to prevent the prompt from showing. You can also prevent the prompt from
displaying by checking “Don't show this message again” when you log out.

•

Restore open main view tabs at start up
Select this to display all tabs that were open at the end of the last session when Insightstarts.

•

Close main views automatically
Select this to close all the tabs automatically when you exit Insight.

•

Number of open main views before closing
Enter the number of tabs that can remain open at any time. If a new tab is opened and it
exceeds the limit set here, the oldest (right-most) tab automatically closes.
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•

Use Navigation pane
Select this to enable the left panel navigation through the groups of main views.

•

Truncate labels in Topology views
Select this to shorten the names of devices in the Topology views. You might want to do this
to make the Topology view more easily scanned.

•

Display bars in percentage columns
Select this option to show a graphic representation of the percentage in addition to the
percentage number.

•

Show topology watermark
Select this to display a watermark image under the Topology view. You might want to insert
this image so that when someone prints the image, the image shows a watermark such as
"Confidential" underneath the image. This watermark appears on the display, in the printed
version, and in the exported version of the Topology.

•

Watermark text
If you enable the Topology watermark, enter the text that should appear in the watermark, for
example, "Confidential" or your company name.

•

Log out of OnCommand Insight when idle
Number of minutes the user is idle before logging out: Enter the number of minutes that users
can remain idle before the system logs them out. Five minutes prior to this, users receive a
warning indicating that they will be logged out in five minutes, if they do not initiate any
activity.

4. To save settings on this view and continue with other settings, click Apply; otherwise, click OK.

Creating global SAN path policies
To establish global SAN path policies easily, create global policies for the Fibre Channel and iSCSI
environments. This feature is available with the Assure license.
Steps

1. On the main menu, select Tools > Settings.
2. In Settings, expand the Policies tree.
3. Select FC Global Path for Fibre Channel global policies or iSCSI Global Path.
4. Click the tab to define a specific type of global policy.
In this example, the types of Fibre Channel global policies are accessed using these tabs:
•

Storage

•

Volume Type Exceptions

•

Volume Capacity Exceptions

•

Tape

•

Backend Path
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Related references

Settings for FC global policies on page 48

Setting up the reservation policy
The reservation policy lets you set the severity for available reservation violations. This policy is
applied to all reservations.
Steps

1. From the Client menu, select Tools > Settings.
2. In the Settings window, expand the Policies tree.
3. Select Reservations.

4. Select Warning, Error, or Ignore for each field. The violation severity can be set to error or
warning, or the violation can be ignored.
5. Click OK.
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Customizing the Java UI reference
If you want to customize the Insight Java UI, you can use any of these features.

General Preferences view
You use this view to configure how you want Insight to act when closing the program, the display of
the Navigation pane, the display of progress, the number of main views that can be open, and the
main views that open at startup. Use this view also to set whether you want to truncate device labels
in the Topology views.
Navigation
From the Insight Client menu, select Tools > Settings. In the left tree of the Settings view, click the
General Preferences option.
Field descriptions
Pop-up progress dialog during long-running tasks
Select this check box to display the progress bar automatically whenever a task, such as
loading data for a view, takes longer than 1.5 seconds to complete. Clear this selection to
prevent the dialog box from showing automatically. The Progress dialog box displays the
progress of any Insight operation. You can also open the Progress dialog box from the
Client status bar by clicking the progress area between the device icon on the left and the
information ("i") icon, or by selecting View > Progress. A progress indicator appears in
the status bar regardless of whether this option is enabled.
Confirm when exiting OnCommand Insight
Select this check box to display a prompt that requests confirmation when exiting the
Client. Clear the check box to prevent the prompt from showing.
Restore open main views at start up
Select this check box to display all main views that were open at the end of the last
session when Insight starts.
Close main views automatically
Select this check box to limit the number of open main views displayed in Insight at the
same time.
Number of open main views before closing
Enter the number of main views that can be open at any time. If a new main view is
opened and the number of open views is at the limit set here, the oldest (right-most) view
tab automatically closes.
Use Navigation pane
Select this check box to enable the Navigation pane. The Navigation pane provides quick
access to the Dashboard and main views at all times.
Truncate labels in Topology views
Select this check box to shorten the names of devices in the Topology views. If the name
of the device is too long, the name is truncated and an ellipsis is added. You can see the
full name by positioning your mouse pointer over the device name.
Display bars in percentage columns
In columns that display percentage data, display the data as a bar. If disabled, only
numerical data appears. Enabling or disabling the feature takes effect as soon as you click
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Apply or OK. It is not necessary to restart the Client or exit the dialog box. The feature is
enabled by default.
Show topology watermark
Select this check box to display a watermark image under the corners of Topology view.
You might want to do this so that when someone prints the image, the watermark such as
"Confidential" appears underneath the image. This watermark appears on the display, in
the printed version, and in the exported version of the Topology.
Show transient violations
Select this check box to display all violations in the Changes main view. Clearing the box
removes from the display any violations that were generated by maintenance or other
planned activities.
Watermark text
If you enable the Topology watermark, enter the text that should appear in the watermark,
for example, "Confidential" or your company name.
Log out of OnCommand Insight when idle: Number of minutes the user is idle before
logging out
Enter the number of minutes that users can remain idle before the system logs them out.
Starting at five minutes prior to this and counting down to 0, users receive a warning
indicating that they will be logged out in x minutes, if they do not initiate any activity.
Related tasks

Setting general preferences on page 44

Settings for FC global policies
The Fibre Channel global path policies have these settings and tabs.
Navigation
Select Policy > FC Global Policy.
Settings and tabs
To establish the global Storage policies, be certain to check the "automatically authorize" option to
implement the changes and then select the appropriate settings for your environment. Click these
additional tabs to set special criteria for your FC global policies:
•

Volume Type Exceptions

•

Volume Capacity Exceptions

•

Tape

•

Storage

•

Backend Path
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Settings
Redundancy level

Sharing

Options and Definitions
•

None - No redundancy is required on the path

•

No SPF - If you select this No Single Point of Failure option,
the policy requires at least two paths between the host and its
storage device, and OnCommand Insight verifies that each path
travels through unique devices. In other words, all SAN devices
traversed by a given path must be redundant. If two paths use the
same switch, the switch is a possible point of failure for both
paths and would be marked as a violation.

•

Redundant - The policy requires the host to reach the storage
device through at least two different fabrics.

Level of volume sharing permitted by the host, as follows:
•

Any - Any host can share the storage volume with the host
assigned to this policy.

•

No Sharing - All access to the volume must originate from the
host device on the path. If another host accesses the same
volume, the host assigned to this policy will be in violation of its
policy.

•

Application - Hosts that share at least one application with this
host can share the same volume, but other hosts cannot. If a host
accesses the same volume but does not share at least one
application, the host assigned to this policy is in violation of its
policy.

You can ignore the application-sharing setting for the policy on an
application-by-application basis.
Min virtualizer ports

Minimum number of virtualizer ports that should be active for the
path.

Min backend storage ports

Minimum number of backend storage ports that can be set per path.

Min host port count

Minimum number of host ports that should be active (that is, have
access to the storage volume or tape device) for the path.

Min storage port count

Minimum number of storage ports that can be set per path.

Maximum switch hops

Maximum number of switch hops on the shortest path between the
host and its storage data on the path.

Related tasks

Creating global SAN path policies on page 45

Settings for Host Virtualization policies
You can set a policy that monitors for active/passive volume multipathing, for identical volume
access for hosts in a virtual cluster, and for identical volume LUN for virtual cluster hosts.
Navigation
From the Client menu, select Tools > Settings. In the left tree of the Settings view, click the Policies
> Host Virtualization option.
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Field descriptions
The Host Virtualization policy is enabled by default on all hosts.
Single storage processor for volume active paths
Alerts the SAN administrator that a volume is being actively accessed via multiple storage
processors. For storage arrays that maintain active/passive multipathing, this will result in
storage performance degradation (and even service interruption).
Storage models
If you enabled the Single storage processor for volume active paths option, select the
storage models that are active/passive and that should not allow access through multiple
storage processors to the same volume.
Identical volume access for hosts within a virtual cluster
Alerts the SAN administrator that some hosts in a virtual cluster cannot access volumes
other members of the group can. Such a configuration may cause these hosts to be unable
to run virtual machines that other hosts in the cluster are able to run. (This is also
applicable for NAS shares.)
Identical volume LUN for hosts within a virtual cluster
Alerts the storage administrator that a volume is presented to different members of a
virtual cluster using different LUNs.

Settings for iSCSI global policies
When you are defining iSCSI global path policies, use these settings.
Navigation
From the Client Main Menu, select Policy > iSCSI Global Policy.
Settings and tabs
To establish the global Storage policies, be certain to check the "automatically authorize" option to
implement the changes and then select the appropriate settings for your environment. Click these
additional tabs to set special criteria for your iSCSI global policies:
•

Storage

•

Volume Type Exceptions

•

Volume Capacity Exceptions
Settings

Options and Definitions

Require Security (iSCSI)

Yes or No
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Settings

Options and Definitions

Sharing

Level of volume sharing permitted by the host is defined by one of
these options:
•

Any - any host can share the storage volume with the host
assigned to this policy.

•

No Sharing - All access to the volume must originate from the
host device for the path. If another host accesses the same
volume, the host assigned to this policy is in violation of its
policy.

•

Application - Hosts that share at least one application with this
host can share the same volume, but other hosts cannot. If a host
accesses the same volume but does not share at least one
application, the host assigned to this policy is in violation of its
policy.

You can ignore the application-sharing setting for the policy on an
application-by-application basis.
Min Sessions

Minimum number of sessions required.

Min Connections

Minimum number of connections required.

Settings for Reservation policies
The reservation policy lets you set the severity for available capacity reservation violations. This
policy is applied to all request reservations.
Navigation
From the Insight Client menu, select Tools > Settings. In the left tree of the Settings view, click the
Policies > Reservations option.
To establish reservation policies, the Insight Plan license must be enabled.
Field descriptions
Select Warning, Error, or Ignore indicating the severity of the violation for each of the following
fields.
Requests overdue by x days
Displays a violation if a request has not been addressed for the number of days set here.
The request is in the Open or New state and it is past the due date. You can set a buffer of
x days, where Insight ignores the violation until the due date plus the x days set here have
passed.
Reservations on resources past sunset
Displays a violation if a reservation was placed on a device or resource whose date has
expired. Controls the severity of "Reserved device past Sunset" violation. This refers to
the resource's end of life. In the context of reservations, you can mark a switch, storage, or
volume with the sunset annotation when you no longer need to use it.
Note: Sunset, Hot, and Data Center are set as annotations. Sunset and Hot are date
annotations; however, the reservation system ignores the date. A device in "sunset" is
scheduled for replacement or removal. A "hot" device is over-utilized according to the
threshold you set.

Reservations on hot resources
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Displays a violation on reservations made on hot resources. This setting controls the
severity of the following "hot" violations:
•

"Hot storage reserved" violations, where the storage has a hot annotation.

•

"Hot switch reserved" violations, where the switch has a hot annotation.

Incorrect reservation
Displays a violation on reservations that do not have correct information. This option
controls the severity of the "Incorrect Data Center reserved" violation. The reserved
volume belongs to a different data center than the requested data center.
Potentially incorrect reservation
Displays a violation on reservations that might not have correct information. This option
controls the severity of the following violations:
•

Verify volume resolution violations, where the reserved volume is of a different tier
than the requested volume.

•

Reservation exceeds requirement violations, where there are more reserved ports than
requested.

Incorrect allocation
Displays a violation if the capacity allocation related to the request is incorrect. This
option controls the severity of the following violations:
•

Incorrect volume allocation. This indicates the allotted volume does not map to the
requested host.

•

Incorrect port allocation. This indicates that the allocated port does not connect to the
requested hosts.

Potentially incorrect allocation
Displays a violation if the capacity allocation related to the request seems incorrect.
Controls the severity of the following violations:
•

Verify volume allocation violation. This is a warning that occurs when the request
target called "Other" is used. A volume was requested, reserved, and is now mapped to
a host. When "other" is used, this indicates that you are not sure which host is going to
receive the volume. The reservation system creates this violation as a way for you to
verify that the assigned host is the one intended.

•

Verify port allocation violation. This is a warning that occurs when the request target
called "Other" is used. A port was requested, reserved, and is now connected to a host.
When "Other" is used, this indicates that you are not sure which host is going to
connect to this port. The reservation system creates this violation as a way for you to
verify that the assigned host is the one intended.

•

Allocation for canceled request violations. This indicates that a port or volume was
allocated, but the request is now canceled.

Missing resource
Displays a violation if the resource associated with the request cannot be located. This
option controls the severity of the following violations:
•

Reserved inactive port violations. This indicates that the reserved port is inactive or
dead.

•

Reserved inactive storage violations. This indicates that the reserved storage is inactive
or dead.
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•

Reserved inactive volume violations. This indicates that the reserved volume is
inactive or dead.

Settings for Profiles
You can set the filter, set grouping options, and adjust columns on a view to customize the way data
is shown in a view You can then save these settings in a profile. When you return to the view, you can
display the view with your customized settings simply by selecting the view profile. You can share
profiles with others or delete profiles.
Navigation
From the Insight Client menu, select Tools > Settings. In the left tree, click Profiles.
The Profiles option includes two tabs:
•

User Profiles: Lists profiles that you do not share with other Insight users.

•

Shared Profiles: Lists profiles that you share with other Insight users.

Field descriptions
Profile
Name of the profile that you can use for a specific view.
Screen
Name of the screen to which the profile applies.
Option
Remove
Deletes the profile from the set of profiles. You can remove only those shared profiles that
you own. After you remove the profile, you can no longer use it.
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Identifying hosts and tapes automatically with
automatic resolution
Insight identifies devices in your environment automatically. Typically, after you set up data sources,
you then use the automatic resolution (AR) feature to determine the types of those devices and to
attach those devices to a host. You can enable or disable this option and you can configure AR
settings.
Steps

1. Open the Insight Client and locate the AR icon on the status bar.
•

: AR is enabled.

•

: AR is disabled.

2. If AR is disabled, select the AR icon to enable it.
3. Select Tools > Settings > Auto Resolution to set the AR schedule and preferences.
Result

After the host or tape resolution process is complete, Insight shows the identified host name and IP
address in the Java UI views. Even after automatic host or tape resolution is completed, you can
override the AR identifications. After Insight tries to identify devices automatically, there might be
some devices that Insight cannot identify. You should identify these devices manually.

Setting host and tape automatic resolution schedule and
preferences
You can schedule the automatic resolution (AR) for hosts and tapes and other preferences.
Steps

1. Do one of the following:
•

From the Insight Client, select Tools > Settings > Auto Resolution.

•

In the Client status bar, click the AR option.

2. In the Auto Resolution settings page, click the Preferences tab.
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3. Configure the AR schedule by selecting one of the provided options.
•

Every time a change occurs in the environment

•

Every day at a specific time

•

At a set interval of time in hours, days, or weeks (for example, every two hours)

•

Manually only, using the FC Identify view or IP Identify view.
This disables scheduling of automatic host resolution.

4. Complete the following:
Option

Description

Domain Names

Configure one or more domain names that Insight appends to the
potential host name before the DNS lookup and validation. To include
multiple names, separate them with semicolons.

Append domain name

Check this to append the domain name to the resolved host name and
display that in the Java UI views.

Allow underscore in host
names

Check this to allow underscores in host names.

Prefer 'connected to' alias

Check this to use the “connected to” alias instead of the standard port
alias.

Enable automatic resolution
of IPs

Check this to enable automatic host resolution for iSCSI initiators and
hosts accessing NFS shares by using DNS lookup. If this check box is
not selected, only FC-based resolution is performed.

Enable DNS lookup result
processing

Check this to enable post processing of names used in DNS lookups
using regular expressions (as set up on the Methods tab). This option runs
a regular expression on the name provided to the DNS lookup and returns
the matching result as the resolution name rather than the name used for
DNS lookup. This process further transforms the resulting name.
See the full description and examples in the Auto Resolution Preference
settings information for this view.

5. Click Apply to apply the changes.
After you finish

Continue with the Methods and Storage and Tape Vendors tabs.
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Auto Resolution (AR) Preference settings
The preference options for automatic resolution let you set the domain names that are appended to
the resolved host or tape name and define a schedule.
You can configure the following AR preferences:
•

Set a schedule for AR.

•

Enable or disable AR by setting the schedule to the Manual Only option.

•

Enter domain names that can be appended to a resolved host name during DNS lookup to resolve
the host name.

•

Select whether you want to show a “connected to” alias instead of the standard port alias.

•

Enable automatic host resolution for iSCSI initiators and hosts accessing NFS shares by using DN
lookup.
If this check box is disabled, only-FC-based resolution is performed.

Field descriptions
Set auto resolution schedule
The following options allow Insight to resolve host or tape identification:
•

Every time a change occurs in the environment

•

Every day at a specific time

•

At a set interval of time in hours, days, or weeks (for example, every 2 hours)

•

Manually only using the IP Identify view. This disables scheduling of automatic host
or tape resolution.

Domain names
Specifies one or more domain names for Insight to append to the resolved host name
during the DNS lookup and validation. Separate multiple names with semicolons.
Append domain name
Adds the domain name to the resolved host name and displays it in Java UI views.
Allow underscore in host names
Allows underscores in host names.
Prefer 'connected to' alias
Uses the “connected to” alias instead of the standard port alias.
Enable automatic resolution of IPs
Enables automatic host resolution for iSCSI initiators and hosts accessing NFS shares by
using DNS lookup. If not specified, only FC-based resolution are performed.
Enable DNS lookup result processing
Allows post processing of names used in DNS lookups using regular expressions (as set
up on the Methods tab). This option runs a regular expression on the name provided to the
DNS lookup and returns the matching result as the resolution name rather than the name
used for DNS lookup. This process further transforms the resulting name.
Regular expression
Identifies the regular expression you want to use to post-process the name before
assigning it to a device.
Format
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Indicates how to format the matching text to get the result you want. When you use
\n, it substitutes the text that matches the “nth” set of parentheses. For example, to
remove the domain name from the source text of hostA.netapp.com, the regular
expression is (.*)\.netapp\.com and the format is \1 which retains the

characters in the first set of parentheses.
The following examples illustrate the post-processing results.
Intent

Source text

Regular
expression

Format

Result

Retain entire
source text

host_123

(.*)

\1

host_123

Retain prefix
and suffix

host_123

(.*)_(.*)

\1\2

host_123

Replace text in
first
parentheses
with "app" and
retain text in
second set of
parentheses

host_123

(.*)_(.*)

app\2

app123

Remove the
text in the first
set of
parentheses
and replace the
text in the
second set of
parentheses
with "app" and
insert a dash.

host_123

(.*)_(.*)

app-\2

app-123

Retain text in
first set of
parentheses but
remove domain
name

hostA.netapp.c
om

(.*)\.netapp
\.com

\1

hostA

Manually enabling or disabling automatic resolution by
using the Identify views
Using the FC Identify or IP Identify views, you can manually enable automatic resolution so that
Insight can identify devices in your environment.
Before you begin

You have configured automatic resolution to run manually from the Identify views.
Steps

1. Access the Client.
2. Select Configuration > IP Identify or Configuration > FC Identify.
3. At the upper right of the view, click the Auto Resolution green arrow.
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4. To stop AR processing, click the red square.

Setting automatic resolution methods
Insight can identify devices in your environment, determine device types, and attach devices to hosts
using the automatic resolution (AR) feature. You can set the method that Insight uses to extract and
validate host names during host identification. You can enable DNS lookup as a method to validate
host names; you can match patterns of source names, or you can use the host name exactly as it
appears in your Storage Resource Management (SRM) software.
Steps

1. Do one of the following:
•

From the Insight Client, select Tools > Settings > Auto Resolution.

•

In the Client status bar, click the AR option.

2. In the Auto Resolution settings page, click the Methods tab.

3. In the Methods tab, to change the order in which the sources are used to identify hosts, click the
source row and click Up or Down.
4. For the Re-evaluate column, do one of the following:
•

Ensure that the Re-evaluate check box is not selected.
Insight continues to apply the rule that successfully identified the device. In other words,
identifications stick to the rule that completed the match.

•

Select the Re-evaluate check box.
Insight uses the selected rule to re-identify the device, again looking through all the rules in
the order in which they appear. This is especially helpful if you change your strategy for
device naming, such as naming with storage aliases. Without this selection, you would have to
unidentify the device and configure AR again. With this check box selected, the software can
identify the device using your new strategy. The ability to migrate without unidentification
enables you to preserve any annotations and policies that have been applied to the host.

Insight attempts to identify a device by using the rules in the order in which they appear. After
identification is complete, Insight typically uses the same rule that successfully performed the
identification to process future identifications. Insight does not run through the rules in order as it
did before. However, you can change that by using the Re-evaluate check box.
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5. Select the sources (for example, switch alias or zone) that should be used as a source to identify
the host.
There is a row for each combination of source, method, and validation: for example, SRM might
have five lines.
6. To change the delimiters or regular expression used as the method to identify host names, do the
following:
a. Click the row.
b. Click Configure.
7. Do one of the following:
•

To configure a regular expression, see "Using regular expressions in host identification
methods."

•

To change the delimiter information, continue with the next step.

•

(Applicable only with SRM) To use the host name exactly as it appears in the SRM software,
check As Is . Insight might or might not verify the host name using DNS.

8. If you selected a source with a delimiters method, the Delimiters Configuration dialog box
enables you to change the delimiter information (which represents how the data is to be delimited:
for example, with commas to separate one data from the next).

a. In the Delimiters text box, enter the character used to separate the values of the devices.
The default value is the combination of an underscore (_) and a hyphen (-).
b. In the Minimum length of Host Name text box, enter the minimum number of characters that
Insight should use to identify a host.
Insight performs DNS lookups only for host names that are this long or longer.
c. Click OK.
9. Click Apply to apply the changes.
10. Navigate to the Storage and Tape Vendors tab.

Auto Resolution (AR) methods settings
You can set up the methods that Insight uses to extract and validate host or tape names. You can
configure Insight to validate switches by DNS Lookup. You can also set the order in which Insight
performs the name extraction methods.
AR method components
The method that you choose depends upon the source naming strategy employed in your environment
and affects the validation process used to validate the resolution. For example, for host names
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encoded as part of a switch alias, you can extract host names by entering delimiters or by using
regular expressions to enter pattern search criteria. The methods consist of two components.
•

The source of the data used to identify the host: for example, a switch alias, zone, or SRM

•

The method used to extract and validate host or tape names. This includes delimiter pattern
matching or regular expression use (tape resolution can use only regular expression matching).

Field descriptions
Source
Sources used to identify the host can include the following:
•

Zone names containing embedded host names

•

Switch alias names containing embedded host names

•

Storage alias names containing embedded host names

•

Storage Resource Management (SRM) software

Sources used to identify the tape can include the following:
•

Zone names containing embedded host names

•

Switch alias names containing embedded host names

Method
Indicates the type of method by which Insight extracts and validates host or tape
information for the selected source. To configure the method, select the row and click
Configure.
Methods include the following:
•

Delimiters
Use delimiters when you want to match patterns of the source names (applies to host,
not tape, resolution).
The host name is part of the source text, bounded by specific characters. For example,
if your zones are named with a pattern combining the host name and the storage name,
with the _ character as the separator, you can use the zone source method with the
delimiter configured to use this character, as in the following example:
blade14_ds4800_1 (where blade14 is the host name)
If you use delimiters, you must verify the host name using a DNS lookup.

•

Regular expressions
Use one or more regular expressions to identify the host or tape name from source
names. If you use regular expressions, you can verify the host or tape name by using
DNS lookup or by using another validation process.

•

As Is (SRM source only)
Use this to use the host name exactly as it appears in the Storage Resource
Management (SRM) software. If you use this, you can verify the host name by using
DNS lookup or by using another validation process (applies to host, not tape,
resolution).

Validation
Indicates whether Insight validates each resolved host or tape name for the selected
source. With DNS lookup, a host name is considered valid if it is found as a name in the
DNS servers that the Insight Server can access.
Re-evaluate
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Indication of whether to reevaluate the rule.
Insight attempts to identify a device by using the rules in the order in which they appear.
After identification is complete, Insight typically uses the same rule that successfully
performed the identification to process future identifications. Insight does not run through
the rules in order as it did before. However, you can change that by using the Re-evaluate
check box.
Do one of the following:
•

Uncheck the Re-evaluate column. Insight continues to apply the rule that successfully
identified the device. In other words, identifications stick to the rule that completed the
match.

•

Check Re-evaluate. Insight uses the checked rule to re-identify the device, again
looking through all the rules in the order in which they appear.
This is especially helpful if you change your strategy for device naming such as
naming with storage aliases. Without this verification, you would have had to
“unidentify” the device and configure AR again. With this check box selected, Insight
can identify the device using your new strategy. The ability to migrate without having
to unidentify the device enables you to preserve any annotations and policies that have
been applied to the host.

Options
Configure
Choose this to change the delimiter or regular expression method to extract host or tape
information from the selected source.
Up/Down
Use this to move the selected source row up or down in the table.

Using regular expressions in host or tape identification methods
You can create a regular expression for Insight to use when resolving the host or tape name. This can
be done from zone names or from switch, storage, or SRM software alias names, according to the
methods specified in the Methods tab.
Steps

1. Do one of the following:
•

From theInsight Client, select Tools > Settings > Auto Resolution.

•

In the Client status bar, click the AR option.

2. In the Auto Resolution settings page, click the Methods tab.
3. Select the check boxes next to the sources (for example, switch alias or zone) that should be used
as a source to identify the host.
There is a row per combination of source, method, and validation. For example, SRM might have
five lines.
4. To change the method (delimiters or regular expression) used to identify host names, do the
following:
a. Click the row.
b. Click Configure.
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5. To change the regular expression information (which enables you to enter pattern-matching
expressions), do the following:

a. To add a new expression, click Add.
Add a rule to identify host names for generic devices.
b. To edit an expression, click in the RegExp field and click the [...] icon to open an Editor
dialog box.
Enter the expression directly into the field or enter it in the Editor dialog box. iThe icon
becomes visible only after you click in the RegExp field.
c. To make the expression case sensitive, select Case Sensitive.
d. To move an expression up or down in the list, click the expression and click either Up or
Down.
The order in which the expression appears is the order in which the software evaluates
expressions.
e. To preview the resulting host identification based on the set of expressions in the list, click
Preview.
f. To validate each potential host name against DNS, select DNS Validation.
g. In the No Match section, view the list of generic devices that do not match any of the regular
expressions entered.
Use this information to add or change an expression so that these devices are resolved.
h. Click OK to return to the Methods tab.
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6. In the Methods tab, to change the order in which the sources are used to identify hosts, click the
source row and click Up or Down.
7. Click Apply to apply the changes.
After you finish

Continue with the Storage and Tape Vendors tab.

Regular expression examples
If you have selected the regular expression approach as your source naming strategy, you can use the
following regular expression examples as guides for your own expressions used in the OnCommand
Insight automatic resolution methods.
Formatting regular expressions
When creating regular expressions for OnCommand Insight Automatic Resolution, you can configure
output format by entering values in a field named FORMAT.
The default setting is \1, which means that a zone name that matches the regular expression is
replaced by the contents of the first variable created by the regular expression. In a regular
expression, variable values are created by parenthetical statements. If multiple parenthetical
statements occur, the variables are referenced numerically, from left to right. The variables can be
used in the output format in any order. Constant text may also be inserted in the output, by adding it
to the FORMAT field.
For example, if the zone naming convention is:
[Zone number]_[data center]_[hostname]_[device type]_[interface number]

You might have the following zone names:
•

S123_Miami_hostname1_filer_FC1

•

S14_Tampa_hostname2_switch_FC4

•

S3991_Boston_hostname3_windows2K_FC0

•

S44_Raleigh_hostname4_solaris_FC1

And you might want the output to be in the format:
[hostname]-[data center]-[device type]

To do this, you need to capture the host name, data center, and device type fields in variables, and use
them in the output. The following regular expression would do this:
.*?_([a-zA-Z0-9]+)_([a-zA-Z0-9]+)_([a-zA-Z0-9]+)_.*

Because there are three sets of parentheses, the variables \1, \2 and \3 would be populated.
You could then use the following format to ensure output in your preferred format:
\2-\1-\3

Your output would thus be:
hostname1-Miami-filer
hostname2-Tampa-switch
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hostname3-Boston-windows2K
hostname4-Raleigh-solaris

The hyphens between the variables provide an example of constant text which is inserted in the
formatted output.
Example 1 showing zone names
In this example, you use the regular expression to extract a Host name from the zone name. You
could create a regular expression if you have something similar to the following zone names:
•

S0032_myComputer1Name-HBA0

•

S0434_myComputer1Name-HBA1

•

S0432_myComputer1Name-HBA3

The regular expression that you could use to capture the host name would be:
S[0-9]+_([a-zA-Z0-9]*)[_-]HBA[0-9]

The outcome is a match of all zones beginning with S that are followed by any combination of
digits , followed by an underscore, the alphanumeric hostname (myComputer1Name), an underscore
or hyphen, the capital letters HBA, and a single digit (0-9). The hostname alone is stored in the \1
variable.
The regular expression can be broken into its components:
•

"S" represents the zone name and begins the expression. This matches only an "S" at the
beginning of the zone name.

•

The characters [0-9] in brackets indicate that what follows "S" must be a digit between 0 and 9,
inclusive.

•

The + sign indicates that the occurrence of the information in the preceding brackets has to exist 1
or more times.

•

The _ (underscore) means that the digits after S must be followed immediately by only an
underscore character in the zone name. In this example, the zone naming convention uses the
underscore to separate the zone name from the host name.

•

After the required underscore, the parentheses indicate that the pattern contained within will be
stored in the \1 variable.

•

The bracketed characters [a-zA-Z0-9] indicate that the characters being matched are all letters
(regardless of case) and numbers.

•

The * (asterisk) following the brackets indicates that the bracketed characters occur 0 or more
times.

•

The bracketed characters [_-] (underscore and dash) indicate that the alphanumeric pattern must
be followed by an underscore or a dash.

•

The letters HBA in the regular expression indicate that this exact sequence of characters must
occur in the zone name.

•

The final set of bracketed characters [0-9] match a single digit from 0 through 9, inclusive.

Example 2
In this example, skip up to the first underscore "_" then match E and everything after that up to the
second "_" then skip everything after that.
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Zone: Z_E2FHDBS01_E1NETAPP
Hostname: E2FHDBS01
RegExp: .*?_(E.*?)_.*?
Example 3
The parentheses "( )" around the last section in the Regular Expression (below) identifies which part
is the hostname. If you wanted VSAN3 to be the host name, it would be: [a-zA-Z0-9]+_([a-zAZ0-9]+).*
Zone: A_VSAN3_SR48KENT_A_CX2578_SPA0
Hostname: SR48KENT
RegExp: [a-zA-Z0-9]+_[a-zA-Z0-9]+_([a-zA-Z0-9]+).*
Example 4 showing a more complicated naming pattern
You could create a regular expression if you have something similar to the following zone names:
•

myComputerName123-HBA1_Symm1_FA3

•

myComputerName123-HBA2_Symm1_FA5

•

myComputerName123-HBA3_Symm1_FA7

The regular expression that you could use to capture these would be:
([a-zA-Z0-9]*)_.*

The \1 variable would contain only myComputerName123 after being evaluated by this expression.
The regular expression can be broken into its components:
•

The parentheses indicate that the pattern contained within will be stored in the \1 variable.

•

The bracketed characters [a-zA-Z0-9] mean that any letter (regardless of case) or digit will match.

•

The * (asterisk) following the brackets indicates that the bracketed characters occur 0 or more
times.

•

The _ (underscore) character in the regular expression means that the zone name must have an
underscore immediately following the alphanumeric string matched by the preceding brackets.

•

The . (period) matches any character (a wildcard).

•

The * (asterisk) indicates that the preceding period wildcard may occur 0 or more times.
In other words, the combination .* indicates any character, any number of times.

Example 5 showing zone names without a pattern
You could create a regular expression if you have something similar to the following zone names:
•

myComputerName_HBA1_Symm1_FA1

•

myComputerName123_HBA1_Symm1_FA1

The regular expression that you could use to capture these would be:
(.*?)_.*
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The \1 variable would contain myComputerName (in the first zone name example) or
myComputerName123 (in the second zone name example). This regular expression would thus
match everything prior to the first underscore.
The regular expression can be broken into its components:
•

The parentheses indicate that the pattern contained within will be stored in the \1 variable.

•

The .* (period asterisk) match any character, any number of times.

•

The * (asterisk) following the brackets indicates that the bracketed characters occur 0 or more
times.

•

The ? character makes the match non-greedy. This forces it to stop matching at the first
underscore, rather than the last.

•

The characters _.* match the first underscore found and all characters which follow it.

Example 6 showing computer names with a pattern
You could create a regular expression if you have something similar to the following zone names:
•

Storage1_Switch1_myComputerName123A_A1_FC1

•

Storage2_Switch2_myComputerName123B_A2_FC2

•

Storage3_Switch3_myComputerName123T_A3_FC3

The regular expression that you could use to capture these would be:
.*?_.*?_([a-zA-Z0-9]*[ABT])_.*

Because the zone naming convention has more of a pattern, we could use the above expression,
which will match all instances of a hostname (myComputerName in the example) that ends with
either an A, a B, or a T, placing that hostname in the \1 variable.
The regular expression can be broken into its components:
•

The .* (period asterisk) match any character, any number of times.

•

The ? character makes the match non-greedy. This forces it to stop matching at the first
underscore, rather than the last.

•

The underscore character matches the first underscore in the zone name.

•

Thus, the first .*?_ combination matches the characters Storage1_ in the first zone name example.

•

The second .*?_ combination behaves like the first, but matches Switch1_ in the first zone name
example.

•

The parentheses indicate that the pattern contained within will be stored in the \1 variable.

•

The bracketed characters [a-zA-Z0-9] mean that any letter (regardless of case) or digit will match.

•

The * (asterisk) following the brackets indicates that the bracketed characters occur 0 or more
times.

•

The bracketed characters in the regular expression [ABT] match a single character in the zone
name which must be A, B, or T.

•

The _ (underscore) following the parentheses indicates that the [ABT] character match must be
followed up an underscore.

•

The .* (period asterisk) match any character, any number of times.
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The result of this would therefore cause the \1 variable to contain any alphanumeric string which:
•

was preceded by some number of alphanumeric characters and two underscores

•

was followed by an underscore (and then any number of alphanumeric characters)

•

had a final character of A, B or T, prior to the third underscore.

Example 7
Zone: myComputerName123_HBA1_Symm1_FA1
Hostname: myComputerName123
RegExp: ([a-zA-Z0-9]+)_.*
Example 8
This example finds everything before the first _.
Zone: MyComputerName_HBA1_Symm1_FA1
MyComputerName123_HBA1_Symm1_FA1

Hostname: MyComputerName
RegExp: (.*?)_.*
Example 9
This example finds everything after the 1st _ and up to the second _.
Zone: Z_MyComputerName_StorageName
Hostname: MyComputerName
RegExp: .*?_(.*?)_.*?
Example 10
This example extracts "MyComputerName123" from the zone examples.
Zone: Storage1_Switch1_MyComputerName123A_A1_FC1
Storage2_Switch2_MyComputerName123B_A2_FC2
Storage3_Switch3_MyComputerName123T_A3_FC3

Hostname: MyComputerName123
RegExp: .*?_.*?_([a-zA-Z0-9]+)*[ABT]_.*
Example 11
Zone: Storage1_Switch1_MyComputerName123A_A1_FC1
Hostname: MyComputerName123A
RegExp: .*?_.*?_([a-zA-z0-9]+)_.*?_
Example 12
The ^ (circumflex or caret) inside square brackets negates the expression, for example, [^Ff] means
anything except upper or lower case F and [^a-z] means everything except lower case a to z, and in
the case above, anything except the _. The format statement adds in the "-" to the output host name.

68 | OnCommand Insight Inventory User Guide

Zone: mhs_apps44_d_A_10a0_0429
Hostname: mhs-apps44-d
RegExp: ([^_]+)_([AB]).*Format in OnCommand Insight: \1-\2 ([^_]+)_
([^_]+)_([^_]+).*Format in OnCommand Insight: \1-\2-\3

Example 13
In this example, the storage alias is delimited by "\" and the expression needs to use "\\" in order to
define that there are actually "\" being used in the string, and that those are not part of the expression
itself.
Storage Alias: \Hosts\E2DOC01C1\E2DOC01N1
Hostname: E2DOC01N1
RegExp: \\.*?\\.*?\\(.*?)
Example 14
This example extracts "PD-RV-W-AD-2" from the zone examples.
Zone: PD_D-PD-RV-W-AD-2_01
Hostname: PD-RV-W-AD-2
RegExp: [^-]+-(.*-\d+).*
Example 15
The format setting in this case adds the "US-BV-" to the hostname.
Zone: SRV_USBVM11_F1
Hostname: US-BV-M11
RegExp: SRV_USBV([A-Za-z0-9]+)_F[12]
Format: US-BV-\1

Adding or excluding automatic resolution storage and tape
vendors
You can add or exclude specific storage and tape vendors for automatic resolution. You might want to
exclude specific vendors if you know, for example, that a specific host will become a legacy host and
should be excluded from your new environment. You can also re-add vendors that you earlier
excluded but no longer want excluded.
Steps

1. Do one of the following:
•

From the Insight Client, select Tools > Settings > Auto Resolution.

•

In the Client status bar, click the AR option.

2. In the Auto Resolution Settings page, click the Storage and Tape Vendors tab.
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3. To exclude a vendor from the host identification process, do the following:
a. Click Add/Remove.
b. In the list of Available Vendors in the Select Storage and Tape Vendors dialog box, click the
vendor that you want to exclude.
c. Select the vendor name or names to add.
d. Click Add.
e. Click OK.
4. To re-add a vendor, so that it is no longer excluded from the host identification process, do the
following:
a. Click Add/Remove.
b. In the list of Selected Vendors in the Select Storage and Tape Vendors dialog box, click the
vendor that you want to remove from the exclusion list.
c. To look for vendors, click the magnifying glass icon in the left pane.
d. Enter part of the name.
The list shows all vendors that contain the entered text.
e. Click Remove.
f. Click OK.
Insight updates the list of vendors to be excluded from the host identification process.
5. Click OK.

Auditing automatic host and tape resolution
You can use the configuration options to audit the host and tape resolution or change the
identification or re-identification events.
Steps

1. From the Insight Open menu, select Configuration > FC Identify.
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2. In the FC Identify view, review the Audit column.
3. To see detailed information about the AR process, in the status bar, click the Resolution Details
icon.

The Resolution Details detail view shows the sequence of identification activities related to the
generic device selected in the FC Identify view.

Automatic resolution (AR) status codes
The automatic resolution status codes indicate how a host or tape is identified to the system. The FC
Identify view shows warnings.
Insight shows the following AR status codes related to identification:
Status

Description

Not identified
automatically

All AR rules failed or AR has never run.

Identification failed

AR produced a possible identification, but it conflicts with existing
identifications.

Identified to “X”

Initial identification

Identified to “X”, reidentification disabled

Re-identification was skipped because the method used to identify the
device initially is now disabled in the AR configuration.

Identified to “X”, valid

Re-identification did not detect any changes.

Manually identified

An Insight user performed a manual identification. AR does not attempt
to re-identify this entry.

Matches “X” storage
vendor, ignored

AR identified the generic device as storage and rather than a host, and
ignores the result.

If AR encounters warnings, it appends the text “(with warnings)” to the status value. Use the
Resolution Details detail view to understand the warnings. Warning messages are displayed only for
the following two statuses:
•

Identified to “X”

•

Identified to “X”, valid
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Viewing the environment in Topology maps
You can look at a graphic representation of your SAN or NAS environment using a Topology map.
With the map, you can see the devices and their connections.
Before you begin

You must first select a device in one of the main views.
About this task

You can do the following tasks related to working with Topology maps.
•

Display the Topology maps for a selected device.

•

Select a device in the Topology map, see its details, and expand the map.

•

Display device details.

•

Interpret color in the map.

•

Add a watermark to the map.

•

Manipulate objects in the map.

•

Display different Topology map views.

•

Change the link style on the map.

•

Add connected devices to the selected device from the map.

•

Export information in the map.

Related tasks

Adding a watermark to the Topology view on page 77
Exporting the Topology map layout on page 82

Displaying network Topology maps
When you are viewing the Hosts, Paths, Changes, Generic Devices, or Zones main views, you can
select a resource and display its connections in a visual representation. Choose to display the
Topology view, a view that appears in the center of the Java UI Client.
About this task

The Topology view displays a graphic representation of your SAN or NAS environment based on the
resource you select in the main view. This view displays the devices, connections, and paths. The
data in any opened detail views changes depending on what you select in the Topology view.
You can display a Topology map from the Changes, Paths, Hosts, Generic Devices, or Zones main
views. You cannot access the Topology map from the Switches, Storage Arrays, or Tapes main views.
Steps

1. In the Client, access one of the main views (Changes, Paths, Hosts, Generic Devices, or Zones
view).

72 | OnCommand Insight Inventory User Guide

2. With that main view open, click the Topology icon at the bottom of the view.
The Topology view appears in the center. The following illustration shows the Paths main view,
the Topology view, and two detail views.

3. Optionally, right-click on any object in the Topology map.
Option

Description

Fit on Screen

Fits the topology view inside the display area.

Open Details

Displays detailed properties for the selected device or link.

View In

Displays the current topology view in a separate window, effectively
creating a second topology view. The basic content does not change, even
as you navigate to another host, path, and so on in the main display. You
can perform any actions on the separate window that are available from the
main view.

Export

Exports the topology to a graphic file.

Link Style

Customizes the style of your links.

Manage Device

Launches the third-party management console for the selected device.

Add all
Connected
Devices

Adds to the Topology view any devices to which the selected device is
connected (one hop away).

Add to
Application

Assigns a selected host to a particular application.

Identify

Identifies a generic device.

Related tasks

Examining devices in the Topology view on page 79
Analyzing mismatched zones and masks on page 74
Analyzing missing paths on page 108
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Displaying clustered storage arrays in the Topology view
You can look at your clustered storage using the Topology view to see a graphic representation of the
arrays within the network structure.
Steps

1. From the Storage Arrays view, select a storage array that indicates at least “8.1.x” in the
Microcode Version column.
2. Right-click Analyze.
3. From the Analyze dialog box, click the Topology tab to display the Topology view.
4. In the Topology view, look at the clustered storage.
The clustered storage is represented by the clustered storage icon
appended to the storage array's name.

with the suffix of “cluster”

5. To view details about the array, double-click the Storage Arrays clustered storage icon.
The generated hub switches (for example, Cisco N-Point Virtualization (NPV)) and the
underlying storage array details appear:

6. To view performance information, from the Storage Arrays view, right-click on the clustered
storage row to display a performance menu and select Analyze.
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Analyzing mismatched zones and masks
OnCommand Insight examines network paths to locate possibly mismatched zone and masking
settings. You use the Topology view to analyze the listed paths. Then you can make the necessary
changes to correct the paths.
Steps

1. To analyze possible mismatched zones and masks, select Tools > Analyze Zone and Mask.
The total number of zone and mask path conflicts are listed at the top of the view. Each row
indicates if a path exists and if there is a violation on the path.
2. Review the list and select a row to analyze in the Topology view.
3. If there is a path with two colors between two elements, that means that one element is zoned to a
different element than the element to which it is masked.

4. Position the mouse pointer over the lines and elements in the Topology view to identify each
element precisely.
5. Locate the problematic element in your environment and change to zoning or masking to
coordinate mismatched settings and resolve the problem.

Topology view
Use this view to visualize your SAN or NAS environment, the devices, and their connections. Every
device in your environment is shown as an icon that represents the device type, while physical
connections appear as lines connecting the devices. Each time you select a different device or path in
a main view, the Topology representation changes as well.
Access
You can display a Topology map from the majority of the main views; however, you cannot access
the Topology Map from the Switches, Storage Arrays, or Tapes main views. From a main view, select
a device or path and click the Topology icon in the bottom of the Client view.
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Operations
From the Topology view, you can perform the following operations:
•

Position the mouse pointer over a device or path to see its detail.

•

Click any device icon to view port information.

•

Use the Topology toolbar to adjust settings.

•

Select different view representations on the Topology Map.

•

Change the link style to rounded or square.

•

Add a watermark to the map.

•

Add connected devices.

•

Export the Topology layout as an image.

Related tasks

Exporting the Topology map layout on page 82

Topology map elements
The Topology map is a graphic representation of devices and connections.

The Topology map shows the following information:
•

Start and end points in connections. Target devices are shown in blue. If a path is selected, both of
its endpoints are shown in blue. In an inventory display, the device selected in the main table is
shown in blue.

•

Properties of the devices and connections.

•

SAN paths.

•

NAS paths. ESX servers that are deployed over NAS show the NAS path where the target is a
share. Multiple path selection is not allowed for topology.

•

Icons representing different types of devices, such as ports, adapters, hosts, virtual machines
(VMs), and switches.

•

Insight represents devices identified by using IP Identify with a cloud icon.
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•

Clustered storage is represented by the Storage Arrays Cluster-Mode icon with the suffix of
"cluster" appended to the storage array's name.

.

If you double-click on the Storage Array Cluster-Mode icon, the generated hub switches, for
example, Cisco N-Point Virtualization (NPV), and the underlying storage array details appear.

•

Backend storage and paths for the selected host or virtual machine (VM). Storage systems that are
virtualizers show a V icon. Backend storage systems show with a B icon.
The following image shows a virtual machine, ESX, NFS network, storage virtualizer, FC switch,
and backend storage.

The Topology map shows the paths differently based on the selected device or path:
•

Volume: When you select a volume, Insight displays the starting point as a host, VM, volume or
internal volume.

•

Path: When you select a path, Insight displays the topology starting from the VM all the way until
terminated at the most distant point, which could be a VM, host, or volume. The topology
represents the logical relationship and not the physical relationship.
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Multiple IPs can exist for a single host; however, multiple IPs cannot exist for a single tape or storage
array.

Interpreting link color in the Topology view
The Topology view indicates the status of links in different colors.
About this task

Color indicates the status of the physical or logical connection:
•

Green: The link is part of a path that is operating normally, is zoned correctly, and for which the
volumes are mapped and masked properly.

•

Yellow: The link is participating in a path that has connectivity and is mapped or masked
correctly, but is not zoned.

•

Blue: The link is participating in a path that has connectivity and is zoned correctly, but for which
the volumes are not masked and/or mapped.

•

Gray: The link has connectivity only.

•

Blue and Yellow Stripes: The link represents zoning and masking to a different potential or
existing paths.

Steps

1. In the Client, display a main view and click the Topology icon at the bottom of the view.

.

2. View the legend.

Adding a watermark to the Topology view
You can insert a watermark image in the Topology view. You might want to insert this image so that
when someone prints the image, the printout displays a watermark such as "Confidential" underneath
the image. This watermark appears on the display, in the printed version, and in the exported version
of the Topology.
Steps

1. From the Client menu, select Tools > Settings.
2. In the left tree of the Settings dialog box, click the General Preferences option.
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3. Configure the following settings:
•

Show topology watermark: Check this to display a watermark image under the of Topology
view. You might want to insert this image so that when someone prints the image, the image
shows a watermark such as "Confidential" underneath the image. This watermark appears on
the display, in the printed version, and in the exported version of the Topology.

•

Watermark text: If you enable the Topology watermark, enter the text that should appear in the
watermark, for example, "Confidential" or your company name.

For details on other fields, see the "Setting general preferences."
4. To save settings on this one view and continue with other settings, click Apply. Otherwise, click
OK.
The following image shows a "Confidential" watermark.

Related tasks

Setting general preferences on page 44
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Examining devices in the Topology view
You can examine the details for any device in the Topology view by double-clicking on that device.
About this task

The detailed device view shows:
•

Each device port that is connected in the current view (shown in green).

•

Connections to each port. These are the same connections that display when the device is
collapsed (not expanded).

•

Each port adapter or controller (shown in yellow).

If a port is unused, unknown, or in a state of failure, the port does not display in the detailed device
view.
Steps

1. In the Client, display a main view and click the Topology icon at the bottom of the view.

.

2. In the Topology view, select the device.

3. In the Topology view, double-click on the device.

Displaying device details in the Topology view
You can view device details quickly in the Topology view by positioning the mouse pointer over the
device icon in the view. For example, you can examine detailed device, port, adapter, and link
properties.
About this task

You can see the following types of properties in the device icon pop-up window:
•

Device properties.
If SAN Routing is enabled for a switch device, the icon changes and the pop-up window indicates
that SAN Routing is enabled.

•

Port and adapter/controller properties:

•

Link properties
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Steps

1. In the Client, display a main view and click the Topology icon at the bottom of the view.

.

2. To display details of the device, do one of the following:
•

Position your cursor over a device icon.

•

Right-click on the device and select Open Details.

A pop-up window shows the details.

3. To view port and adapter properties, with the device expanded, move the cursor over any port or
adapter/controller (yellow box) to see its detail.

4. To view link properties, do one of the following:
•

Position your cursor over a link.

•

Right-click on the link and select Open Details.

The link details appear.
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Manipulating objects in a Topology view
When viewing a Topology map, you can select individual components in the map and manipulate the
display.
Steps

1. In the Client, display a main view and click the Topology icon at the bottom of the Insight view.
.
2. Manipulate the objects or map by using the options in the Topology toolbar.
Tool

Description
Selects individual devices in the Topology view.
Moves the map around the display area.
Zooms into focus on a specific area of the network.
Zooms out to show more of the topology.
Fits the map inside the display area.
Reloads the current display.

Displaying different Topology views
You can display different views of the Topology map. The available views vary, depending on the
main view.
About this task

You can select from one of the following views:
•

Path view: This default view shows the paths associated with the current selection in the main
view: the host server and storage device for each path, as well as the switch hops in between. By
default, OnCommand Insight displays the path corresponding to the device selected in the main
table. However, you can change this by selecting a different view.

•

Path with Connectivity view: This view displays all the information available in the Path view, as
well as any additional links and configurations that could, with some additional work, create a
path between the host and target volume.
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•

Enclosure view: This view is available from the Inventory views and shows any devices that are
connected within a single hop of the selected device.

•

Volume Replication view: This view shows the path between the host, volume, and internal
volumes. It also shows any undiscovered WWNs. If the host is masked to a volume, but there is
no path, the path appears in red. If a volume that is masked to a WWN has not yet been
discovered, the path appears in blue.

•

Volume Virtualization view: This view shows volumes accessing backend disks (virtual disks or
LUNs) and shows hosts, volumes, backend storage, virtual disks, and internal volumes. It also
shows any undiscovered WWNs.

The last two views are available only when a particular volume uses replication and/or array
virtualization. You can choose these two options only from the Paths and Violations views or in the
Volumes detail view by selecting the right-click option of Show Volume Virtualizer or Show Volume
Replication. In the Paths view, show the Array Virtualization column, then look for rows with the
blue volume virtualization icon shown in that column. The topology for those paths show the Volume
Virtualization topology.
Steps

1. In the OnCommand Insight Client, display a main view and click the Topology icon at the bottom
of the OnCommand Insight view.

.

2. From the drop-down list at the top right of the map, select a view.

Exporting the Topology map layout
You can export the image of your network as it appears in the Topology view. When you export it,
Insight creates a graphic file in a format that you choose, including PNG, BMP, GIF, and JPG. You
might want to do this to incorporate the image in reports, edit it in a graphics editing application, or
print it.
Steps

1. In the Client, display a main view and click the Topology icon at the bottom of the main view.
.
2. In the Topology view, create the layout that you want.
3. Right-click on the Topology view and select Export - Image to File.
4. Select a location for the new file, enter a filename, select the type of file, and click Save.
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Viewing virtual machine data and utilization
Using OnCommand Insight enables storage administrators to determine how resources are being used
by virtual machines, identify the path from the hypervisor host) to the storage array, and identify the
volumes used by virtual machines.
About this task

You can do the following to analyze your virtual machine data:
•

Monitor virtual machines and their properties in near real-time.

•

Obtain cross-domain (server to storage) visibility for a virtual data center: hosts, virtual machines,
data stores and paths.

•

View topology for a selected virtual machine.

•

View CPU, memory, IP traffic, and I/O utilization information.

•

View a list of hypervisor hosts.

•

See OnCommand Insight virtual machine data inside VMware with the VMware vCenter Server
plug-in (formerly VMware VirtualCenter).

With other modules of OnCommand Insight, you can to do the following tasks related to monitoring
virtual machines:
•

Activate and configure host virtualization rules (policy-based validation). Monitor violations
against those policies.
Note: Violation and policy features are available with the OnCommand Insight Assure license.

•

Obtain SAN-related performance visibility for virtual machines.
Note: Performance features are available with the OnCommand Insight Perform license.

•

Obtain SAN-related performance analyzing capabilities for physical hosts.

•

Identify virtual machine resource bottlenecks.

•

Identify inefficient resource allocations and underutilization of physical devices.

•

Identify what may become problematic virtual machine configurations.

•

Mitigate the impact of virtual machine sprawl and maximize utilization for virtual machine
environments.

About virtual machine data in OnCommand Insight
OnCommand Insight spans both virtual machines and physical host deployments.
The following illustration shows how virtual machine hosts access data stores across FC SAN
environments and NAS environments. The illustration also shows how virtual machine hosts can
access multiple data stores.
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For each virtual machine, you can answer the following:
•

Which virtual machine is running on which host?

•

Which hosts are accessing which volumes?

•

What is the active HBA/storage port for the path?

•

How is capacity allocated and utilized? (How much is being used by virtual machines?)

How virtual devices appear in OnCommand Insight views
Virtual devices are represented by icons in virtual machine columns in OnCommand Insight views.
Paths main view
Virtual devices are represented on the following ways in the Paths main view:
•

The V-Host column indicates that a host is a virtual machine host.
◦
◦
◦

◦
•

Blank: The path originates from a standard host.
: The path originates from a virtualization host (ESX server).
: The path originates from an ESX server and is currently running, meaning that at least
one of the virtual machines accessing this volume from the host is running. Because the
OnCommand Insight path does not include the storage port, this indication does not show the
active path.
: The path originates from an ESX server, but the volume is not mounted.

The V-Cluster (Host Group) column names a group of virtualization hosts sharing access to the
same SAN volumes. A V-Cluster is either a VMware HA cluster or a manually defined group of
hosts.
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•

The Active SP (Storage Processor) column gives the name of the storage processor used by the
active path from the host to the volume. There can be only one active path for a given pair of
(host, volume) and thus one storage processor.

•

The V-Policy column shows whether a Host Virtualization Policy has been applied. The column
displays an icon when a host is excluded from the virtual machine Host policy. Otherwise, the
column is blank.

Hosts view
The V-Host column indicates whether the host is a virtual host.
Volumes detail view
Virtual devices are represented in the following ways:
•

The Datastore column shows the names of the data stores residing on the volume (probably only
one) in ascending order.

•

The RDM column shows the RDM name if the volume is used for raw device mapping.

Masking detail view
Virtual devices are represented in the following ways:
•

The Datastore column shows the names of the data stores residing on the volume (probably only
one) in ascending order.

•

The RDM column shows the RDM name if the volume is used for raw device mapping.

Switch Port Performance view
The Switch Port Performance view shows both the physical host and virtualization host (ESX server).
You can see whether a host is a virtualization host. The V-Host column indicates that a host is a
virtual machine host.
Note: This view requires the OnCommand Insight Perform license.

VM Distribution detail view
From the Virtual Machine Performance view, you can access the VM Distribution detail view, which
shows the distribution of traffic by virtual machines. Each row shows the traffic generated by a
virtual machine running on the selected host when it accesses a specific volume. Rows for virtual
machines and LUNs that do not map to a volume appear unless only one row appears for the virtual
machine.
Note: This view requires the OnCommand Insight Perform license.

Viewing all virtual machines
Storage administrators can view all the virtual machines available to the host (ESX server) that
OnCommand Insight has detected, their allocated capacity, and all the data stores accessible by the
host.
Steps

1. From the OnCommand Insight Open menu, select Inventory > Virtual Machines.
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2. In the Virtual Machines view, group the data, for example, by application or business entity, and
then check the State to see whether the virtual machine is running.
3. Click on the Virtual Machines or VMDKs icon in the status bar to show the corresponding detail
view.
Virtual Machines view, Topology view, and detail views
The following example shows the Virtual Machines view, the Topology center view, and the
VMDKs detail view. If you select a row in the main view or an item in the Topology view, the
data in the detail views changes to represent the selected item.

Virtual Machines view
You use this view to see all the virtual machines available to the host (ESX server) that Insight has
detected, their allocated capacity, and all the data stores accessible by the host.
Navigation
You can access this view in any of the following ways:
•

From the Insight Open menu, select Inventory > Virtual Machines.

•

From the navigation pane on the left, select Inventory > Virtual Machines.

•

From the Insight Open menu, select Assurance > Changes. Click the Virtual Machines icon.

Column descriptions
Each row represents a relationship between a virtual machine and a volume on the SAN or a NAS
share. Each row represents a virtual machine that is available to the virtualization host (ESX server)
and one of the following:
•

A data store containing a portion of the virtual machine

•

A SAN device to which it is mapped

The number following the table heading (in parentheses) indicates the total number of virtual
machines in the list.
If other modules are installed, additional columns might appear.
Name
The name of the virtual machine.
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DNS Name
The host domain name.
IP
The IP address for the virtual machine.
Host Names
Name of the ESX host owning with the virtual machine.
Host IPs
ESX host IP address.
V-Cluster
Name of a cluster of virtualization hosts that share access to the same SAN volumes or
NAS share. For a standalone host, this is blank.
VM Capacity (GB)
The capacity allocated to the virtual machine on the data store. This is the sum of all
virtual disks stored on the data store that are used by the virtual machine. Represents the
amount of usable space for the guest operating system and applications.
VM Provisioned Capacity (GB)
The amount of capacity that a virtual machine can use from its data stores, in aggregate.
This includes the basic VM capacity from its virtual disks (VMDK),but also other items,
such as memory swap files, Snapshot files, configuration files, and log files.
VM Used Capacity (GB)
The amount of capacity currently used by the virtual machine from its data stores, in
aggregate. This includes used disk capacity across all types of files, such as virtual disks,
swap files, Snapshot files, configuration files, and log files.
OS
The guest operating system running on the ESX server.
VM Memory (GB)
Memory available for the virtual machine.
Processors
The number of processors for the virtual machine.
State
The power state of the virtual machine. For RDM, this is blank.
Datastore
The data stores accessible by the host.
Storage
Storage system associated with the ESX host, for example, virtualizer or NetApp storage.
Resource Name
The name of the volume or internal volume.
Resource Technology
The SAN (FC and iSCSI) or NAS (NFS and CIFS) protocols that the device supports.
Resource Capacity (GB)
Total capacity of the storage resource identified in the Storage Resource column.
Resource Used Capacity (GB)
Used capacity of the storage resource identified in the Storage Resource column.
Deduplication Savings
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The known amount of storage savings through deduplication, a process that detects blocks
with identical content and replaces subsequent identical blocks with a reference to a single
copy of the block.
RDM
Raw device mapping. A VMware feature that exposes SCSI targets (or LUNs) directly to
a virtual machine. RDMs are an alternative to using VMFS. RDMs are special files in a
VMFS volume that act as proxies for a raw device.
Power State
Indication of the state of the storage resource as Suspended, On, or Off.
V-Policy
A green check mark indicates that the host is included in the VM Host policy. If the host is
excluded, a red "X" appears.
FC Port Count
The number of licensed ports on the device.
Application
Name of applications associated with the resource.
Application Priority
The priority (high, medium, or low) assigned to the application.
Tenant, Line of Business, Business Unit, Project
Columns listing the business entity components associated with the applications.
Right-click options
From this view, right-click on a row to show a pop-up menu containing the following options. If other
Insight components are installed, additional options appear.
Analyze
If the OnCommand Insight Perform license is enabled, shows the Analyze dialog box and
views where you can view disk contention, view performance, and analyze congestion for
the selected virtual machine.
Analyze Storage Pools
Available only with the Assure license. Allows you to select a specific storage pool and
assess its status relative to the thin-provisioning policies. You can use this dialog box,
instead of the Violations Browser, to see the current thin provisioning violations and how
close the storage pool is to reaching the policy limits.
Set Applications
Assigns the selected host to one or more applications that you select.
Set Business Entities
Assigns the select host or hosts to a business entity (tenant, line of business, business unit,
and project).
Automatically Add Applications
Automatically adds hosts to applications based on a host naming pattern.
Set/Clear Annotation
Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or tier. The Clear option removes the annotation from
the resource.
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Related tasks

Analyzing load across VM host servers on page 92

Viewing virtual machine topology
You can view the paths from a virtual machine's ESX host to the fabric and storage array. With this,
you can identify the hosts to which the virtual machines are connected and identify where they are
storing data.
About this task

Use the Topology view to see a graphical representation of the virtual machines that exist on the host.
These virtual machines are represented as icons and appear to the left of the host icon.
Steps

1. From the OnCommand Insight Open menu, select Inventory > Virtual Machines.
2. With the Virtual Machines view displayed, in the status bar at the bottom, click the Topology
icon.
The Topology view appears in the center.

3. In the Topology view, select a device to see device details in any opened detail views.

Viewing virtual machine disk details
You can view all virtual machine disk (VMDK) details and compare their capacity with used
capacity. You can track storage resources and deduplication savings. You might want to group by
data store to review all the VMDK allocations per data store or group by storage user to see the
VMDK allocations per storage arrays.
Steps

1. From the OnCommand Insight Open menu, select Inventory > Virtual Machines.
2. With the Virtual Machines view displayed, in the status bar at the bottom, click the VMDKs
icon.

3. Optionally, in the VMDKs view, group the data using these Grouping selections:
•

Virtual Machine

•

Datastore
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•

Datastore then Virtual Machine

•

Storage

Related references

VMDKs detail view on page 90
VMDKs detail view
Use this view to monitor virtual machine disk (VMDK) performance characteristics such as IOPS,
throughput, latency CPU, and memory utilization. You can also look for busy VMDKs by data store
or storage.
Navigation
This detail view is available after clicking a device in one of the following views:
•

Changes main view

•

Hosts main view

•

Paths main view

•

Storage Arrays view

•

Virtual Machines view

You can access this detail view in any of the following ways:
•

From the Insight menu, select View > Detail Views > Virtual Machines Disks.

•

At the bottom of the Insight view, click the VMDKs detail view icon.

Column descriptions
A row exists for each virtual disk. This differs from the VM Paths detail view, which shows one row
for each volume.
The Insight licenses control the types of information displayed in the view.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by virtual machine, this column
displays the virtual machine names. The number in parentheses indicates the number of
virtual machines in each grouped row.
Name
The name of the virtual machine disk (VMDK file name).
Virtual Machine
The name of the virtual machine. May be blank when the row represents a SAN volume or
NAS share that is being accessed from a virtual host (ESX) but does not contain virtual
machine data.
Datastore
Name of the data store residing on a volume.
Capacity
Storage capacity allocated to the virtual machine disk (provided by the SDK). If you are
using raw device mappings (RDMs), this is blank because the virtual machine has no
knowledge of RDMs.
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Used Capacity (GB)
Capacity that is allocated to virtual machines (provided by the SDK). For RDM, this is
blank.
RDM
Raw device mapping. A VMware feature that exposes SCSI targets (or LUNs) directly to
a virtual machine. RDMs are an alternative to using VMFS. RDMs are special files in a
VMFS volume that act as a proxy for a raw device.
Host Names
Name of the host owning the virtual machine.
Storage
Storage associated with the ESX host. This column may be blank if Insight is unable to
identify the storage containing the virtual machine.
Resource Name
Volume or internal volume name.
Resource Technology
Indication of whether the disk uses NFS, iSCSI, or FC technology.
Resource Capacity (GB)
Size of the virtual disk, in gigabytes. Note that each row represents a single virtual disk, as
opposed to a row in the VM Paths detail view that represents an aggregate of all the virtual
disks and meta data of a virtual machine stored on a single data store.
Resource Used Capacity (GB)
Used capacity of the virtual disk, in gigabytes.
Deduplication Savings
The known amount of storage savings through deduplication, a process that detects blocks
with identical content and replaces subsequent identical blocks with a reference to a single
copy of the block.
Right-click options
From this view, right-click on a row to show a pop-up menu containing the following options.
Analyze
Available only with the Perform license. Allows you to investigate the performance of the
selected data store. For example, you can determine contention issues, availability issues,
and array performance.

Finding the best data store for a new virtual machine
When you have a new virtual machine, you want to assign it to the best data store. You can look at
the CPU and memory of the ESX servers, view the distribution, and determine whether the data store
is overcommitted. For example, you might want to look at only those data stores with low utilizations
for new virtual machines with high expected utilization.
Steps

1. From the Open menu, select Inventory > Datastores.
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2. Examine the value in the Overcommitted Capacity column for the data store.
3. Click the data store, then right-click and select Analyze.
The display of Performance information requires the OnCommand Insight Perform license.
4. Select the Hosts tab.
5. Select icons to display the details:
•

Performance Chart to see anomalies or sudden changes in virtual machine activity over time.

•

Performance Distribution view to see traffic distribution trends over time and identify peak
periods.

6. Look at the CPU and memory.

Analyzing load across VM host servers
While you are looking at VM host servers, you might want to analyze the load distribution between
virtual machines and ports. This requires the OnCommand Insight Perform license.
Steps

1. From the OnCommand Insight Open menu, select Inventory > Virtual Machines.
2. Right-click and select Analyze.
3. Select tabs and icons to display the details:
•

Performance Chart to see anomalies or sudden changes in virtual machine activity over time.

•

Performance Distribution view to see traffic distribution trends over time and identify peak
periods.

The display of Performance information requires the OnCommand Insight Perform license.
Note: For details about load analyzing, see the OnCommand Insight Performance User Guide

for the Java UI.
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Viewing virtual machine hosts (Hypervisor servers)
You can identify performance data related to the physical Hypervisor host servers across a selected
time. You might want to do this to determine the proper placement of new and migrated virtual
machines or determine on which cluster you should put a virtual machine. You can also look at a list
of recommended Hypervisor servers for a specific virtual machine.
Steps

1. From the OnCommand Insight Open menu, select Inventory > Hosts.
Example

The following example shows the Hosts main view where you can see virtual machines as
indicated by the V-Host column.

The Hosts main view appears.
2. Optionally, click on one of the following icons in the Icon status bar at the bottom:
•

Virtual Machine Disks detail view to see the path for a single virtual machine, the volumes
that comprise the virtual machine, and how it is mapped to storage.

•

Virtual Machines detail view to see all the virtual machines available to the host (ESX server),
their allocated capacity, and the data stores accessible by the host.

3. Optionally, right-click, select Analyze, and select tabs and icons to display the details:
•

Performance Chart to see anomalies or sudden changes in virtual machine activity over time.

•

Performance Distribution view to see traffic distribution trends over time and identify peak
periods.

The display of Performance information requires the OnCommand Insight Perform license.

Viewing memory allocation of a virtual machine in a cluster
You can view the memory allocation of a virtual machine in a cluster. If you have a cluster of VM
hosts, they should all be configured the same way. However, you might want to verify whether this is
true by showing if the VM hosts are being used in the same way and are using the same amount of
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memory. Using the Memory Map, you can visually compare the utilization percentage for multiple
VM hosts.
Steps

1. From the OnCommand Insight Open menu, select Inventory > Hosts.
The Hosts main view appears.
2. In the Hosts main view, click on two or more hosts.
3. Right-click on a VM and select Analyze.
4. Select the Virtual Machines tab.
5. Click the Performance Chart icon at the bottom.

6. In the chart's legend box, ensure that Memory Utilization is checked.
7. Below the legend, click links in the list of changes to display details.
8. From the Virtual Machines tab, select multiple VMs.
The chart compares performance across VMs.

Setting virtualization policy and monitoring VM violations
You can set policies that help you monitor virtualization configurations. After you set these policies,
OnCommand Insight monitors your environment and issues alerts if a violation occurs on these
policies. This requires the Assure license.

Violations related to VMs
After you set policies that help you monitor virtualization configurations using Settings,
OnCommand Insight monitors your environment and issues alerts if a violation occurs on these
policies.
The settings in the Host Virtualization Policy option in Settings can generate the following violations:
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Violation

Condition

Issued for

Active path conflict

A volume in an active/passive
storage array is accessed
through multiple storage
processors. This situation can
lead to "path thrashing."

All paths to the volume being
accessed.

Inconsistent LUNs

A volume is presented
(mapped) to different hosts in a
group using different LUNs.

All paths to the volume that are
mapped using different LUNs.

Datastore Latency

When the virtual machine
latency of the datastores in
your environment exceeds the
threshold set in the global
general policies.

You can set the notification
policy for the violation to be
generated when the latency
first exceeds the threshold
(peak) or when the average of
an hour of samples exceeds the
threshold.
Note: This violation appears
in the Violations browser
while the others appear in
the SAN Path Violations
view.

Missing virtual cluster NAS
share

A host in a cluster does not
access a NAS share that is
being accessed by other hosts
in that cluster.

Missing virtual cluster paths

A host in a virtual cluster
cannot access some volumes
while another host in the group
can.

For each host and for all
volumes that other hosts in the
group can access. Issued for
each missing path.

Analyzing VM violations: Missing virtual cluster path
If OnCommand Insight issues a “Missing virtual cluster path” violation, you can research the cause.
This violation means that a host in a virtual cluster cannot access volumes that another host in the
cluster can.
About this task

A path does not exist for the host within the cluster, and so no path exists from the virtual machine to
the volume. All hosts need access to the same storage to ensure that in the event of path outage, the
virtual machine can fail over to another host in the cluster.
To analyze this violation, ask these questions:
•

Which hosts in the cluster have access to the volume? Which hosts do not?

•

Should the hosts in the cluster access this volume? If not, then access to the volume should be
prevented from all the hosts in the cluster.

•

Why does a host not have access? This is similar to analyzing a “Path Outage” violation:
◦

Connectivity: Are the host and storage active and connected to the same fabric?

◦

Zoning: Do the host and storage share zones? Do any of the shared zones contain connected or
active ports of the host and storage?
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◦

Volume masking and mapping: Does the storage map and mask the volume to the host use
connected ports that are members of the same zone?

To prevent this violation from occurring, you should provide sufficient connectivity and configure
matching zoning, mapping, and masking. This grants the host access to the volume.
Steps

1. From the Open menu, select Assurance > SAN Path Violations.
2. Group the data by violation type.
3. Look at the Volume column to see if the host is using different active storage to get to the selected
volume.
If this is the case, you must know which VMs are affected by this violation so that you can
attempt to prevent a performance degradation.
4. Look in the V-Host column.
An icon with a green triangle in the column indicates that a VM is present.
5. From the SAN Path Violations view, select a row showing the “Missing Virtual Cluster Paths”
violation.
6. In the status bar on the bottom, click the Virtual Storage icon to show the Virtual Storage detail
view.
This view displays all the active VM paths to the SAN volume (except the VM paths to a NAS
share). If there is a path conflict, there are at least two VMs shown in the Impacted Hosts column
that are accessing the same volume. Throughput immediately suffers as a result.
Note: To see violations related to VM paths to a NAS share, select the “Missing Virtual Cluster
NAS Share” violation in the SAN Path Violations view.

7. From the SAN Path Violations view, you might also want to right-click the row and select
Analyze to use the summary information and further isolate the issue.
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Using storage virtualization
If you use virtual storage, the layer between the physical storage array and the HBA, you can view
the end-to-end path from a host to a virtual volume to a physical volume. Storage virtualization lets
the administrator map virtual volumes to the physical volumes on the backend. To the host, virtual
storage appears (and acts) as an array, and to the physical array, it appears (and acts) as a host.
About this task

This abstraction of detail allows administrators to migrate data between storage arrays without
impacting servers using the data or causing any downtime. Administrators might like to do this if
they perform the following:
•

Perform a seamless hardware refresh, for example, replace the backend storage with a newer
device.

•

Change tiers. The administrator can choose to "move" the data from a Tier 2 storage array to a
Tier 1 array (or vice versa) without affecting the user.

You can do the following tasks related to storage virtualization in Insight:
•

View storage virtualization configuration.

•

View virtualization from the backend volumes perspective in the Backend Volumes detail view.
View backend volumes for each virtualized volume.

•

View the backend volumes for each backend array.

•

View all virtualized paths.

•

View changes related to storage virtualization.

Storage virtualization benefits in Insight
Insight provides visibility into the virtualized environment.
The benefits include:
•

Total visibility into the virtualized environment

•

Awareness of the physical paths (switches and array ports) between virtual volumes and physical
volumes

•

Enhanced change management

Using storage virtualization, the administrator can determine what devices will be affected when an
upgrade or migration is being planned. Such information supports continuous access to data and
ensures ongoing availability of that data for applications. In this way, the administrator can manage a
more cost-effective environment by avoiding downtime.
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Storage virtualization in Insight overview
Insight gives you a view into the backend from the virtualizer to the storage array. This expands the
level of discovery available in virtual environments, enabling the end-to-end visibility required for
optimum management of the storage network.
Virtualizers appear as storage arrays in the Storage Arrays view. The virtualizer is always placed in
front of the storage systems. The following diagram displays a typical layout.

The virtualizer receives the traffic, processes it, and forwards it to the backend storage arrays. The
virtualizer act as a host in the extended backend path.
Note: To confirm which storage virtualizers and backend storage that Insight supports, see the
Insight Interoperability Support matrix at the NetApp Support Site at mysupport.netapp.com.

To see storage virtualization, use the Backend Volumes detail view, which provides the baseline view
as the host or path perceives it.
The same information can be accessed in the following views. Each view contains a column to
indicate virtualization, marked with a Virtual icon.
•

Storage Arrays view

•

Paths view

•

Hosts view

This column has also been added to the following detail views to identify virtual storage (the values
for Properties can be found using the right-click menu):
•

Volumes view

•

Masking, Paths views

•

Storage Properties view
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•

Path Properties view

•

Volume Properties view

The same icon is used to identify everything related with virtualization. When it appears on a
volume, it indicates a virtualized volume. On a storage array, it indicates a virtualizer.
The other icon is a “B”.
When it appears on a storage array, it means that device is a backend
storage. When it appears on a volume, it means that this is a backend volume.

Backend volumes
In SAN virtualization, backend refers to a LUN that is not presented to a host system for direct use.
A frontend LUN or volume is presented to a host system. The backend is also referred to as a
virtualized volume or disk or a virtual disk. The mapping between the frontend and the backend is
handled by a storage virtualizer.

Viewing virtual storage information
You can view the virtual volumes, virtual internal volumes, virtual disks, and backend volumes used
by the virtualizer.
Steps

1. From the Open menu, select Inventory > Storage Arrays.
2. In the Storage Arrays view, click on a storage system that shows a Virtual icon.
3. At the bottom of the view, click one of the following icons:
•

Disks: Shows all the virtual disks used by the virtualizer.

•

Volume: Shows all the virtual volumes created by the virtualizer.

•

Internal Volume: Shows all the virtual internal volumes created by the virtualizer.

•

Backend Volume: Shows all the backend volumes used by the virtualizer. Displays backend
volumes only when the item selected in the main or center views is connected to virtual or
backend storage.

•

Virtual Storage: Shows one row for each relationship between the front-end (virtual) and
backend storage.

Viewing backend volumes
View a list of backend volumes associated with a selected path from a host perspective by reviewing
the Backend Volumes detail view.
About this task

You can see how a virtual volume is stored. The backend volumes associated with a volume are of
the same redundancy and located on the same type of storage. A virtualized volume is stored on only
a single array and a single array type.
Steps

1. In the Hosts main view, click on a host that shows a Virtual icon.
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2. At the bottom of the view, click the Backend Volumes icon to display the Backend Volumes
detail view.

For descriptions of the fields on this view, see "Backend Volumes detail view."
3. At the bottom of the view, click the Volumes icon.
4. In the Volumes detail view, identify the volumes that exist for that host.
5. In the Backend Volumes detail view, review all the virtual volumes listed in the Virtualized
Volumes column.
6. In the Backend Volumes detail view, highlight one of the volumes and scroll to the right to
determine the exact location of the volumes by viewing the Volume and Storage columns.

Viewing storage virtualization changes
View a list of changes related to storage virtualization.
About this task

Insight generates a list of changes such as the following for storage virtualization:
•

When the mapping in the virtualizer changes (the front end and back end mapping for a volume is
changed).

•

When a new mapping is created (a virtualized volume is mapped to the back end volume on the
back end storage).

•

When a mapping is removed (the virtualized volume is no longer mapped to a back end volume
on the back end storage).

•

When the virtualizer identifies a new back end volume (a new LUN is identified).

•

When a new back end volume added (from back end link to back end volume on the back end
storage).

•

When the virtualizer has a back end volume removed.
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Steps

1. In the Hosts main view, click on a host that shows a Virtual icon.
view, click on an array.

Or, in the Storage Arrays

2. At the bottom of the view, click the Changes icon to display the Changes detail view.
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Viewing paths in your SAN or NAS environment
You can view the path of physical links from the server to switches, the link between switches and a
storage volume, or tape, and the link from storage to a NAS share. You can view multiple physical
paths for each logical path. In a SAN environment, volumes represent services or end points of SAN
paths, while in a NAS environment, shares are displayed as end points.
About this task

You can do the following tasks related to paths:
•

View a list of paths in the Paths main view.

•

Select a path and view the topology and changes related to it.

•

Analyze missing paths.

Steps

1. Do one of the following:
•

From the Open menu, select Inventory > Paths.

•

From the navigation pane, select Inventory > Paths.

2. In the Paths main view, select a path.

Paths overview
A path can include physical links (starting from the link between the server and its edge switch),
optionally followed by links between core switches, and completed by the link between an edge
switch and a storage volume, tape, or share. Or, the path can show the link from storage to an NFS
share. Your environment can have multiple physical paths for each logical path.
Each path has attributes, including the specific devices on the path between the end points, the
number of possible physical paths between the two end points, the level of security of the path
between the end points, volume sharing, and volume mapping or masking.
You can see both SAN and NAS paths. The end point of a SAN path is a volume. In contrast, the end
point of a NAS path is a share. The Paths main view for NAS shows only those NAS paths that use
the NFS protocol.
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•

SAN path: When you can select a SAN path, you can see similar details as in the NAS in both the
Storage Pool and Internal Volumes detail views. However, for SAN environments, you should
show the Volumes detail view rather than the Shares detail view (that you would use for NAS
paths).

•

NAS path: You can select a NAS path, and then view related information in the Storage Pools,
Internal Volumes, and Shares detail views.

Paths view
Use this view to see all the device paths in your environment. You can identify the logical
relationship between a host server and its data residing on a storage device. Each path is defined and
identified by these two end points: the host server on one end and the storage volume or share on the
other.
You can see both SAN and NAS paths in the same view. The end point of a SAN path is a volume. In
contrast, the end point of a NAS path is a share. This view shows only those NAS paths that use the
NFS protocol.
If you are looking at the Paths main view, you see the entire SAN. If, on the other hand, you are
looking at the Paths detail view, you see information about a selected device.
Navigation
You can access the main view in one of the following ways:
•

From the Open menu, select Inventory > Paths.

•

From the navigation pane, select Inventory > Paths.

You can access the detail view by clicking on a resource in a main view and clicking the Paths icon at
the bottom of the view.
Column descriptions
Each row represents a single path. To see details for a particular path, click on the path in the Paths
main view. At the bottom of the Client window, in the icon bar, click the Properties icon.
icon (Are there violations?)
An icon in this column marks a path with a violation.
Technology
The protocol used by the given path. The SAN (FC and iSCSI) or NAS (NFS and CIFS)
protocols that the device supports.
Policy Type
Indicates the type of policy, if any, associated with the path. Types include Global Storage,
Host, Path, and Global Backend Volume.
Host
The name of the host from which the path originates.
V-Host
Indication that the host is a virtual machine host.
•
•

Blank: The path originates from a standard host.
: The path originates from a virtualization host (ESX server).
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•

: The path originates from an ESX server and is currently running, meaning that
at least one of the virtual machines accessing this volume from the host is running.
Because the path does not include the storage port, this indication does not show the
active path.

•

: The path originates from an ESX server, but the volume is not mounted.

V-Cluster
A group of virtualization hosts sharing access to the same SAN volumes. A V-Cluster is
either a VMware HA cluster or a manually defined group of hosts.
Storage
The name of the storage device where the data for this path resides.
vFiler
An isolated software container that behaves exactly like a physical storage array. A vFiler
unit shares the physical resources of the array, but abstracts the client access from the
physical array into virtual arrays. Displays the vFiler to which the target belongs. Displays
only for NetApp storage systems.
Storage Alias
This user-defined annotation provides an easy to recognize alias for the storage.
Storage Pool
The storage pool on which the storage target resides.
Volume
The name of the volume where the data for this path resides (applicable with disk storage
only).
Capacity
The size of the volume, in gigabytes.
Share
Name of the share path end point for NAS paths. If the path is to a share, the full path to
the share appears.
Active SP
The name of the storage processor used by the active path from the host to the volume.
There can be only one active path for a given pair of (host, volume) and thus one storage
processor.
icon (Array Virtualization Type)
Indication of virtualization. One of two icons could appear: V icon or B icon. In the
Volumes and Backend Volumes views, this column indicates whether the volume is a
virtualized volume (V) or a backend volume (B). In the Paths view, if the path connects to
a volume, the V/B column indicates if the volume is virtual, backend, or neither. If the
path connects to a share, the column indicates if the share is virtual. In the Storage Arrays
view, this column indicates whether the storage acts as a virtualizer device (V) and uses
virtual volumes or as backend storage (B).
Since
Date and time when the path was first discovered.
Registered
Indicates that the host on this row is registered to the current user. You can register any
number of hosts and then filter on this field to view only the hosts registered to you.
Application
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Applications assigned to a host. If the host is not dedicated to any applications, no value
appears here. Together, the host servers associated with an application are known as an
application group.
Application Priority
The priority for each application if the host is assigned to run specific applications.
Tenant, Line of Business, Business Unit, Project
The business entities associated with each virtual machine as defined in Settings.
Host FC Port Count
The number of host ports that can access the storage (tape device or volume).
Storage FC Port Count
The number of FC ports on the storage array.
HOPS
The number of FC switch devices that path traverses from the host to the storage. The
comma-separated list shows the number of switch hops for each physical path. For
example, one access path might have two potential physical paths, each with a different
number of switch devices.
Host Fabrics
The number of fabrics on which the host (associated with the selected path) resides.
Session Count
The number of iSCSI sessions that are used by this path.
Connection Count
The number of iSCSI connections that are used by this path.
RDM
A VMware feature that exposes SCSI targets directly to a virtual machine. RDMs are an
alternative to using VMFS. RDMs are special files in a VMFS volume that act as a proxy
for a raw device.
Datastore
The name of data store residing on a volume.
V-Policy
Indication whether a Host Virtualization Policy has been applied. The column displays an
icon when a host is excluded from the virtual machine host policy. Otherwise, the column
is blank.
Options
From the Paths main view, right-click to show a pop-up menu. If other Insight product licenses are
installed, additional options appear.
Set/Remove Path Policy
Attaches a policy to logical elements such as path or fabric.
Set/Remove Host Policy
Available only with the Perform license.
Attaches a policy to or removes a policy from physical system elements such as a host,
storage, or VM. Policies may be based on detecting compliance with configurations, or
they can be based on transitory events like a performance spike.
Analyze Violation
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Available only with the Assure license. Displays the Analyze Violation dialog box where
you can look at the violation details and review possible issues contributing to the
violation.
Analyze Performance
Available only with the Perform license. Allows you to analyze the performance for the
selected data store.
Related tasks
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Viewing the topology map and changes for a path
You can select a path from the Paths main view, see a graphical representation of that path, and view
all the changes that impact the devices on the selected path.
Steps

1. Do either of the following:
•

From the Open menu, select Inventory > Paths.

•

From the navigation pane, select Inventory > Paths.

2. In the Paths main view, select a path.
3. Display the Changes detail view by doing one of the following:
•

From the Client menu, select View > Detail Views > Changes.

•

At the bottom of the Client view, click the Changes detail view icon.

4. To display the Topology view, at the bottom of Client view, click the Topology center view icon.

Example: Path topology map and changes
The illustration shows the path selected in the Paths main view and the following information
about the selected path:
•

The Topology view shows the host and the storage array as end points. The green arrows
indicate that the paths are operating normally.

•

The Changes detail view shows the changes to the host, for example, there was a fabric
configuration change that affected devices in the path.
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The Changes detail view shows all the changes that occurred in the SAN or NAS environment
that are relevant to the path selected in the Paths main view. The list of changes includes all the
physical actions and configuration changes performed on devices belonging to that path, as
well as implications of those actions.
Using these views, you can identify changes to devices along critical paths and quickly
determine whether you need to take action.

Viewing path details
You can see details about a selected path, which is the logical relationship between a host server and
its data residing on a storage device. The Paths view is available as a main and detail view and shows
both SAN and NAS NFS paths.
Steps

1. To display a Paths view, use any of these methods:
•

From the Insight Client menu, select Inventory > Paths.

•

From the navigation pane, select Inventory > Paths.

•

To display the detail view from a main view, click the Paths icon below the main view.

2. Select a path of interest and use the right-click to perform additional analysis or set a policy on
the path.
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Related references

Paths view on page 147

Analyzing missing paths
You can identify hosts, storage arrays, and volumes that are not connected in any paths and connect
them in a path.
About this task

Use this tool when you know that there should be a path between a host and a volume. You can select
each one and run a series of tests on the server. Insight then presents the results of the tests that help
you identify why a path does not exist between the two. You can then use that information to resolve
the issue.
Steps

1. From the Client menu, select Tools > Analyze Missing Paths.
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2. Click on the source that represents the host or storage array that you want to connect.
3. Click on the target that you want to connect to the source.
4. Click on the volume that you want to connect in this path.
5. Click OK.
Related tasks

Examining devices in the Topology view on page 79
Related references

Paths view on page 103
Changes detail view on page 118
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OnCommand Insight views
OnCommand Insight includes many main views, which appear at the top of the OnCommand Insight
Client, and many detail views, which appear at the bottom of the Client view.

Automatic storage tiering in Inventory and Performance
views
Data in views is affected by the use of automatic storage tiering.
If a host uses a volume that is configured for automated storage tiering (for example, FAST VP),
OnCommand Insight does not show all of the storage pools for the volume. You see only the primary,
native pool for that volume. If, as part of the automatic storage tiering, a volume moves to another
storage pool, Insight does not display the new relationship.
The following views are impacted by the use of automatic storage tiering (for example, FAST VP):
•

Analyze: The Disks tab does not show the full list of disks; it shows only the primary storage pool
disks. The Backend Volumes tab does not show the full list of backend volumes; it shows only the
backend volumes of the primary storage pool. The Volumes and Backend Volumes center views
of the Disks tab do not show all the relevant volumes. The Disks center view of the Volumes tab
does not show all the relevant disks. The Hosts tab does not show all the hosts using a disk. The
Daily Patterns tab does not show complete information when Disk or Backend Volume is
selected for Performance data.

•

Backend Volumes and Backend Volume Performance detail views: Do not show all the relevant
backend volumes.

•

Disks and Disk Performance detail views: Do not show all the relevant disks.

•

Disk metric columns of the Host Performance view: Because roll-up values do not include all the
relevant disks, these columns contain N/A values.

•

Host Performance Chart view and Host Performance Distribution view: No data is shown if
automatic storage tiering would display incorrect data.

•

Storage Pools and Storage Pool Performance detail views: Do not show all the relevant storage
pools.

•

Virtual Storage detail view: Does not show all the relevant virtual disks and backend volumes.

•

Volume Members By Disk dialog box: Does not show all the relevant volume members.

Applications detail view
Use this view to look at applications associated with a given host. For example, you might be
interested in all the hosts associated with your email, finance, development or human resources
applications.
About applications
You can assign an application to a host. Other attribute assignments are done with other annotations,
such as data center and floor. You define applications and other annotations in Tools > Settings >
Annotations > Types. You then can assign the application or other annotation to the host.
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Navigation
You can access this detail view in any of the following ways:
•

From the Client menu, select View > Detail Views > Applications.

•

At the bottom of the Client view, click the Applications detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Paths main view

•

Changes main view

•

Hosts main view

•

Topology view

•

Virtual Machines view

•

SAN Path Violations view

Column descriptions
If other licenses are installed, additional columns might be displayed.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by priority, this column displays the
priority values. The number in parentheses indicates the number of applications in each
grouped row.
Name
The name of the application.
Priority
The priority assigned to the application.
Validate Volume Sharing
Indication whether volume sharing between this application's hosts and other hosts is
being done. This is set when you assign applications to hosts. This requires the Assure
license.
Business entity columns (Tenant, Line of Business, Business Unit, and Project)
A hierarchy of information that can be associated with resources. The hierarchy includes
tenant, line of business, business unit, and project. For details about business entities and
assigning them, see "Setting up business entities."
Options
From the Storage Arrays view, right-click to show a pop-up menu containing the following options:
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
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Available only with the Perform license. Shows the performance information for the
selected resource.

Backend Volumes detail view
Use this view to find information about backend volumes, not a set of directly accessible (virtual or
otherwise) volumes.
Using the Backend Volumes detail view, you can see the end points of SAN paths. For NetApp
storage, you can view the LUNs configured on the device.
The Backend Volumes detail view shows all the relationships between the frontend and backend
storage (one row per relationship), but with few details. The Backend Volumes detail view lists just
the backend volumes (one row per volume), but provides the same details as the Volumes detail view.
Note: To view NetApp volume information, use the Internal Volumes detail view.

Navigation
This detail view is available after clicking a device in one of the following views:
•

Paths main view

•

Changes main view

•

Hosts main view

•

Storage Arrays view

•

Zones view

•

Topology view

You can access this detail view in one of the following ways:
•

From the Client menu, select View > Detail Views > Backend Volumes.

•

At the bottom of the Client view, click the Backend Volumes detail view icon.

Column descriptions
The Backend Volumes detail view shows the following information, depending on the device
selected:
•

Information about volumes configured on a storage array or for a host. This applies when you
select a storage array or a host in the Topology view, the Storage Arrays view, or Hosts main
view.

•

Volume details for the selected row in the main view (for example, the volumes accessible
through a particular path).

Thin provisioned volumes report disk speed, disk type, and disk size just as other volumes do. These
values are extracted from disks that are aggregated to the storage pool from which the volume is
allocated.
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blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by data store type, this column
displays the data stores. The number in parentheses indicates the number of data stores in
each grouped row.
Volume
Name of the volume.
Label
Full volume name within the storage array.
UUID
Universally unique identifier for the object. In this case, it is generated by and retrieved
from the storage array itself.
Storage
Storage associated with the volume.
Storage Pool
Name of the storage pool on which the volume resides. A logical layer used by some
storage array to map the resources (volume and shares) to the storage (for example, disks
and backend volumes) where the capacity actually resides.
Thin Provisioned
A check appears if the volume is leveraging thin provisioning.
Performance Policy
The level of performance threshold (for example, Global) set on this resource. For
example, maximum IOPS, response time, or throughput thresholds might be set for
specific resources and not use the global thresholds.
vFiler
If the volume is associated with a vFiler, the vFiler unit name appears. An isolated
software container that behaves exactly like a physical storage array. A vFiler unit shares
the physical resources of the array, but abstracts the client access from the physical array
into virtual arrays.
Internal Volume
Internal volume on which the volume resides.
Qtree
Name of the qtree associated with the volume. Volumes and shares can potentially reside
on top of qtrees.
icon (array virtualization type)
A “V” icon indicates that the device is a virtualized volume, and a “B” icon indicates that
the device is a backend volume. For the Backend Volumes detail view, this column
displays a “B”.
Virtualizer
For backend volumes in array virtualization. The name of the front end virtualizer that is
using this volume.
Virtual Storage Pool
For backend volumes in array virtualization. The name of the storage pool on the front end
virtualizer that is using this volume.
Capacity (GB)
Size of the volume that is accessible to host applications, in gigabytes.
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Raw Capacity (GB)
Physical capacity actually present on the device, in gigabytes. At the storage pool level,
this differs from usable capacity when technologies such as RAID-5 are used, where some
of the raw capacity is used for protection purposes.
Consumed Capacity (GB)
The amount of capacity that the volume consumes from underlying storage (such as
internal volumes and storage pools). For non-thin provisioned volumes, this value is the
same as the volume's capacity. For thin provisioned volumes, it is the amount of capacity
used to store the volume's contents. Its value is also affected by Snapshot copies,
deduplication, and other storage technologies. If the volume does not have usage
information available, this appears blank.
If the Insight Acquisition obtains a blank value for consumed capacity, the Consumed
Capacity summary value is blank.
Mapped Ports
The number of storage ports through which this volume is accessible.
Masked Hosts
The number of host ports that are defined, by the masking mechanism, as being able to
access the specific volume.
Replication Mode
Type of replication, for example, Synchronous, Asynchronous, Semi-Synchronous, Copy,
or Unknown.
Replica Source Storage
Storage device that contains the volume being replicated.
Replica Source Volume
Volume that is being replicated.
Type
The vendor-specific type of volume (for example, SFS or BV). This column also displays
replication role, such as striped, sequential, or image. Virtual disks can have more than
one replication type and could show one of the following replication types:
FlashCopySource, FlashCopyTarget, MetroMirrorMaster, MetroMirrorAuxilary,
GlobaMirrorMaster, GlobalMirrorAuxilary.
Auto Tiering
A checkmark indicates that the selected storage pool is using the automatic storage tiering
technology (for example, FAST VP).
Auto Tiering Policy
The name of the automatic storage tier policy as taken from the vendor, for example,
FAST VP policy.
Auto Tiering Policy Constraints
Details of the automatic storage tiering policy. Shows the maximum LUN capacity for
each vendor tier. Although tiering can use up to 9 tiers, typically only 2 or 3 tiers are used.
Each tier can be associated with different storage pools.
For example, “SATA 50%, FC 40%, SSD 10%” indicates that no more than 50% of the
LUN capacity can be assigned to SATA disks, 40% to FC disks, and 10% to SSD disks.
Redundancy
Level of mirroring defined for the device based on the storage technology, for example,
RAID-DP, underlying the device. This is taken from the device itself. For an explanation
of values, see the device documentation.
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Disk Type
The type of disk (for example, Fibre Channel or ATA) underlying the volume.
If there are disks with multiple disk types, speeds, or sizes, the information about them
appears in a comma-separated list. If a storage pool is on a virtual LUN, “vLUN” appears
as the disk type, the LUN size appears as the disk size, and Disk Speed is blank.
Disk Group
The vendor-specific, disk-group value, often related to RAID storage. Refer to the device
documentation for an explanation of values.
Device Group
Group to which the volume belongs.
Disk Size (GB)
Size of the physical disk as used by the volume.
Disk Speed
Speed of the disk as used by the volume, in revolutions per minute (RPM).
Reservation Status
Indication of whether the volume is currently Used (masked and mapped), is Reserved for
fulfilling a storage request, or is Free for allocation or reservation. (OnCommand Insight
Plan only)
RDM
A VMware feature that exposes SCSI targets directly to a virtual machine. RDMs are an
alternative to using VMFS. RDMs are special files in a VMFS volume that act as a proxy
for a raw device.
Datastore
Name of the data store using the volume.
Application
The name of the application associated with this resource.
Application Priority
The priority (high, medium, or low) assigned to the application.
<annotations>
Annotations associated with each volume.
Options
From the detail view, right-click to show a pop-up menu containing the following options:
Show Volume Virtualization
Shows the virtualization information of the volume in a separate window.
Show Volume Replication
Shows the replication information of the volume in a separate window.
Show Disks
Shows the disks used by the selected volumes.
Show Volume Members
Shows the members of the volume in a separate window. You can right-click on the
Volume Members window and select Show Disks to see the disks for the volume member.
You can select a disk and see the other volume members that are on the disk.
Reserve volumes for new (or existing) request
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Allows you to reserve storage space on the selected volume and associate that with an
existing request or generate a new request.
If the volume is not free, meaning that there is a path to it, the option will not be available.
To help clarify this, if you have the Plan license, you can add the Reservation Status
column to the Volumes detail view. This column could help you determine the paths that
exist and identify requests for space.
Modify Policy
Changes the policy that governs alerts set on this resource. This requires the Assure
license.
Open request
If a storage capacity request exists on this volume, this option enables you to open it. This
requires a Plan license.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
Shows the performance information for the selected resource. This requires the
OnCommand Insight Perform license.
Set Applications
After you define applications with their business entities, associates the applications with
the hosts on which they run.
Set Business Entities
Associates the business entities (tenant, line of business, business unit, and project) with
this resource.
Automatically Add Applications
Associates applications with the resource based on criteria you define.
Set/Edit Annotations
Enables you to assign a predefined or custom category to this device so that you can later
group the devices by the annotation. For example, you might want to group all devices in a
specific data center or tier.
Clear Annotations
Enables you to remove a predefined or custom category from this device.

Changes main view
Use this view to see physical and logical modifications to devices in your environment, including
equipment additions and removals, zoning and masking changes, cabling reconfigurations, and
system outages. Using the Changes main view and the Topology view, you can select a time frame
and view the topology and the changes for a previous time. This helps you view the state of your
environment at different times.
From this view, you can see changes to both SAN and NAS configurations.
Navigation
You can view changes in any of the following ways:
•

From the Open menu, select Assurance > Changes.

•

From the navigation pane, select Assurance > Changes.
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•

With the Changes detail view open, click on a device or path in the Topology view. A list of
changes that relate to the currently selected device or path appears.

•

With the Changes detail view open, from the Hosts, Paths, or Storage Arrays main view, select a
host, path, or storage array. A list of changes that relate to the currently selected device or path
appears.

You can view changes in a main view, which shows all the changes to your entire environment. You
can also select a host or storage array and view changes to the selected device in a detail view.

Field descriptions
The number following the table title identifies the total number of changes in the list. Each row in the
table represents a specific change and includes the information below.
You might see violations in the Changes list. Violation tracking is a feature provided through the
Assure license.
To see details for a single device, path, or violation, click on the change in the Changes main view. At
the bottom of the Insight Client window, in the icon bar, click the Properties icon.
To see details for changes that affect multiple objects, expand the change row in the main view.
Time
Date and time at which a data source reported this event . This timestamp allows Insight to
recreate and display the state of your environment at any point in time.
icon

Indicates the type of event, for example, equipment additions and removals, zoning and
masking changes, cabling reconfigurations, and system outages.
Event
The change action that occurred at the time indicated.
Changes that resulted from a single action are stamped with the same time and are
grouped in the display. Click the + sign to display more detailed change information for
events that are nested.
The information included here reports not only the change itself, but also the impact of the
change on the access path.
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Options
The Changes main view includes the following options:
•

HTML report: Click the Printer icon to generate an HTML report of changes. If you have filtered
the list, the HTML report includes only the changes currently listed.

•

In the Tools > Settings > General Preferences option, clear the Show transient violations
option to remove the violations generated by maintenance or other planned activities from the
Changes main view. Check that option to include all of those violations.

•

Clear filter: Click the Clear Filter icon to clear all filters set on any columns.

•

Expand rows: Click the Expand icon to expand all rows that have a + to the left.

•

Collapse rows: Click the Collapse icon to collapse all child rows under parent entries.

•

Time period: Click this to change the time frame for the list of changes. You can also enter a
custom time period.

•

Filter: Click the Filter drop-down list to see all changes or only a subset of the changes. You can
filter the Changes list by one of the following filters:
◦

All: Shows all changes.

◦

Paths, Policies, and Violations: Shows only the events that are related to paths and policies
and the associated violations.

◦

Devices: Shows only the events that are related to device configuration.

◦

Device up/down: Shows only the events that are related to devices shutting down or starting
up.

◦

Host Virtualization: Shows only the events related to virtual machines.

With the Topology view open, in the main Changes main view, click on any change to view the
topology as of the date and time when that change occurred. Then, step your way through the
Changes list, watching the topology change. For example, as devices are added, you can select them
and review the detail views to ensure that they were added correctly.
From the Changes main view, right-click to show a menu. The Insight licenses control the types of
information displayed in the view.
Related concepts

Maintaining Insight on page 8
Insight logs on page 8

Changes detail view
Use this view to identify physical and logical modifications to a selected device in your environment,
including equipment additions and removals, zoning and masking changes, cabling reconfigurations,
and system outages. The Changes detail view displays a list of changes related to a selected path,
switch, host, storage array, or tape device.
Navigation
You can access this detail view in one of the following ways:
•

From the Insight Client menu, select View > Detail Views > Changes.
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•

At the bottom of Insight Client views, click the Changes detail view icon.

Column descriptions
Insight displays the following information for each change that relates to the selected item or displays
a set of changes that occurred at a specified date and time.
You can also view changes in a main view, which shows all the changes to your entire environment.
The Insight licenses control the types of information displayed in the view. For example, you might
see violations in the Changes list. Violations detection is a feature provided by the Assure license.
Time
The date and time at which a data source reported this event or events. This timestamp
allows Insight to recreate and display the state of your environment at any point in time.
The most current change appears at the top and the changes are in descending order by
time stamp.
icon

Icon indicating the type of event.
Event
The change action that occurred at the time indicated.
Changes that resulted from a single action are stamped with the same time and are
grouped in the display. Click the + sign to display more detailed change information for
events that are nested.
The information included here reports not only the change itself, but also the impact of the
change on the access path.
To display properties for the device in a row, click the link in the row.
Options
Open changes in a web browser
Generates an HTML report of changes that you can view in a web browser. If you have
filtered the list, the report includes only the changes currently listed. To distribute or print
the report, user the standard browser options.
Time Period
Changes the time frame for the list of changes. You can also enter a custom time period.
Filter
Filters the list of changes. You can filter to show only those changes related to devices
being up or down or changes related to all devices. If you have other licenses installed,
additional options appear.
Related tasks

Viewing storage virtualization changes on page 100
Viewing the topology map and changes for a path on page 106
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Datastores view
You use this view to compare the capacity and performance characteristics of the ESX, storage and
fabric. You can also determine which data store to choose for the next virtual machine allocation.
Navigation
You can access this view in one of the following ways.
•

From the Insight Open menu, select Inventory > Datastores.

•

From the navigation pane on the left, select Inventory > Datastores.

•

From the OnCommand Insight Open menu, select Inventory > Hosts. Click the Datastores icon.

•

From the OnCommand Insight Open menu, select Assurance > Changes. Click the Datastores
icon.

Column descriptions
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by storage, this column displays the
storage names. The number in parentheses indicates the number of data stores in each
grouped row.
Name
The name of the data store.
Virtual Center IP
The IP address of the Virtual Center host for the data store.
VM Count
The number of virtual machines whose files are contained in this data store.
Hypervisor Count
The number of ESX hosts (hypervisors) that use this data store for their virtual machines.
FC Ports
The number of FC ports on the hypervisor hosts in the physical storage paths that this data
store logically represents.
Unused Capacity (GB)
The usable capacity that might be available for storing additional data on the storage pool,
in gigabytes.
Capacity (GB)
Usable capacity or configured size of the data store, in gigabytes.
Provisioned Capacity (GB)
The amount of total capacity that has been set aside for potential use, based on the virtual
machines using this data store. Includes space set aside for virtual machine files of all
types.
Used Capacity (GB)
The used capacity of the data store, in gigabytes.
VMDKs Capacity (GB)
The VMDKs usable capacity, in gigabytes.
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Over-committed Capacity
The amount of capacity that has been overcommitted from the storage pool. When thin
provisioning is in use, the total size of volumes and internal volumes that are created from
a storage pool can exceed the total size of the capacity committed to volumes and internal
volumes versus the total capacity of the storage pool. If there is no overcommitment on
the storage pool, the value is 0.
Commit Ratio
The ratio (%) of the sum of the capacity of all virtual disks allocated on a data store to the
capacity of the data store. If thin provisioning is in place, the ratio can be greater than
100%.
Storage
Name of volume or internal volume.
Resource Name
The volumes or internal volumes in the path.
Resource Capacity (GB)
The total capacity, in gigabytes, of the volumes or internal volumes in the paths for this
data store.
Resource Used Capacity (GB)
The total used capacity, in gigabytes, of the volumes or internal volumes, in the paths for
this data store.
Resource Technology
The SAN (FC and iSCSI) or NAS (NFS and CIFS) protocols that the device supports.
Deduplication Savings
The known amount of storage savings through deduplication, a process that detects blocks
with identical content and replaces subsequent identical blocks with a reference to a single
copy of the block.
Storage Pools
Storage pools associated with the data store.
Options
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
Available only with the Perform license. Allows you to investigate the performance of the
selected data store. For example, you can determine contention issues, availability issues,
and array performance. The Data Store Summary tab provides information that might be
needed for troubleshooting.
Analyze Storage Pools
Available only with the Assure license. Allows you to select a specific storage pool and
assess its status related to the thin-provisioning policies. You can use this dialog box,
instead of the Violations Browser, to see the current thin provisioning violations and how
close the storage pool is to reaching the policy limits.
Edit Annotations
Allows you to assign a predefined or custom category to this device so that you can later
group the devices by the annotation. For example, you might want to group all devices in a
specific data center or tier.
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Related tasks

Finding the best data store for a new virtual machine on page 91

Devices detail view
Use this view to identify the devices that receive information from a selected data source.
Navigation
Open the Data Sources main view or the Acquisition Units main view, highlight an item in the main
view, and do one of the following:
•

From the Client menu, select View > Detail Views > Devices.

•

At the bottom of the Client view, click the Devices detail view icon.

This detail view is available only after clicking a resource in a main view.
Column descriptions
blank
Column that organizes the data according to the selected grouping format. Applicable with
any presentation order other than No Grouping.
Device
Name of the data source device.
Connected
Indication of whether any other devices are connected to this device. Green indicates other
devices are connected to this device. For example, if Insight is collecting data on an array,
but not collecting on the switch to which that array is attached, the Connected column
shows a red X.
Type
The type of device, for example, storage, switch or fabric/VSAN.
Originator
Information about an attribute of a data source that helps in troubleshooting the data
source. A data source can have multiple originators of information and can be of different
types. The ID that appears in this field depends on the type of data source originator. For
example, if the originator is a switch, the IP of that switch appears in this field.
This might be helpful when you review data source error messages. The error includes the
originator information.
Identifier
The identifier information of the data source.
Originator Access Time
The last time that the data source successfully logged into the device and queried the
originator. If the Originator Access time is older than three months, the data in the row
appears in red.
Originator Update Time
The last time that the server was notified of changes to the originator. The acquisition does
not update the server if the data did not change.
Additional Data Sources
Additional data sources that report on the same device, if any. This field appears only if
accessing this view from the Acquisition Units main view.

OnCommand Insight views | 123

Disks detail view
Use this view to see a list of storage array disk drives associated with the selected device.
Navigation
You can access this detail view in one of the following ways:
•

From the Client menu, select View > Detail Views > Disks.

•

At the bottom of the Client view, click the Disks detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Paths main view

•

Changes main view

•

Hosts main view

•

Storage Arrays view

•

Topology view

Column descriptions
The Disks detail view displays the following information, depending on the device you select:
•

Information about disks configured on a storage array or for a host.
This applies when you select a storage array or a host in the Topology view or in the Storage
Arrays or Hosts main view.

•

Disk details for the currently selected row in the main view (for example, the disks accessible
through a specific path or the disks that relate to a particular violation).

blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by capacity, this column displays
the capacity values. The number in parentheses indicates the number of disks in each
grouped row.
Name
The name of the disk.
Storage
The storage array or arrays associated with the disk.
icon (Is virtual?)
A V icon indicates that the volume on the path is a virtualized volume.
Disk Size (GB)
The size of the disk, in gigabytes.
Disk Group
The vendor-specific, disk-group value, often related to RAID storage. Refer to the device
documentation for an explanation of values.
Disk Speed (RPM)
The speed of the disks in revolutions per minute.
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Type
Vendor-specific type of disk. The following values could appear: ATA, FATA, FC, SAS,
SATA, SATA2, SATA3, SSD, Other.
Position
Location of the disk, as in, for example, Symmetrix: DirectorID-075, Slot 38.
Serial Number
Serial number of the disk, if the data source supports reporting it.
Role
Role of the disk, as obtained from the vendor. Values include data, faulty, parity, double
parity, mixed, spare, unallocated, or other. For spare disks, “spare” appears.
Status
Status of the disk, if the data source supports reporting it. The following values could
appear:
•

Normal

•

Copying

•

Failed

•

Partner

•

Pending

•

Questionable

•

Reconstructing

•

Zeroing

•

Other

Vendor
The disk vendor.
Model
The disk model, as provided by the vendor.
Options
From the detail view, right-click to show a pop-up menu containing the following options. If other
modules are installed, additional options appear. See the documentation for that module.
Show Volumes
Displays the volumes associated with this disk in a separate view.
Show Volume Members
Displays the volume members of the disk. You can select a volume member and see the
other disks that the volume member uses.
Show Storage Pools
Displays all storage pools using the selected disk in a separate view.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
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Displays all performance data for the selected disk in a separate dialog box. You can see
volume contention, disk contention, performance charts, performance patterns and trends,
and topology. Requires Insight Perform license.
Analyze Storage Pools
Available only with the Perform license. Enables you to select a specific storage pool and
assess its status related to the thin-provisioning policies. You can use this dialog box,
instead of the Violations Browser, to see the current thin provisioning violations and how
close the storage pool is to reaching policy limits.

FC Ports detail view
Use this view to determine port information for a selected device. This view shows Fibre Channel
port information only.
Navigation
You can access this detail view in any of the following ways:
•

From the Client menu, select View > Detail Views > FC Ports.

•

At the bottom of the Client view, click the FC Ports detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Paths main view

•

Changes main view

•

Switches view

•

Hosts main view

•

Storage Arrays view

•

Tapes view

•

Generic Devices view

•

Zones view

•

Topology view

The FC Ports detail view displays information about the following:
•

The Fibre Channel ports on the currently selected device (applicable with the Topology view or
from any main inventory view.

•

The ports on all devices referenced by the currently selected row in the main view (for example,
storage and host devices for a path).

Column descriptions
Insight shows as much information about each port as it can obtain from the device. If a field is
blank, the information was not available, in which case you should consult the device documentation
for further details.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by device name, this column
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displays the application names. The number in parentheses indicates the number of ports
in each grouped row.
Name
Name of the port or, if no name is available, the WWN of the port.
Connected to
Device and port to which the port identified by the Name field is physically connected.
Connected Node WWN
Node WWN of the connected port.
Connected Port WWN
Port WWN of the connected port.
Port Index
The index number of the port on the device.
icon (Is the device offline?)
An icon in this column indicates that the device is inactive (offline).
Fabric/VSAN
The fabric or VSAN on which the port is configured to operate.
State
The current state of the port, for example, Online or Faulty, taken from the device itself.
Value

Description

Inactive

Port is online, but shows no activity. It is not connected to
anything.

Offline

Port is not online.

Online

Port is working successfully.

Faulty

Port is online, but errors are reported.

Testing

Port is online, but is in test mode.

Unknown

The status of the port cannot be determined.

Status
The current status of the port based on information from the device itself. Insight obtains
the values from the Vendor Status column and translates them into one of the following
predefined statuses:
Note: Because the values are taken from the device, some State and Status values may
be similar or even the same.

Value

Description

Disabled

Port is not online.

Faulty

Port is online, but errors are reported.

Inactive

Port is online, but shows no activity. Possibly the port does
not have a loop address.

Not supported

The status of the device is not provided by the vendor.

OK

Port is working successfully.

Segmented

Port is connected and there are no physical problems;
however, some configuration issues, such as zoning, exist.
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Value

Description

Unknown

The status of the port could not be determined.

Unused

Port exists, but is not used.

Warning

The port is online, but errors are reported.

Vendor Status
The status as supplied from the vendor. Refer to the device documentation for an
explanation of values.
Is Generated
Indicates that this port was generated during acquisition.
Type
The port type, typically used to identify the protocol used to communicate with the other
device, taken from the device itself. For example, E-Port, F-Port, G-Port, or TE-Port.
Speed
The speed capability of the port.
Switch Blade
Switch unit that contains or is connected to the port.
Controller
The storage controller that contains or is connected to the port.
GBIC
The type of Gigabit Interface Converter (GBIC) used for the port.
Port WWN
The World Wide Name (WWN) used to identify the port.
Node WWN
The WWN for the port's node.
Identify Information
The alias from the fabric to which the port is connected. If there is more than one alias
related to the port from the same fabric, they appear separated by commas. This is the
same information as shown in the Switch Alias field in the FC Identify view.
Device Name
The name of the device where the port resides.
Device Type
Type of device in the storage network, for example, switch, host, or storage array.
FC4
The FC4 (application layer) protocol. Applicable for switch ports only. Displays any or a
combination of the following values:
•

BASIC_LINK

•

EXTEND_LINK

•

FCIP

•

SCSI_FCP

•

FC_SERVICES

•

FC_SW
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•

SNMP

•

FABRIC_SERVICES

•

FABRIC

•

DIAG

•

VI

Firmware
The version of the firmware running on the port.
Driver
Name of the device managing access to the generic device.
Vendor
The name of the vendor who sells the port.
Model
The model number supplied by the manufacturer.
Serial Number
The serial number of the device.
Reservation Status
Indication of whether the volume is currently Used (masked and mapped), is Reserved for
fulfilling a storage request, or is Free for allocation or reservation. (OnCommand Insight
Plan only)
Tenant, Line of Business, Business Unit, and Project
A hierarchy of information that can be associated with resources. The hierarchy includes
tenant, line of business, business unit, and project. For details about setting up business
entities and assigning them, see "Setting up business entities."
Options
From the FC Ports detail view, right-click to open a menu containing the following options.
Set Annotation
Allows you to assign a predefined or custom category to this device so that you can later
group the devices by the annotation. For example, you might want to group all devices in a
specific data center or tier.
Clear Annotation
Removes the assigned annotation from this device.
Open Request
Available only with the Plan license. Allows you to open a storage request that was
entered through the Web-based Request Portal or the Client and make changes and
reservations. See the OnCommand Insight Planning User Guide for the Java UI for
detailed instructions on managing these requests. This guide also explains how to use the
other two Plan options: Reserve ports for an existing request and Reserve ports for an
new request.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
Available only with the Perform license. Allows you to analyze the performance for the
selected data store.
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File Systems detail view
Use this view to identify the file systems in your environment. File systems make use of an
underlying data storage device that offers access to an array of fixed-size blocks, for example, a local
hard drive, SAN LUN, or SAN volume.
Navigation
If you have the Insight Plan license, you can access this detail view from one of the following views:
•

Paths (if the link between the LUN or NAS share is discovered)

•

Changes

•

Hosts

•

Topology (if the link between the LUN or NAS share is discovered)

Click the File Systems detail view icon.
Column descriptions
The File Systems detail view displays the following, depending on what you select in the main view
or Topology view.
blank
When you group the data using the Grouping drop-down list, the Grouping column shows
the grouped values. For example, if you grouped the data by fabric, the Grouping column
displays the fabric names. The number in parentheses indicates the number of switches in
each grouped row.
Name
Displays the name of the file system.
Capacity (GB)
Displays the usable capacity of the file system, in gigabytes.
Used Capacity (GB)
The sum of all internal volumes' consumed capacity, including reserved capacity,
Snapshot used capacity, Snapshot reserved capacity, and storage efficiency technology
overhead. If no internal volumes are present, Capacity Used is the sum of all volumes
consumed capacity, including reserved capacity, Snapshot used capacity, Snapshot
reserved capacity, and storage efficiency technology overhead.
Utilization
Displays the percentage of storage space used on the file system.
Location Type
Displays the type of file system location, for example, SAN, NAS, or local.
Type
Displays the type of file system, for example, NTFS or FAT32.
Last Agent Report Time
This is the last time the data source reported to Insight.
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Generic Devices main view
Fibre Channel switches that are monitored by OnCommand Insight sometimes report about devices
whose identity is unknown. Each unknown port on such a device is reported as a generic device until
it is identified. Use this view to identify those FC-based devices that OnCommand Insight does not
identify as hosts. After you identify a device, it no longer appears on the Generic Devices view.
Navigation
You can access this main view in one of the following ways:
•

From the OnCommand Insight Open menu, select Inventory > Generic Devices.

•

From the navigation pane, select Inventory > Generic Devices.

Column descriptions
A host can have multiple ports connected to multiple switches; multiple generic devices might be
identified as a single host. A host can have multiple IPs, and multiple IPs might be identified as a
single host.
For details about data source setup, device identification and data acquisition, see the OnCommand
Insight Configuration and Administration Guide.
The following information appears in the main view for each generic device, if available. This
information is reported by the data source that discovers the generic device. All unidentified FC
devices are called generic devices until they are identified as a host, storage, or tape. After that
happens, they are no longer generic devices, and no longer display on the Generic Devices view.
However, the Identify views show all identifications made in OnCommand Insight, so you can
review, update, and correct identifications as needed.
WWN
World Wide Name assigned to the device.
Vendor
The name of the vendor who sells the generic device based on industry standard WWN
allocation ranges.
Model
The device manufacturer's model number.
FC Port Count
The number of licensed ports on the device.
Last Report Time
Date and time when the information about the device was last received.
icon (Is the device offline?)
An icon in this column indicates that the device is inactive (offline).
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Options
To see details for a particular device, click on the device in the Generic Devices view. At the bottom
of the OnCommand Insight Client window, in the icon bar, click the Properties icon.
Generic Devices Properties
Select this to display the Generic Devices Properties view for the selected device in a
separate window, allowing you to hold the properties of one device while selecting another
device in the main view.
From the Generic Devices view, right-click to show a pop-up menu containing the following options.
If other OnCommand Insight modules are installed, additional options appear. See the documentation
for those modules, as appropriate.
Identify
Select this to identify the selected device manually in a wizard.
Delete Inactive Device
Removes the selected device, typically after you decommission it from your environment.
OnCommand Insight confirms the request before removing the device from the database.
Before using this option, make sure that the device is marked as inactive. An icon
indicating whether the device is offline appears in this view. The device's icon in the
Topology view should be grayed, as well as the corresponding row in the inventory
display. There should not be any links from the device to other devices in the Topology
view. This happens automatically when you remove the data source corresponding to the
device. If no inactive devices exist, this option is disabled.
See information about deleting inactive devices.
Analyze
Shows the performance information for the selected resource. This requires the
OnCommand Insight Perform license.

Hosts view
Use this view to identify the hosts that Insight detects in your environment. A host can be a client, a
server, both a client and a server, a manager, or a managed host. The host can provide a centralized
control of the network.
You can view hosts in both your SAN and NAS environments. For NAS environments, you can view
hosts as defined by their usage of NAS shares.
Hosts that are inactive appear in gray text. Active hosts appear in either black text (no violations
exist) or red text (violations exist).
You can select a host and associate it with one or more applications, delete an inactive host, delete an
inactive HBA adapter, or view host properties. You can also register a host with your user name to
indicate those hosts to which you want to pay particular attention. You can then filter the list of hosts
by those that are registered with your name.
This view displays the following types of hosts:
•

Hosts that have been identified from detecting and identifying FC WWNs

•

Hosts that have been identified from detecting and identifying IPs accessing NFS shares

•

Hosts that have been identified from detecting and identifying IPs accessing iSCSI initiators

•

All ESX servers reported from the VMware data source

All changes made in the IP Identify view appear in the Hosts main view.
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Navigation
You can view host information in the Hosts main view or detail view.
You can access the detail view by selecting a device in the main view and then clicking on the Hosts
detail view icon at the bottom of the view.
You can access this main view in any of the following ways:
•

From the Open menu, select Inventory > Hosts.

•

From the navigation pane, select Inventory > Hosts.

You can access the detail view by selecting a device in the main view and then clicking on the Hosts
detail view icon at the bottom of the view.
Column descriptions
The table reflects the configuration of the host server itself, based on the manufacturer's configuration
procedures. The number following the table heading (in parentheses) indicates the total number of
hosts in the list.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by application, this column displays
the application names. The number in parentheses indicates the number of hosts in each
grouped row.
(Registered)
Indication that the host on this row is registered to the current user. You can register with
any number of hosts and then filter on this field to view only the hosts registered to you.
Name
The name of the host.
IPs
The IP address or addresses assigned to the host. Multiple IPs are separated by commas.
No IP appears more than once.
Protocols
The SAN (FC and iSCSI) or NAS (NFS and CIFS) protocols that the device supports.
Multiple protocols appear, separated by commas.
icon (Is the device offline?)
An icon in this column indicates that the device is offline.
OS
The operating system running on the host.
FS Unused (GB)
The amount of free storage in the host file systems, in gigabytes.
FS Total (GB)
The total amount of storage in the host file systems, in gigabytes.
FS Used (GB)
The amount of used storage in the host file systems, in gigabytes.
CPU Count
The number of CPUs running on the host.
CPU Speed (MHz)
The speed of the host CPU.
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DB Count
The number of databases for the host.
Domain Name
The host DNS name.
Memory (MB)
The total amount of memory available on the host.
Model
The manufacturer's model number.
OS Class
The class of the operating system running on the selected host.
OS Level
The operating system level running on the host.
OS Release
The release of the operating system running on the selected host.
Vendor
The name of the vendor who manufactures the device.
NIC Count
The number of the Network Interface Connectors (NICs) used for iSCSI
traffic.
NIC Speed
The speed of the NIC.
V-Host
Indication that the host is a virtual machine host.
•

Blank
The path originates from a standard host.

•
The path originates from a virtualization host (ESX server).
•
The path originates from an ESX server and is currently running, meaning that at least
one of the virtual machines accessing this volume from the host is running. Because
the Insight path does not include the storage port, this indication does not show the
active path.
•
The path originates from an ESX server, but the volume is not mounted.
V-Cluster
A group of virtualization hosts sharing access to the same SAN volumes. A V-Cluster is
either a VMware HA cluster or a manually defined group of hosts.
V-Policy
Indication whether a Host Virtualization Policy has been applied. The column displays an
icon when a host is excluded from the virtual machine Host policy. Otherwise, the column
is blank.
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Application
Applications to which this host has been assigned. If the host is not dedicated to any
application, no value appears here. Together, hosts associated with an application are
known as an application group.
Application Priority
The priority for each application if the host is assigned to specific applications. Listed in
the same order as the applications in the Application field.
Tenant
Part of the Business Entity definition. Primarily used by service providers to associate
resources to a customer.
Line of Business
Part of the Business Entity definition. A line of business within a company: for example,
“Snack Foods” or “Soft Drinks.”
Business Unit
Part of the Business Entity definition. The business unit associated with the host's
applications. Listed in the same order as the applications in the Application field.
Project
Part of the Business Entity definition. A project to which you might want to further
analyze capacity chargeback.
icon (Uses virtual volumes?)
A “V” icon indicates that the host accesses one or more virtualized volumes.
If a “V” appears, you might find it helpful to open the Virtual Storage detail view and the
Backend Volumes detail view.
FC Port Count
The number of FC ports on the host machine.
icon (Are there violations?)
A violation icon in this column indicates there are violations on this host.
icon (Policy )
Indicates that a policy has been set to control this host
icon (Redundancy Violation)
Indicates a missing path redundancy violation for the host.
Last Report Time
Date and time when the information about the device was last received.
<annotations>
Annotations associated with each host. Different types of annotations display in separate
columns.
Options
From the Hosts main view, right-click on a row to show a pop-up menu containing the following
options. If otherInsight products are installed, additional options appear. See the documentation for
those modules, as appropriate.
Delete Inactive Device
Removes the selected host device, typically after you decommission it from your
environment. Insight confirms the request before removing the host server from the
database. Then, the HBAs for the host appear as generic devices unless you delete them
also, with the Delete Inactive Adapter option.
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Before using this option, make sure that the device is marked as inactive. An icon
indicating whether the device is offline appears in this view. The device's icon in the
Topology view view should be grayed, as well as the corresponding row in the inventory
display. There should not be any links from the device to other devices in the Topology
view. This happens automatically when you remove the data source corresponding to the
device. If no inactive devices exist, this option is disabled.
Delete Inactive Adapter
Removes an inactive host adapter from the selected host. Insight confirms the request
before removing the host adapter or controller from the Insight database. The host remains
connected via other active HBAs.
Undo Identification
Removes the identification for a host server that was identified manually. Insight confirms
the request and then removes the host's identifying data from the database, reverting it to a
generic-device status.
Note: You cannot undo the identification for devices that are discovered through data
source acquisition.

Set Applications
Assigns the selected host to one or more applications that you select.
Set Business Entities
Assigns the select host or hosts to a business entity (tenant, line of business, business unit,
and project).
Automatically Add Applications
Automatically adds hosts to applications based on a host naming pattern.
Set/Remove/Modify items for both FC and iSCSI host policies
Available only with the Perform license.
Attaches a policy to physical system elements such as a host, storage, or VM, and to
logical elements such as path or fabric. Policies may be based on detecting compliance
with configurations, or they can be based on transitory events like a performance spike.
Or, changes or removes the policy.
Modify Policy
Allows you to modify non-performance policies and is only available with the Assure
license. (You modify performance policies using the web UI.)
Register
Registers a host so that you can focus on hosts registered to you. You might want to
register those hosts or servers for which you receive regular reports. You can register with
any number of hosts. After you register a host, the Register pin icon
host row.

appears in the

Unregister
Removes your registration from a host.
Create Request for Host(s)
Allows you to request storage space on the selected hosts and associate that with an
existing request or generate a new request. This requires the OnCommand Insight Plan
license.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
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Available only with the Perform license. Allows you to investigate the performance of the
selected resources affected by the violation. For example, you can determine contention
issues, availability issues, and array performance.
Analyze Storage Pools
Available only with the Assure license. Allows you to select a specific storage pool and
assess its status relative to thin-provisioning policies. You can use this dialog box, instead
of the Violations Browser, to see the current thin provisioning violations and how close
the storage pool is to reaching the policy limits.
Edit/Set/Clear Annotation
Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or tier. The Clear option removes the annotation from
the resource.
Related tasks

Viewing all hosts on page 30
Registering a host on page 31
Adding hosts to an application automatically on page 32
Working with Insight Java UI views on page 12

Internal Volumes detail view
You can use this view to find information about volumes that are used internally in storage devices.
Only some storage devices have internal volumes.
Navigation
You can access this detail view in one of the following ways:
•

From the Client menu, select View > Detail Views > Internal Volumes.

•

At the bottom of the Client view, click the Internal Volumes detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Changes main view

•

Hosts main view

•

Paths main view

•

Storage Arrays view

•

SAN Path Violations view

•

Topology view

•

Virtual Machines view

•

Generic Devices view

•

Zones view
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Column descriptions
The Internal Volumes detail view displays the following, depending on what you select in the main
view or Topology view:
If other modules are installed, additional columns might appear. See the documentation for that
module.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by clone, this column displays the
clone names. The number in parentheses indicates the number of internal volumes in each
grouped row.
Name
The name of the internal volume.
Storage
The name of the storage array on which the internal volume resides.
SVM/vFiler
The name of the SVM (Storage Virtual Machine) or vFiler unit. An isolated software
container that behaves exactly like a physical storage array. A vFiler unit shares the
physical resources of the array, but abstracts the client access from the physical array into
virtual arrays.
Capacity (GB)
The usable capacity of the internal volume, in gigabytes.
Raw Capacity (GB)
Physical disk capacity of the internal volume, in gigabytes. This differs from usable
capacity when technologies such as RAID-5 are used, where some of the raw capacity is
used for protection purposes.
Used Capacity (GB)
Used capacity of the internal volume in gigabytes as read from the device (taken from the
data source).
Used Capacity (%)
Used capacity of the internal volume in gigabytes as read from the device (taken from the
data source) divided by Capacity.
Consumed Capacity (GB)
The amount of capacity in gigabytes taken from the underlying storage pool for this
internal volume, including reserved capacity, Snapshot copy used capacity, Snapshot copy
reserved capacity, and storage efficiency technology overhead.
Storage Pool
The storage pool on which the internal volume resides. A logical layer used by some
storage array to map the resources (volume and shares) to the storage (for example, disks
and backend volumes) where the capacity actually resides.
Type
The type of internal volume: for example, FlexClone or FlexVol.
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FlexClone is a NetApp software technology that allows instant replication of data files,
LUNs, and volumes without requiring additional storage space. Each cloned file, LUN, or
volume is a virtual copy of the original data.
FlexVol volumes can have multiple volumes stored on a single aggregate, while traditional
volumes have one volume per aggregate. FlexVol is a NetApp storage-virtualization
technology that pools physical storage, so you can create and resize virtual volumes as
application needs change.
Flash Pool Eligibility
Indication of the type of usage that the selected internal volume is making of the Flash
Pool technology. The statuses could include read, read-write, or none to indicate whether
the internal volume is using Flash disks for cache. "Read" indicates that Flash disks are
being used for read access. "None" indicates that the internal volume is not leveraging
Flash disks for cache. "Read-write" indicates that Flash disks are being used for both read
and write access.
Thin Provisioned
A check mark is displayed if the internal volume is leveraging thin provisioning.
Volume Count
The number of volumes associated with this internal volume.
Share Count
The number of shares associated with this internal volume.
Datastore
The name of the storage location for virtual machines.
Space Guarantee
A vendor-specific indication of how the internal volume's space is allocated if thin
provisioning is used. For NetApp, displays one of the following types:
•

Volume: NetApp pre-allocates space in the storage pool for the volume. The preallocated space cannot be allocated to any other volume in that storage pool.

•

File: NetApp pre-allocates the space in the volume so that any file in the volume with
space reservation enabled can be completely rewritten, even if its blocks are pinned for
a Snapshot copy.

•

None: NetApp reserves no extra space for the volume. Writes to the LUNs or files
contained by that volume could fail if the containing storage pool does not have
enough available space to accommodate the write.

Deduplication Savings (%)
The percentage of space saved on the internal volume due to data deduplication. This
column is empty for internal volumes for which deduplication is not enabled.
This represents the rate of savings in the internal volume. For example, 1/3 of capacity is
saved by using deduplication.
Data Warehouse and Insight reports show a Deduplication Ratio data element. This
represents the rate of compression that occurs from using deduplication, complementary
data related to Deduplication Savings. In the example where Deduplication Savings is 1/3,
the Deduplication Ratio is 2/3.
Clone Source
The name of the internal volume that this internal volume cloned. This is the source of the
cloned relationship.
Clone Shared Capacity (GB)
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When the internal volume is a clone of another internal volume, the amount of capacity in
gigabytes that is shared between this internal volume (which is a clone) and the source of
the clone. A cloned internal volume stores on the disk only the disk differences between
the clone and the source. The amount of space in common between the source and the
clone is reported in this value. If no changes were made to the source and target internal
volumes since the clone operation occurred, all capacity is shared. Modifications made to
either of the internal volumes decreases the shared capacity.
Replication Technology
The type of replication technology, for example, SnapMirror.
Replication Mode
Type of replication, for example, Synchronous, Asynchronous, Semi-Synchronous, Copy,
or Unknown.
Replica Source Storage
Storage device that contains the internal volume being replicated.
Replica Source Internal Volume
Internal volume that is being replicated.
Status
Information about whether the internal volume is online, offline, or OK.
Snapshot Reserve (GB)
The amount of usable capacity, in gigabytes, reserved for Snapshot copies for the internal
volume.
Snapshot Used (GB)
The amount of usable capacity, in gigabytes, that has been used for Snapshot copies for
the internal volume.
Snapshot Used (%)
The percentage of the Snapshot copy reserve capacity that has been used. If the value
exceeds 100%, the Snapshot copies overflowed the reserved space.
Snapshot Overflow (GB)
The amount of usable capacity, in gigabytes, that is used for Snapshot copies for the
internal volume that exceeds the space reserved for the volume for Snapshot copies.
Snapshot Count
The number of Snapshot copies that are stored for this internal volume.
Last Snapshot
The time when the last Snapshot copy operation occurred on this internal volume.
Disk Types
The types of physical disks (for example, Fibre Channel or ATA) on which the internal
volume is based.
Disk Size (GB)
Comma-separated list of the sizes of the physical disks on which the internal volume is
based.
Disk Speed (RPM)
The speed of the physical disks on which the internal volume is based.
Application
The name of the application associated with this resource.
Application Priority
The priority (high, medium, or low) assigned to the application.
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Tenant, Line of Business, Business Unit, and Project
A hierarchy of information that can be associated with resources. The hierarchy includes
tenant, line of business, business unit, and project. For details about setting up business
entities and assigning them, see "Setting up business entities."
annotations
User-defined annotations associated with each internal volume.
Options
From the detail view, right-click to show a pop-up menu containing the following options. If other
modules are installed, additional options appear.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Set Applications
Assigns the selected internal volume to one or more applications that you select.
Set Business Entities
Assigns the select internal volume or internal volumes to a business entity (tenant, line of
business, business unit, and project).
Automatically add Applications
Automatically adds applications to internal volumes based on the internal volume naming
pattern.
Modify Policy
Changes the global general policies governing specific items you select in the view.
Edit/Set/Clear Annotation
Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or building location. The Clear option removes the
annotation from the resource.

iSCSI Sessions detail view
Use this view to determine the active sessions formed between an iSCSI initiator node and an iSCSI
target node. An iSCSI session represents the communication between an initiator and a target. This
communication occurs over one or more TCP connections. In Insight, initiator nodes are associated
with hosts and target nodes with storage.
Navigation
You can access this detail view in one of the following ways.
•

From the Insight Client menu, select View > Detail Views > iSCSI Sessions.

•

At the bottom of the Client view, click the iSCSI Sessions detail view icon.

This view appears only when the Insight NAS, iSCSI and Multiprotocol Capacity license is installed.
This detail view is available after clicking a device in one of the following views:
•

Paths main view

•

Changes main view
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•

Hosts main view

•

Storage Arrays view

•

Topology view

Column descriptions
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by target storage, this column
displays the target storage names. The number in parentheses indicates the number of
sessions in each grouped row.
Target Storage
The storage device targeted by the session.
Target Node Alias
The user-configurable name assigned to the target node.
Target Node Name
The unique identifier for the target (storage) node.
Initiator Device
The host that initiates SCSI requests to the iSCSI target.
Initiator Node Alias
The user-configurable name assigned to the initiator node.
Initiator Node Name
The unique identifier for the initiator (iqn/eui) node.
Portal Group
The portal group information, which includes both a name and a number. The name is a
user friendly alias set by the administrator, but is optional. The portal group value is
displayed as "name (number)" if both name and number are specified, or just the number
if the name is blank.
Authentication
The authentication protocol as CHAP or NONE. The Challenge Handshake
Authentication Protocol (CHAP) enables authenticated communication between iSCSI
initiators and targets.
Max Connections
The maximum number of iSCSI connections that are allowed for the given session.
Connection Count
The number of iSCSI connections that are used by the selected session.
Target Session ID
The iSCSI session identifier assigned by the storage.
Initiator Session ID
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The iSCSI session identifier assigned by the initiator host.
Initiator IPs
The IP address or addresses of the initiator.

Masking detail view
You use this view to identify all volumes that are masked or mapped for a particular storage array or
host.
Zone and masking conflict resolution
You can use the Tools > Analyze Zone and Mask option to determine why masking entries are not
recognized in zones, which is typically a path issue with the host.
Navigation
You can access this detail view in any of the following ways.
•

From the Client menu, select View > Detail Views > Masking.

•

At the bottom of the Client view, click the Masking detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Paths main view

•

Changes main view

•

Hosts main view

•

Storage Arrays view

•

Generic Devices view

•

Zones view

•

Topology view

Column descriptions
The details vary depending on the type of device selected.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by status, this column displays the
statuses. The number in parentheses indicates the number of masked or mapped volumes
in each grouped row.
Technology
The SAN (FC and iSCSI) protocols that the volume mask supports.
Storage
The storage array or arrays associated with the mapped or masked device.
Volume
The name of the volume that is masked to the host port or node referenced to the right.
Capacity (GB)
The size of the volume that is accessible to host applications, in gigabytes.
Raw Capacity
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Physical capacity actually present on the device, in gigabytes. At the storage pool level,
this differs from usable capacity when technologies such as RAID-5 are used, where some
of the raw capacity is used for protection purposes.
icon (Array Virtualization Type)
A "V" icon indicates that the device is a virtualized volume and a "B" icon indicates that
the device is a backend volume.
Storage Port
The name of the storage port (on the specified storage array) from which the volume is
accessible.
LUN
The logical unit number used by the host to access this volume.
Status
One of the following statuses of the masking or mapping for the volume.
Status

Indicates that the volume is:

No mapping

Not mapped to a storage port.

Allocated (no masking)

Mapped to a storage port and masked to a host, but the
masking has been disabled so that the volume is accessible to
any host. (WWN security is disabled.)

No masking

Mapped, but not masked.

Allocated

Mapped to a storage port and masked to a host.

Host
The host to which the storage volume is masked.
Host Initiator
The WWN or node name for the host port to which the storage volume is masked.
Storage Target
The WWN or node name for the storage port.
Initiator Alias
The ASCII alias (Symmetrix only).
Inbound CHAP User
The user name used for Challenge Handshake Authentication Protocol (CHAP)
authentication with the target storage. The CHAP enables authenticated communication
between iSCSI initiators and targets.
Outbound CHAP User
The user name used for CHAP authentication with the initiator host.
Detailed Status
Information about whether there is any problem with the masking. For example, you
might see a message indicating that the host and storage devices do not share zones or that
there is a disconnected host port.
Protocol Controller
The protocol converter through which the volume is mapped to a storage port (applicable
only for some types of storage arrays, for example, EMC CLARiiON).
Datastore
The name of the storage location for virtual machines.
RDM
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A VMware feature that exposes SCSI targets directly to a virtual machine. RDMs are an
alternative to using VMFS. RDMs are special files in a VMFS volume that act as proxies
for raw devices.
Related tasks

Analyzing mismatched zones and masks on page 74

Network Portals detail view
Use this view to see iSCSI network portal information about an iSCSI selection.
Navigation
You can access this detail view in one of the following ways.
•

From the Client menu, select View > Detail Views > Network Portals.

•

At the bottom of the Client view, click the Network Portals detail view icon.

This detail view is available from one of the following views:
•

Paths main view

•

Changes main view

•

Storage Arrays view

Column descriptions
Insight shows as much information about each network portal as it can obtain from the device.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by portal group, this column
displays the portal group names. The number in parentheses indicates the number of
portals in each grouped row.
Interface
Displays the name of the Network Interface Connector (NIC) used for iSCSI traffic.
IP
Displays the IP address of the network portal.
Port
Displays the TCP port that the storage is listening on for this portal.
Portal Group
Displays the portal group information, which includes both a name and a number. The
name is a user friendly alias set optionally by the administrator. The portal group value is
displayed as "name (number)" if both name and number are specified, or just the number
if the name is blank.
Device Name
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Displays the name of the device associated with the specific network portal.
Related tasks

Working with tables and data in OnCommand Insight views on page 13

NPV Switches view
This view lists all of the NPV and access gateway (proxy) switches that OnCommand Insight detects
in your environment. This view applies to SANs only. The inactive NPV switches appear in gray text;
active switches appear in black text.
Navigation
You can access this main view in one of the following ways:
•

From the OnCommand Insight , select the Open menu and Inventory > NPV Switches.

•

From the navigation pane, select Inventory > NPV Switches.

Column descriptions
The main table reflects the configuration of the switch itself, based on the manufacturer's
configuration procedures. The number following the table heading (in parentheses) indicates the total
number of switches in the list.
blank

When you group the data using the Grouping drop-down list, the Grouping column shows
the grouped values. For example, if you grouped the data by fabric, the Grouping column
displays the fabric names. The number in parentheses indicates the number of switches in
each grouped row.
Name
The name of the switch, as provided by the SAN manager at the switch console. Inactive
NPV switches appear gray.
WWN
World Wide Name assigned to the switch.
Fabric/VSAN
The fabric or VSAN on which this NPV switch is configured to operate.
IP
IP address assigned to the switch.
Vendor
The name of the vendor who sells the switch.
Model
The model number from the switch manufacturer.
Firmware
The version of the firmware running on the switch.
Serial Number
The serial number of the switch.
icon (Is the device offline?)
An icon in this column indicates that the switch is offline.
FC Port Count
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The number of Fibre Channel ports on the switch.
Status
The current status of the switch as reported by the switch. The conditions on the switches
that result in the following values might differ between switches:
Value

Definition

Faulty

The switch is not working properly.

Not supported

The status of this switch is not provided
by the switch vendor or the switch is
unused.

OK

The switch is working properly.

Unknown

OnCommand Insight cannot detect the
status of the switch. The status is not
reported by the vendor.

Warning

The switch is operating; however, an issue
exists.

Type
Vendor-specific type of switch.
Last Report Time
Date and time when the information about the device was last received.
Options
The NPV Switches view has these options available on the right-click menu.
Delete Inactive Device
Removes the selected switch device, typically after you decommission it from your
environment. OnCommand Insight confirms the request before removing the device from
the database.
Before using this option, make sure that the switch is marked as inactive. An icon
indicating whether the switch is offline appears in this view. The switch icon in the
Topology view should be grayed, as well as the corresponding row in the inventory
display. There should not be any links from the switch to other devices in the Topology
view. This happens automatically when you remove the data source corresponding to the
switch. If no inactive devices exist, this option is disabled.
Delete Inactive Ports
Removes inactive ports from the selected switch. OnCommand Insight confirms the
request before removing the port from the database. The switch will remain connected
through any other active ports. If no inactive ports exist, this option is disabled.
Manage Switch
Launches a third-party management console or user interface for the selected switch. If
the third-party management console is not configured, this option is disabled.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Set Business Entities
Assigns the selected resource or resources to a business entity (tenant, line of business,
business unit, and project).
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Edit Annotations
Allows you to assign a predefined or custom category to this device so that you can later
group the devices by the annotation. For example, you might want to group all devices in a
specific data center or tier.
Related concepts

Maintaining Insight on page 8

Paths view
Use this view to see details about the selected path, which is the logical relationship between a host
server and its data residing on a storage device. The Paths view shows both SAN and NAS NFS
paths.
Navigation
You can access this view in any of the following ways:
•

From the Client menu, select Inventory > Paths.

•

From the navigation pane, select Inventory > Paths

•

To display the detail view from a main view, click the Paths icon below the main view.

Column descriptions
The Paths view displays information about each known access path for the currently selected device.
icon (Are there violations?)
An icon in this column marks a path with a violation.
Protocols
The protocol used by the given path. The SAN (FC and iSCSI) or NAS (NFS and CIFS)
protocols that the device supports.
Policy Type
The type of policy assigned to this resource, if any. Types include Global Storage, Host,
Path, and Global Backend Volume.
Host
The name of the host from which the path originates.
V-Host
Indication that the host is a virtual machine host.
•

Blank: The path originates from a standard host.
: The path originates from a virtualization host (ESX server).

•
•

: The path originates from an ESX server and is currently running, meaning that
at least one of the virtual machines accessing this volume from the host is running.
Because the Insight path does not include the storage port, this indication does not
show the active path.

•
V-Cluster

: The path originates from an ESX server, but the volume is not mounted.
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A group of virtualization hosts sharing access to the same SAN volumes. A V-Cluster is
either a VMware HA cluster or a manually defined group of hosts.
Storage
The name of the storage device where the data for this path resides.
SVM/vFiler
The name of the SVM or vFiler unit, if the path target is associated with a vFiler unit. A
vFiler unit is An isolated software container that behaves exactly like a physical storage
array. A vFiler unit shares the physical resources of the array, but abstracts the client
access from the physical array into virtual arrays.
Storage Alias
This user-defined annotation provides an easy to recognize alias for the storage.
Storage Pool
The storage pool on which the storage target resides.
Volume
The name of the volume where the data for this path resides (applicable with paths to
SAN storage arrays only).
Capacity
The total usable capacity of the volume, in gigabytes.
Share
Name of the share path end point for NAS paths. If the path is to a share, the full path to
the share appears.
Active SP
The name of the storage processor used by the active path from the host to the volume.
There can be only one active path for a given pair of (host, volume) and thus one storage
processor.
icon (Array Virtualization Type)
Indicates the type of virtualization. A “V” icon indicates that the volume on the path is a
virtualized volume, and a “B” icon indicates that the volume on the path is a backend
volume.
If the path connects to a volume, the V or B column indicates if the volume is virtual,
backend, or neither. If the path connects to a share, the V or B column indicates if the
share is virtual.
The column is always empty if the path does not connect to a volume or share, such as in a
tape path.
Since
The date and time when the path was first discovered.
(Registered)
Indicates whether the host on this row is registered to the current user. You can register
any number of hosts and then filter on this field to view only the hosts registered to you.
Application
Applications assigned to this host. If the host is not dedicated to any applications, no value
appears here. Together, the host servers associated with an application are known as an
application group.
Application Priority
The priority for each application if the host is assigned to run specific applications.
Tenant, Line of Business, Business unit, Project
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The business entities associated with each virtual machine as defined in Settings.
Host FC Port Count
The number of host ports that can access the storage (tape device or volume).
Storage FC Port Count
The number of storage ports through which the path accesses the volume.
Hops
The number of FC switch devices that the path traverses from the host to the storage. The
comma-separated list shows the number of switch hops for each physical path. For
example, one access path might have two potential physical paths, each with a different
number of switch devices.
Host Fabrics
The number of fabrics on which the host (associated with the selected path) resides.
Session Count
The number of iSCSI sessions that are used by this path.
Connection Count
The number of iSCSI connections that are used by this path.
RDM
A VMware feature that exposes SCSI targets directly to a virtual machine. RDMs are an
alternative to using VMFS. RDMs are special files in a VMFS volume that act as a proxy
for a raw device.
Datastore
The name of the storage location for virtual machines.
V-Policy
Indicates whether a Host Virtualization Policy has been applied. The column displays an
icon when a host is excluded from the virtual machine Host policy. Otherwise, the column
is blank. You can include or exclude the host from the policy using the Host Virtualization
Policy option on this view.
If you include the host in the V-policy, a check appears.
Options
From the Paths main view, right-click to open a menu.
Set/Remove Path Policy
Attaches a policy to logical elements such as path or fabric.
Set/Remove Host Policy
Available only with the Perform license.
Attaches a policy to or removes a policy from physical system elements such as a host,
storage, or VM. Policies can be based on detecting compliance with configurations, or
they can be based on transitory events like a performance spike.
Analyze Violation
Displays the Analyze Violation dialog box where you can look at the violation details and
review possible issues contributing to the violation.
Host Virtualization Policy
The host virtual machine (VM) policy is enabled by default for all of the hosts. This
policy is defined automatically and does not require adjustment. However, you can include
or exclude the host from the policy using this option.
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If you include the host in the V-policy, a check appears in the V-Policy column.
Analyze
Available only with the Perform license. Enables you to analyze the performance for the
selected data store.
Analyze Storage Pools
Enables you to select a specific storage pool and assess its status related to the thinprovisioning policies. You can use this dialog box, instead of the Violations Browser, to
see the current thin provisioning violations and how close the storage pool is to reaching
the policy limits.

Qtrees detail view
You can use this view to see the qtree subdivision of Insight internal volumes. With this view, you
can see the qtree security state, qtree status, and qtree type.
Navigation
You can access this detail view in any of the following ways:
•

From the Client menu, select View > Detail Views > Qtrees.

•

At the bottom of the Client view, click the Qtrees detail view icon.

This detail view is available after clicking a device in any of the following views:
•

Hosts main view

•

Paths main view

•

Storage Arrays view

•

Virtual Machines view

Column descriptions
The Qtrees detail view displays the following information.
Name
Name of the qtree.
Type
One of the following qtree types:
•

Default: Qtree was created by the system as a logical construct on the internal volume.

•

Explicit: Qtree was created by the user.

Storage
Name of the storage array on which the qtree resides.
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SVM/vFiler
Name of the SVM (Storage Virtual Machine) or vFiler unit on which the qtree resides.
Storage Pool
Name of the storage pool on which the qtree resides.
Internal Volume
Name of the internal volume on which the qtree resides.
Has Quota?
Indication that the qtree has one of the following types of quotas:
Space quota
Limits on the amount of usable space.
File quota
Limits the number of files that can be created on a NAS share or qtree.
Quota Used Capacity (GB)
Amount of capacity used towards the hard and soft capacity limit set on the quota. This is
blank if the qtree does not include quotas. Applies only if a tree type quota exists on this
qtree.
Quota Capacity Hard Limit (GB)
The disk space limit imposed on this qtree by a quota. If this is exceeded, data cannot be
written. This is blank if the qtree does not include quotas. Applies only if a tree type of
quota exists on this qtree.
Quota Capacity Soft Limit (GB)
The soft capacity space limit. If used capacity exceeds the soft quota, Insight displays a
warning message. Space requests can still be approved. Applies only if a tree type of
quota exists on this qtree.
Security Style
Type of security used on the host associated with the qtree (UNIX, NTFS, or Mixed).
Using qtrees enables the use of different security styles across projects. By default, the
security style of a qtree is the same as that of the root directory of the internal volume.
The view displays one of the following security styles:
UNIX
The user's UID, the user's GID, and the UNIX-style permissions of the file or
directory determine the user's access. The storage system uses the same method for
determining access for both NFS and CIFS requests.
NTFS
The standard file system for Windows operating systems.
•

For CIFS requests, Windows NT permissions determine the user's access.

•

For NFS requests, the storage system generates and stores a set of UNIX-style
permissions that are at least as restrictive as the Windows NT permissions.

Mixed
Mixed UNIX and NTFS security. Some files in the qtree or internal volume have the
UNIX security style and some have the NTFS security style. A file's security style
depends on whether the permission was last set from CIFS or NFS.
Replication Technology
The type of replication technology, for example, SnapMirror.
Replication Mode
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Type of replication, for example, Synchronous, Asynchronous, Semi-Synchronous, Copy,
or Unknown.
Replica Source Storage
Storage device that contains the qtree being replicated.
Replica Source Internal Volume
Internal volume that contains the qtree being replicated.
Replica Source Qtree
Qtree that is being replicated.
Status
Status of the qtree as reported by the device vendor. The following values could appear:
Normal
The share is a typical, exposed share.
Read Only
The share has read-only permissions.
Read Write
The share has read-and-write permissions.
SnapMirror
The share is used for SnapMirror copies.
SnapVault
The share is used for SnapVault storage.
Oplocks
Indication of whether CIFS Opportunistic Locks is enabled on the qtree. Oplocks is a filelocking mechanism that improves performance by controlling the caching of files on the
client. Oplocks are typically enabled, except for database applications.
If you have a project using a database that requires CIFS oplocks to be disabled, you can
set CIFS oplocks to Off for that project's qtree, while allowing other projects to retain
CIFS oplocks. The use of qtrees allows selective disabling of CIFS oplocks, which is
beneficial for certain database and critical-data applications.
Volume Count
The number of volumes that were created on the qtree.
Share Count
The number of shares that were created on the qtree.
Application
Application that is associated with this qtree.
Application Priority
The priority of each application, which helps identify the importance of running that
application.
Tenant, Line of Business, Business Unit, Project
Business entity information associated with this qtree. Using Data Warehouse, you can
create reports using this hierarchy.
annotations

Notes, referred to as annotations, associated with the qtree.
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Grouping
You can group the data in this view by the following options:
•

Storage, then storage pool

•

Storage, then SVM/vFiler unit

•

Internal volume

•

Status

•

Type

•

Replica Source (storage, then internal volume, and then Qtress)

•

Application

Options
The following options appear when you right-click on a row:
Analyze
Enables you to analyze the performance for the selected data store. Available only with
the Perform license.
Set Applications
Assigns the selected host to one or more applications that you select.
Set Business Entities
Assigns the selected host or hosts to a business entity (tenant, line of business, business
unit, and project).
Automatically Add Applications
Automatically adds hosts to applications based on a host naming pattern.
Edit/Set/Clear Annotation
Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or tier. The Clear option removes the annotation from
the resource.

Quotas detail view
You can use the Quotas detail view to identify the limits on the amount of usable space or the number
of files that can be created on a NAS share or qtree. Quotas are typically set up by storage
administrators on the shares or qtrees. Multiple quotas can exist on a qtree.
In this view, you can see quotas that are applied in either of the following ways:
•

Derived quota: This quota was applied to all qtrees in the internal volume (except for those that
have an explicit quota).

•

Explicit quota: This quota was defined on a specific qtree.

To perform capacity management in Insight, quotas must be set on the qtrees.
Navigation
You can access this detail view in any of the following ways:
•

From the Insight Client menu, select View > Detail Views > Quotas.
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•

At the bottom of Client view, click the quotas detail view icon.

This detail view is available after clicking a device in any of the following views and selecting the
qtree on the Qtrees detail view:
•

Changes main view

•

Hosts main view

•

Paths main view

•

Storage Arrays view

•

Topology view

Column descriptions
The Quotas detail view displays the following information.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by type, this column displays the
quota types. The number in parentheses indicates the number of quotas in each grouped
row.
Internal Volume
The internal volume on which the target share resides.
Qtree
Qtree associated with the quota. “All Qtrees” indicates that this quota is associated with
all qtrees.
Type
The type of target (qtree, group, or user) to which this quota is applied. A quota can be
attached to one of the following:
•

A specific qtree or all qtrees

•

A specific user or all users

•

A specific group or all groups

User/Group
Specific user or group associated with the quota. “All Users” indicates that the quota is
associated with all users.
Used Capacity (GB)
Amount of capacity used towards the hard and soft capacity limit set on the quota.
File Count
Number of files counted towards the hard and soft file limit set on the quota.
Threshold (MB)
The disk space usage point at which warnings of approaching quota limits are issued.
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Capacity Hard Limit (GB)
The disk space limit that this quota imposes on the qtree, group, or user. If this is
exceeded, data cannot be written.
Files Hard Limit
The limit on the number of files that this quota imposes on the qtree, group, or user.
Capacity Soft Limit (GB)
The soft disk space limit that this quota imposes on the qtree, group, or user.
Files Soft Limit
The soft limit on the number of files that this quota imposes on the qtree, group, or user.
annotations

Notes, referred to as annotations, associated with the quota.
Option
Edit/Set/Clear Annotation
Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or tier. The Clear option removes the annotation from
the resource.

Shares detail view
Use this view to look at the services or end points of NAS paths for both NFS Exports and CIFS
shares. You can also see the initiator hosts along with read, write, or execute permissions assigned to
the share.
About shares
A share provides the following:
•

Complete path for an existing folder or volume to be shared

•

Name of the share entered by users when they access the share (connect to it)

•

Permission for the share

•

Maximum number of users who can access the share simultaneously

Navigation
You can access this detail view in any of the following ways:
•

From the Client menu, select View > Detail Views > Shares.

•

At the bottom of the Client view, click the Shares detail view icon.

This detail view is available after clicking a device in any of the following views:
•

Paths main view

•

Changes main view

•

Hosts main view

•

Storage Arrays view

•

Topology view
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Column descriptions
The Shares detail view displays the following, depending on what you select in the main view or
Topology view.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by internal volume, this column
displays the internal volume names. The number in parentheses indicates the number of
shares in each grouped row.
Share Name
The name (public name) of the share that the NAS storage uses to expose the directory or
the full path to the exposed directory.
Storage
The name of the storage array with which the share is associated.
SVM/vFiler
If the volume is associated with a SVM (Storage Virtual Machine) or vFiler unit, the unit
name appears. As an isolated software container that behaves like a physical storage array,
a vFiler unit shares the physical resources of the array, but abstracts the client access from
the physical array into virtual arrays.
Storage Pool
The storage pool associated with the share. Storage pools are a logical layer used by a
storage array to map the resources (volume and shares) to the storage (for example, disks
and backend volumes) where the capacity actually resides. You can view storage pools
information only for storage devices where thin provisioning applies.
Internal Volume
The internal volume on which the share resides.
Qtree
Name of the qtree on which the share resides.
Initiators
The iSCSI initiator node associated with a host. An asterisk ( *) indicates a special
initiator representing all hosts.
Permission
The read, write, or execute privileges assigned to the share.
Protocols
The CIFS or NFS protocol. NAS storage can expose the directory as a UNIX or Windows
directory.
Description
The description of the share, as entered by the administrator in the storage system's
application.
Application
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Applications assigned to this host. If the host is not dedicated to any applications, no value
appears here. Together, the host servers associated with an application are known as an
application group.
Application Priority
The priority for each application if the host is assigned to run specific applications.
Tenant, Line of Business, Business Unit, and Project
The business entities associated with each share as defined in the settings.
<annotations>
Annotations associated with each share.
Options
Analyze
Available only with the Perform license. Allows you to analyze the performance for the
selected data store.
Set Applications
Assigns the selected resource to one or more applications that you select.
Set Business Entities
Assigns the select resource to a business entity (tenant, line of business, business unit, and
project).
Automatically Add Applications
Automatically adds resources to applications based on a naming pattern.
Edit/Set/Clear Annotation
Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or tier. The Clear option removes the annotation from
the resource.

Storage Arrays view
Use this view to identify storage arrays that Insight detects in your environment. You can delete an
inactive device or controller, set annotations, or view storage array properties. Inactive arrays appear
in black text; active arrays appear in blue text.
Navigation
You can access this main view in either of the following ways:
•

From the Open menu, select Inventory > Storage Arrays.

•

From the navigation pane, select Inventory > Storage Arrays.

Column descriptions
A storage array is a subsystem that houses a group of disks (or tapes) together and is controlled by
software usually housed within the same subsystem. A storage array usually provides storage to a
consumer (such as hosts or storage systems when using storage virtualization or replication).
The main table on this view reflects the configuration of the storage array itself based on the
manufacturer's configuration procedures. The number following the view heading in parentheses
indicates the total number of storage arrays in the list.
blank
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When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by vendor, this column displays the
vendor names. The number in parentheses in each grouped row indicates the number of
storage arrays in each grouped row.
Name
The name of the storage array.
IP
IP address assigned to the host associated with this storage array.
Capacity (GB)
The capacity available for use on the storage array, if known. This is the sum of all storage
pool capacities.
Raw Capacity (GB)
The total physical capacity of all disks in the storage array.
Protocols
The SAN (FC and iSCSI) or NAS (NFS and CIFS) protocols that the device supports.
icon (array virtualization type)
Indication of virtualization. One of two icons could appear: V icon or B icon. In the
Volumes and Backend Volumes views, this column indicates whether the volume is a
virtualized volume (V) or a backend volume (B). In the Paths view, if the path connects to
a volume, the V/B column indicates if the volume is virtual, backend, or neither. If the
path connects to a share, the column indicates if the share is virtual. In the Storage Arrays
view, this column indicates whether the storage acts as a virtualizer device (V) and uses
virtual volumes or as backend storage (B).
Vendor
The name of the vendor that sells the device.
Family
The device manufacturer's family of products.
Model
The device manufacturer's model number.
Serial Number
The manufacturer's serial number for the device.
Microcode Version
The version of the firmware running on the storage array.
FC Port Count
The number of FC ports on the array.
icon (Is the device offline?)
An icon in this column indicates that the device is inactive (offline).
Last Report Time
Date and time when Insight last received the information about the device.
Tenant, Line of Business, Business Unit, Project
Tenant, line of business, business unit, and project associated with this resource.
<annotations>
Annotations, such as data center or building floor, associated with each storage array.

OnCommand Insight views | 159

Options
From the Storage Arrays view, right-click to show a pop-up menu containing the following options.
Delete Inactive Device
Removes the selected storage array, typically after you decommission it from your
environment. Insight confirms the request before removing the device from the Insight
database.
Before using this option, make sure that the device is marked as inactive. An icon
indicating whether the device is offline appears in this view. The device's icon in the
Topology view should be grayed, as well as the corresponding row in the inventory
display. There should not be any links from the device to other devices in the Topology
view. This happens automatically when you remove the data source corresponding to the
device. If no inactive devices exist, this option is disabled.
Delete Inactive Controller
Removes an inactive controller from the selected storage array. Insight confirms the
request before removing the controller from the database. The storage array remains
connected through any other active controllers.
Undo Identification
Removes the identification of a storage array that was identified manually. Insight
confirms the request and then removes the array's identifying data from the database,
reverting each unidentified port to a generic device.
Note: You cannot undo the identification of devices that were discovered through data
source acquisition. However, you can delete the data source.

Manage Storage
Launches a third-party management console or user interface for the selected storage
array. If the third-party management console is not configured in the device itself, this
option is disabled. Insight detects this during device identification.
Reserve capacity for new request or existing request
Available only with the Plan license. Initiates requests (for capacity and ports) or
reservations (for volumes, capacity, and ports).
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
Available only with the Perform license. Shows the performance information for the
selected resource.
Analyze Storage Pools
Available only with the Assure license. Allows you to select a specific storage pool and
assess its status related to the thin-provisioning policies. You can use this dialog box,
instead of the Violations Browser, to see the current thin provisioning violations and how
close the storage pool is to reaching the policy limits.
Modify Policy
Allows you to modify non-performance policies. This requires the Assure license. You
modify performance policies using the web UI.
Set Business Entities
Associates the business entities (tenant, line of business, business unit, and project) with
this resource.
Edit/Set/Clear Annotation
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Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or tier. The Clear option removes the annotation from
the resource.

Storage Pools detail view
Use this view to display information about the storage pools for a selected item. You can view
information about your storage pools, such as over-commit status and the physical versus committed
size. A storage pool is a logical layer used by a storage array to map the resources (volume and
shares) to the storage (for example, disks and backend volumes) where the capacity actually resides.
You can view storage pool information for storage devices regardless of whether thin provisioning
applies.
You might want to look at this view to determine how much capacity you have left in a storage pool.
For example, suppose a storage pool has 20.9 GB of over-committed capacity out of 239 GB of total
capacity. The sum of capacity of the internal volumes carved from the storage pool exceeds the
capacity of the storage pool. The ratio would appear as 109%.
Navigation
You can access this detail view in one of the following ways:
•

From the Client menu, select View > Detail Views > Storage Pools.

•

At the bottom of the Client view, click the Storage Pools detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Changes main view

•

Hosts main view

•

Paths main view

•

SAN Path Violations view

•

Storage Arrays view

•

Topology view

•

Virtual Machines view

The view is also available from these views after you open the Topology view:
•

Generic Devices view

•

Zones view

The Storage Pools view shows the following information, depending on the device selected:
•

If you selected a storage array, this view shows all storage pools on the selected storage array.

•

If you selected a host, this view shows all storage pools that underlie the shares and volumes to
which hosts have paths or masks.

•

If you selected a path, this view shows all storage pools that underlie the shares and volumes
associated with the selected path.

Column descriptions
Name
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The name of the storage pool.
Storage
The name of the storage array associated with the storage pool.
Nodes
Shows the storage node, if any, that manages the storage pool. This is not the SAN node.
icon (Is virtual?)
A "V" icon in this column indicates that the device is a virtualized volume.
Capacity (GB)
The size of the storage pool that is available for storing user data, in gigabytes.
Used Capacity (GB)
The capacity consumed in the device, in gigabytes. The amount of usable capacity in use
on the storage pool. This includes the capacity consumed by internal volumes, volumes,
Snapshot Reserve, and other storage efficiency technology overheads.
Used Capacity (%)
The percentage of capacity consumed in the device, in gigabytes.
Unused Capacity (GB)
The usable capacity that might be available for storing additional data on the storage pool,
in gigabytes.
Raw Capacity (GB)
The physical disk capacity of the storage pool, in gigabytes. Raw capacity is derived by
the device manufacturer. This differs from usable capacity when technologies such as
RAID-5 are used, where some of the raw capacity is used for protection purposes.
Used Raw Capacity (GB)
The amount of raw capacity in use on the storage pool, in gigabytes.
Unused Raw Capacity (GB)
The raw capacity that might be available for storing additional data on the storage pool, in
gigabytes.
Type
A vendor-specific description of the storage pool. One of the following values can appear:
•

Backend Group: For array virtualization.

•

Flash Pool aggregate: For a storage pool using Flash disks as cache.

•

Hybrid Aggregate: For NetApp storage systems.

•

RAID group: A non-vendor-specific type to indicate RAID technology.

•

Reserved: For a storage pool that cannot be used for data.

•

Thin Provisioning: For a storage pool using thin provisioning technology.

Auto Tiering
A checkmark indicates that the selected storage pool is using the automatic storage tiering
technology (for example, FAST VP).
Vendor Tier
Indicates the tier as taken from the vendor's data. This is different from the tier assigned in
Settings. The vendor tier usually matches the type of the disks in the storage pool, for
example, SATA, FC, or EFD disk types. Vendor tier is the building block in an automated

162 | OnCommand Insight Inventory User Guide

tiering policy. The vendor tier appears in the Auto Tiering Policy Constraints column in
the Volumes detail view.
Uses Flash Pools
A check mark indicates that the selected storage pool is using SSD disks as cache (for
example, Flash Pool technology). In this case, the SSD disks are used for cache and do not
contribute to the usable size of the storage pool.
Status
Current status of the storage pool, taken from the device itself. For an explanation of
values from specific vendors, see the device documentation.
For NetApp devices, the storage pool statuses include the following:
Status

Description

Online

Read and write access to volumes contained in this storage pool is
allowed.

Offline

Some operations, such as parity reconstruction, are allowed, but data
access is not allowed.

Restrict

No read or write access is allowed.

If the value is not provided by the vendor or is unknown, the field appears blank.
Over-committed Capacity (GB)
The amount of capacity, in gigabytes, that has been over-committed from the storage pool.
When thin provisioning is in use, the total size of volumes that are created from a storage
pool can exceed the total capacity of the storage pool. This value displays the difference
between the total size of the capacity committed to volumes versus the total capacity of
the storage pool. If there is no over-commitment on the storage pool, the value is 0. In an
environment with internal volumes that support thin provisioning, if the committed
capacity of the volumes exceed the capacity of the internal volume, the over-committed
size will be the size of the volumes.
Commit Ratio
The ratio of the total space on the storage pool to the capacity that is allocated from it.
This value can be greater than 100% when thin provisioning is in use (the pool is overcommitted).
Snapshot Reserve (GB)
The amount of usable capacity, in gigabytes, of the storage pool that is reserved for
Snapshot copy data.
Snapshot Used (GB)
The amount of usable capacity , in gigabytes, of the storage pool that has been used for
Snapshot copy data.
Snapshot Used (%)
The percent of usable capacity of the storage pool out of the Snapshot reserved capacity
that has been used for Snapshot copies.
Redundancy
Level of mirroring defined for the device based on the storage technology, for example,
RAID-DP, underlying the device. This is taken from the device itself. For an explanation
of values, see the device documentation.
Disk Types
The type of physical disks (for example, Fibre Channel or ATA) on which the storage pool
is based. Taken from the device itself.

OnCommand Insight views | 163

If there are disks with multiple disk types, speed, or size, the information appears in a
comma-separated list. If a storage pool is on a virtual LUN, "vLUN" appears as the disk
type, the LUN size appears as the disk size, and Disk Speed is blank.
Disk Size (GB)
Comma-separated list of the sizes of the physical disks on which the storage pool is based.
Disk Speed
The speed of the physical disks on which the storage pool is based, in revolutions per
minute (RPM).
<annotations>
Annotations defined for each storage pool.
Options
From the Storage Pools detail view, right-click to show a pop-up menu containing the following
options. If other product licenses are installed, additional options appear.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
Available only with the Perform license. Allows you to analyze the performance for the
selected data store.
Analyze Storage Pools
Available only with the Assure license. Allows you to select a specific storage pool and
assess its status related to the thin-provisioning policies. You can use this dialog box,
instead of the Violations Browser, to see the current thin provisioning violations and how
close the storage pool is to reaching the policy limits.
Show Disks
Shows all disks used by the selected storage pool in a separate view.
Modify Policy
Allows you to modify non-performance policies. This requires the Assure license. You
modify performance policies using the web UI.
Set/Edit/Clear Annotation
Allows you to assign a note (annotation) to this resource so that you can later group or
filter the resources by the annotation. For example, you might want to group or filter
resource by a specific note or tier. You can also clear the annotation from the resource.

Switches view
You use this view to see a list of switches that OnCommand Insight detects in your environment. This
view applies to Fibre Channel switches only. Inactive switches appear in gray text; active switches
appear in black text.
Navigation
You can access this main view in one of the following ways:
•

From the OnCommand Insight Open menu, select Inventory > Switches.

•

From the navigation pane, select Inventory > Switches.
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Column descriptions
The main table reflects the configuration of the switch itself, based on the manufacturer's
configuration procedures. The number following the table heading (in parentheses) indicates the total
number of switches in the list.
blank

When you group the data using the Grouping drop-down list, the Grouping column shows
the grouped values. For example, if you grouped the data by fabric, the Grouping column
displays the fabric names. The number in parentheses indicates the number of switches in
each grouped row.
Name
The name of the switch, as provided by the SAN manager at the switch console.
IP
IP address assigned to the switch.
Vendor
The name of the vendor who sells the switch.
Model
The model number from the switch manufacturer.
Firmware
The version of the firmware running on the switch.
Serial Number
The serial number for the device.
FC Port Count
The number of Fibre Channel ports on the switch.
Status
The current status of the switch as reported by the switch. The conditions on the switches
that result in the following values might differ between switches.
Value

Definition

Faulty

The switch is not operating successfully.

Not supported

The status of this switch is not provided
by the switch vendor or the switch is
unused.

OK

The switch is working properly.

Unknown

OnCommand Insight cannot detect the
status of the switch. The status is not
reported by the vendor.

Warning

The switch is operating; however, an issue
exists.

Fabric/VSAN
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The fabric or VSAN on which this switch is configured to operate.
WWN
World Wide Name assigned to the switch.
Last Report Time
Date and time when the information about the device was last received.
icon (Is the device offline?)
An icon in this column indicates that the switch is offline.
Tenant, Line of Business, Business Unit, Project
The business entities associated with this resource.
<annotations>
Annotations associated with each switch.
Options
To see details for a particular switch, click on the switch in the Switches view. At the bottom of the
OnCommand Insight Client window, in the icon bar, click the Properties icon.
From the Switches view, right-click to show a pop-up menu containing the following options or from
the OnCommand Insight main menu, select Action > <option name>. If other OnCommand Insight
modules are installed, additional options appear. See the documentation for those modules, as
appropriate.
Delete Inactive Device
Removes the selected switch device, typically after you decommission it from your
environment. OnCommand Insight confirms the request before removing the device from
the database.
Before using this option, make sure that the switch is marked as inactive. An icon
indicating whether the switch is offline appears in this view. The switch icon in the
Topology view should be grayed, as well as the corresponding row in the inventory
display. There should not be any links from the switch to other devices in the Topology
view. This happens automatically when you remove the data source corresponding to the
switch. If no inactive devices exist, this option is disabled.
Delete Inactive Ports
Removes inactive ports from the selected switch. OnCommand Insight confirms the
request before removing the port from the database. The switch will remain connected
through any other active ports. If no inactive ports exist, this option is disabled.
Manage Switch
Launches a third-party management console or user interface for the selected switch. If
the third-party management console is not configured, this option is disabled.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
Analyze
Allows you to analyze the performance for the selected data store. Requires the
OnCommand Insight Perform license.
Set Business Entities
Assigns the selected resource or resources to a business entity (tenant, line of business,
business unit, and project).
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Edit/Set Annotation
Allows you to assign a predefined or custom category to this device so that you can later
group the devices by the annotation. For example, you might want to group all devices in a
specific data center or tier.
Clear Annotation
Removes the assigned annotation from this device.
Related tasks

Viewing all switches on page 33

Tapes view
Use this view to identify the tapes that OnCommand Insight detects in your environment or to view
tape properties.
Navigation
You can access this main view in one of the following ways.
•

From the OnCommand Insight Open menu, select Inventory > Tapes.

•

From the navigation pane, select Inventory > Tapes.

Column descriptions
The main table reflects the configuration of the tape itself, based on the default configuration
procedures provided by the tape manufacturer. The number (in parentheses) following the table title
indicates the total number of tapes in the list.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by vendor, this column displays the
vendor names. The number in parentheses indicates the number of tapes in each grouped
row.
Name
The name of the tape device.
IP
IP address assigned to the tape.
Vendor
The name of the vendor who manufactures the device.
Serial Number
The manufacturer's serial number for the device.
FC Port Count
The number of Fibre Channel ports on the host associated with this tape device.
Last Report Time
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Date and time when the information about the device was last received.
<annotations>
Annotations associated with each tape.
icon (Is the device offline?)
An icon in this column indicates that the device is inactive (offline).
Options
To see details for a particular tape, click on it in the Tapes view. At the bottom of the OnCommand
Insight Client window, in the icon bar, click the Properties icon.
Tape Properties
Displays the Tape Properties view for the selected device in a separate window, allowing
you to hold the properties of one tape while selecting another tape in the main view.
From the Tapes view, right-click to show a pop-up menu containing the following options. If other
OnCommand Insight modules are installed, additional options appear. See the documentation for
those modules, as appropriate.
Delete Inactive Device
Removes the selected tape device, typically after you decommission it from your
environment. OnCommand Insight confirms the request before removing the device from
the database.
Before using this option, make sure that the tape is marked as inactive. Its icon in the
Topology view should be grayed, as well as the corresponding row in the inventory
display. There should not be any links from the tape to other devices in the Topology view.
This happens automatically when you remove the data source corresponding to the device.
Delete Inactive Controller
Removes an inactive controller from the selected device. OnCommand Insight confirms
the request before removing the device from the database. The tape will remain connected
through any other active controllers.
Undo Identification
Removes the identification for a tape that was identified manually. OnCommand Insight
confirms the request and then removes the tape's identifying data from the database,
reverting each unidentified device to a generic-device status.
Note: You cannot undo the identification for devices that are discovered through data
source acquisition.

Analyze
Shows the performance information for the selected resource. This requires the
OnCommand Insight Perform license.
Analyze
Shows the performance information for the selected resource. This requires the
OnCommand Insight Perform license.
Modify Policy
Allows you to modify non-performance policies. This requires the Assure license. You
modify performance policies using the web UI.
Set/Edit/Clear Annotation
Allows you to assign a predefined or custom category to this device so that you can later
group the devices by the annotation. For example, you might want to group all devices in a
specific data center or tier. You can also edit or clear the annotation.
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Virtual Storage detail view
You can display information about virtual volumes used by a host and backend volumes used by
those virtual volumes or that are associated with a selected device or path. A backend volume is the
storage connected at the backend of a virtualizer device, which supplies the array virtualization
capability and forwards traffic to the backend storage. You can use the Virtual Storage detail view to
see all the relationships between frontend (virtual) storage and backend storage. As these
relationships might be complex, this view might take a noticeable time to display.
About backend volumes
A virtual volume is an exposed volume whose data exists on a backend storage device. A backend
volume is a volume on a backend storage device that houses data for a virtual volume. This enables
the administrators of virtual volumes to add or remove capacity on the backend volume without
affecting the users of the virtual volume.
A backend volume enables you to see how a virtual volume is being stored. You can open the
Backend Volume view to see all the volume information for a device or a path's backend storage. The
Backend Volume view loads more quickly than the Virtual Storage detail view. See the Volumes view
for a description of all the columns and options for the Backend Volumes view.
Navigation
This detail view is available after clicking a device in any of the following views:
•

Paths main view

•

Changes main view

•

Hosts main view

•

Topology view

•

SAN Path Violations view

•

Storage Arrays view

You can access this detail view in one of the following ways:
•

From the Client menu, select View > Detail Views > Virtual Storage.

•

At the bottom of the Client view, click the Virtual Storage detail view icon.

Column descriptions
The Virtual Storage detail view shows different information, depending on the item selected in the
view. For example, if a violation is selected in the SAN Path Violations view, only virtualization
information for the virtual volumes causing the violation is displayed.
The Virtual Storage table shows one row for each virtual-backend connection. In some cases, you
might see a virtual volume multiple times because each one uses multiple backend volumes.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by virtualizer, this column displays
the virtualizers. The number in parentheses indicates the number of backend volumes in
each grouped row.
Virtualizer
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The name of the device that supplies the array virtualization and forwards traffic to the
backend storage. The host sees the virtualizer only as storage. This is the device that
supplies the array virtualization capability.
Virtual Volume
The virtual volume that is exposed to the hosts. This is the “volume” being mapped and
masked to hosts.
Virtual Volume Capacity (GB)
The usable storage capacity of the virtual volume.
Virtual Share
The share that is visible to the data center NAS. The shares determine the file system seen
by hosts. Storage for the virtual share is obtained from the virtual storage pool.
Virtual Internal Volume
A logical storage sub-unit within some virtualizers used to compose the virtual storage
pool. Storage for the virtual internal volume is obtained from one or more backend
volumes. Some virtualizers may compose the storage pool directly from backend volumes
without using internal volumes.
Virtual Internal Volume Capacity (GB)
The usable storage capacity of the internal volume. Some virtualizers may not allow a
virtual volume or share to span multiple internal volumes.
Virtual Storage Pool
The logical collection of storage within the virtualizer from which the virtual volumes and
virtual shares are allocated.
Virtual Storage Pool Capacity (GB)
The usable capacity of the storage pool for the virtualizer. This limits the total capacity
available to the virtual volumes and shares of the virtualizer.
Impacted Hosts
A comma-separated list of hosts impacted by backend violations on the path between the
virtualizer and backend storage.
SVM/vFiler
A logical partition of a NetApp storage array, an SVM (Storage Virtual Machine), or a
vFiler unit. It might manage one or more of the virtual internal volumes.
Virtual Disk
The virtualizer plays the role of a storage initiator, like a host, to the backend storage
target. Just as a host uses a LUN to access a DAS disk or SAN volume, the virtualizer uses
a Virtual Disk LUN to access a backend volume.
Backend Storage
A storage array that provides physical storage to the virtualizer.
Backend Volume
The volume of the backend storage array.
Backend Volume Capacity (GB)
Capacity available for use by the volumes of the backend storage array.
Backend Volume Raw Capacity (GB)
The physical disk capacity of the backend volume. Not all the physical space is usable,
because technologies such as RAID often reserve space for data protection.
icon (Are there violations?)
An icon in this column indicates there is a violation for that storage resource.
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Options
To see details of standard options, such as how to filter data, group data, or expand rows, see
“Working with tables and data in OnCommand Insight views.”
Show Virtualization Topology
Shows the virtualization topology for the selected virtual volume and backend volume
relationship, similar to the action in the Volumes view.
Analyze Virtual Volume Performance
Shows performance information for the selected virtual volume whose data exists on a
backend storage device.
Analyze Virtual Disk Performance
Shows disk performance information for the selected virtual storage device.
Analyze Backend Volume Performance
Shows performance information for the selected backend volume, that is a volume on a
backend storage device that houses data for a virtual volume.
Related tasks

Working with tables and data in OnCommand Insight views on page 13
Using storage virtualization on page 97
Related references

Volumes detail view on page 170

Volumes detail view
Use this view to find information about volumes configured on a storage array or for a host for access
through SAN protocols. You can also see LUNs configured on the device.
About volumes
Using the Volumes detail view, you can see the end points of SAN paths. For NetApp storage, you
can view the LUNs configured on the device.
Note: To view NetApp volume information, use the Internal Volumes detail view.

Navigation
You can access this detail view in any of the following ways.
•

From the Client menu, select View > Detail Views > Volumes.

•

At the bottom of the Client view, click the Volumes detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Changes main view

•

Hosts main view

•

Paths main view

•

SAN Path Violations view

•

Storage Arrays view
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•

Virtual Machines view

•

Topology view

•

Zones view

•

This detail view is available after you open the Topology view and click a device from the
Generic Devices view

Column descriptions
The Volumes detail view shows the following information, depending on the device selected:
•

Information about volumes configured on a storage array or for a host. This applies when you
select a storage array or a host in the Topology view, the Storage Arrays view, or Hosts main
view.

•

Volume details for the selected row in the main view (for example, the volumes accessible
through a particular path).

Thinly provisioned volumes report disk speed, disk type, and disk size similar to any other volume.
These values are extracted from disks that are aggregated to the storage pool from which the volume
is allocated.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by volume type, this column
displays the volume types. The number in parentheses indicates the number of volumes in
each grouped row.
Volume
Name of the volume.
Label
Full volume name within the storage array.
UUID
A universally unique identifier assigned to volume by certain storage arrays.
Storage
Storage array that created or manages the volume.
Storage Pool
Name of the storage pool on which the volume resides. A logical layer used by some
storage array to map the resources (volume and shares) to the storage (for example, disks
and backend volumes) where the capacity actually resides.
Thin Provisioned
A check appears if the volume is leveraging thin provisioning.
SVM/vFiler
If the volume is associated with an SVM (Storage Virtual Machine) or a vFiler, the vFiler
unit name appears. An isolated software container that behaves exactly like a physical
storage array. A vFiler unit shares the physical resources of the array, but abstracts the
client access from the physical array into virtual arrays.
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Nodes
Shows the storage cluster nodes, if any, that manage the storage pool. This is not the SAN
node.
HA Partner
A pair of nodes configured to serve data for each other if one of the two nodes stops
functioning.
Internal Volume
Internal volume on which the volume resides.
Qtree
Name of the qtree associated with the volume. Volumes and shares can potentially reside
on top of qtrees.
icon (Array Virtualization Type)
Indicates type of virtualization. Showing on a volume, a "V" icon indicates that the device
is a virtualized volume and a "B" icon indicates that the device is a backend volume.
Virtualizer
For backend volumes in array virtualization. The name of the front end virtualizer that is
using this volume.
Virtualizer Storage Pool
For backend volumes in array virtualization. The name of the storage pool on the front end
virtualizer that is using this volume.
Capacity (GB)
Size of the volume that is accessible to host applications, in gigabytes.
Raw Capacity (GB)
Physical capacity actually present on the device, in gigabytes. At the storage pool level,
this differs from usable capacity when technologies such as RAID-5 are used, where some
of the raw capacity is used for protection purposes.
Consumed Capacity (GB)
The amount of capacity that the volume consumes from underlying storage (internal
volume, storage pool, and so on). For non-thin provisioned volumes, this value is the same
as the capacity of the volume. For thin provisioned volumes, it is the amount of capacity
used to store the volume's contents. Its value is also affected by Snapshot copies,
deduplication, and other storage technologies. If the volume does not have usage
information available, this appears blank.
If the Insight Acquisition obtains a blank value for consumed capacity, the Consumed
Capacity summary value is blank.
Written Capacity
JK: Need Ram's input
Mapped Ports
The number of storage ports through which this volume is accessible.
Masked Hosts
The number of host ports that are defined, by the masking mechanism, as being able to
access the specific volume.
Replication Mode
Type of replication, for example, Synchronous, Asynchronous, Semi-Synchronous, Copy,
or Unknown.
Replica Source Storage
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Storage device that contains the volume being replicated.
Replica Source Volume
Volume that is being replicated.
Type
The vendor-specific type of volume (for example, SFS or BCV). This column also
displays replication role, such as striped, sequential, or image. Virtual disks can have more
than one replication type and could show one of the following replication types:
FlashCopySource, FlashCopyTarget, MetroMirrorMaster, MetroMirrorAuxilary,
GlobalMirrorMaster, GlobalMirrorAuxiliary. The following examples show the combined
volume type and replication information: 1) "striped,FlashCopySource" or 2)
"striped,FlashCopySource,MetroMirrorAuxiliary".
Auto Tiering
A checkmark indicates that the selected storage pool is using the automatic storage tiering
technology (for example, FAST VP).
Auto Tiering Policy
The name of the automatic storage tier policy as taken from the vendor, for example,
FAST VP policy.
Auto Tiering Policy Constraints
Details of the automatic storage tiering policy. Shows the maximum LUN capacity for
each vendor tier. Although tiering can use up to 9 tiers, typically only 2 or 3 tiers are used.
Each tier can be associated with different storage pools.
For example, "SATA 50%, FC 40%, SSD 10%" indicates that no more than 50% of the
LUN capacity can be assigned to SATA disks, 40% to FC disks, and 10% to SSD disks.
Redundancy
Level of mirroring defined for the device based on the storage technology, for example,
RAID-DP, underlying the device. This is taken from the device itself. For an explanation
of values, see the device documentation.
Disk Type
The type of disk (for example, Fibre Channel, SATA, or ATA) underlying the volume.
If there are disks with multiple disk types, speed, or size, the information appears in a
comma-separated list. If a storage pool is on a virtual LUN, "vLUN" appears as the disk
type, the LUN size appears as the disk size, and Disk Speed is blank.
If automatic storage tiering is in effect and FAST VP technology is used, "Mixed" appears
as the disk type. In this case, Disk Type shows only the primary or native storage pool
disks that the volume is using.
Disk Group
The vendor-specific, disk-group value, often related to RAID storage. Refer to the device
documentation for an explanation of values.
Device Group
Group to which the volume belongs.
Disk Size (GB)
Size of the physical disk as used by the volume.
Disk Speed
Speed of the disk as used by the volume, in revolutions per minute (RPM).
Reservation Status
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Indication of whether the volume is currently Used (masked and mapped), is Reserved for
fulfilling a storage request, or is Free for allocation or reservation. (OnCommand Insight
Plan only)
RDM
A VMware feature that exposes SCSI targets directly to a virtual machine. RDMs are an
alternative to using VMFS. RDMs are special files in a VMFS volume that act as a proxy
for a raw device.
Datastore
Name of the datastore using the volume.
Application
The name of the application associated with this resource.
Application Priority
The priority (high, medium, or low) assigned to the application.
Tenant, Line of Business, Business Unit, Project
The business entities associated with this resource.
<annotations>
Annotations associated with each volume as defined in the settings.
Tier
If automatic storage tiering is used, "Auto Tier" appears in this annotation. This setting
overrides any manual setting of the regular tier annotation rules.
Options
From the detail view, right-click to show a pop-up menu containing the following options.
Show Volume Virtualization
Shows the virtualization information of the volume in a separate window.
Show Volume Replication
Shows the replication information of the volume in a separate window.
Show Disks
Shows the disks used by the selected volumes.
Show Volume Members
Shows the members of the volume in a separate window. You can right-click on the
Volume Members window and select Show Disks to see the volume member’s disks. You
can select a disk and see the other volume members that are on the disk.
Reserve volumes for new (or existing) request
Allows you to reserve storage space on the selected volume and associate that with an
existing request or generate a new request.
If the volume is not free, meaning that there is a path to it, the option will not be available.
To help clarify this, if you have the Plan license, you can add the Reservation Status
column to the Volumes detail view. This column could help you determine the paths that
exist and identify requests for space.
Open request
If a storage capacity request exists on this volume, this option allows you to open it. This
requires a Plan license.
Open in Web UI
Available only with the Perform license. Displays a corresponding web UI page for the
selected resource.
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Analyze
Shows the performance information for the selected resource. This requires the Perform
license.
Analyze Storage Pools
Available only with the Assure license. Allows you to select a specific storage pool and
assess its status related to the thin-provisioning policies. You can use this dialog box,
instead of the Violations Browser, to see the current thin provisioning violations and how
close the storage pool is to reaching the policy limits.
Set Applications
After you define applications with their business entities, associates the applications with
the selected volumes.
Set Business Entities
Associates the business entities (tenant, line of business, business unit, and project) with
this resource.
Automatically Add Applications
Associates applications with the resource based on criteria you define.
Edit Annotations
Enables you to edit a predefined or custom category to this device so that you can later
group the devices by the annotation. For example, you might want to group all devices in a
specific data center or tier.
Set/Clear Annotation
Enables you to edit or assign a predefined or custom category to this resource so that you
can later group the resources by the annotation. For example, you might want to group all
resources in a specific data center or tier. The Clear option removes the annotation from
the resource.

Zones view
You can use this view to see a list of zones within each fabric in your environment. You can view
properties of a selected zone.
Navigation
You can access this main view in any of the following ways:
•

From the Open menu, select Inventory > Zones.

•

From the navigation pane, select Inventory > Zones.

Column descriptions
The main table reflects the configuration of the zone itself. The number following the table title (in
parentheses) indicates the total number of zones in the list.
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blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by fabric or VSAN, this column
displays the fabric or VSAN names. The number in parentheses indicates the number of
zones in each grouped row.
Fabric/VSAN
The fabric or VSAN in which the zone is configured.
Zone Name
The name of the zone.
Connected Initiators
The number of host ports configured as initiators in the zone.
Connected Targets
The number of target storage (disk and tape) devices configured in the zone.
Zone Type
The type of zoning in effect: for example, standard port zoning.
To see the properties of a particular zone, select the zone in theZones view. At the bottom of the
Client window, click

.

Related tasks

Working with tables and data in OnCommand Insight views on page 13
Analyzing mismatched zones and masks on page 74

Zone Members detail view
You can use this view to see a list of Fibre Channel zones in which the currently selected device is a
member or view a list of zones that are connected through the currently selected switch.
Navigation
You can access this detail view in either of the following ways:
•

From the Client menu, select View > Detail Views > Zone Members.

•

At the bottom of the Client view, click the Zone Members detail view icon.

This detail view is available after clicking a device in one of the following views:
•

Paths main view

•

Changes main view

•

Switches view

•

Hosts main view

•

Storage Arrays view

•

Tapes view

•

Generic Devices view

•

Zones view

•

Topology view
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Column descriptions
The Zone Members detail view displays the following, depending on what you select in the main
view or Topology view:
•

A list of zones in which the currently selected device is a member, together with information for
each host and storage device in that zone
This applies when you select a device from the Topology view or from any main inventory view.

•

A list of zones that are connected through the currently selected switch, together with information
for each host and storage device in that zone

•

The zones for all devices referenced by the selected row in the main table (for example, storage
and host devices for a path or the storage and host devices connected through a switch)

The details vary depending on the type of device selected.
blank

When you group the data using the Grouping drop-down list, this column shows the
grouped values. For example, if you grouped this data by device name, this column
displays the device names. The number in parentheses indicates the number of zones in
each grouped row.
Device Type
The type of device to which the zone applies.
Device Name
The name of the host or storage device associated with this zone.
Status
Status of the zone.
Member
The zone member information for the selected device, as known to the switch-based or
fabric-based zoning mechanism. The format appears as follows:
•

For WWN-based zoning, the formatting appears as (X) 10:B0:00:00:00:00:00:73,
where the value of X can be P, N, or G to indicate that the WWN that follows belongs
to a port, node, or generic device, respectively.

•

For switch-port based zoning, the format varies depending on the type of switch, but
looks something like this: 13,fc0 (Switch 3), where 13 represents the domain ID and
fc0 is the port name. Together these two fields uniquely identify the switch.

Type
The type of zoning used. Applies only to Cisco and Brocade switches. Brocade: Standard
port zoning, QuickLoop definition zone, Fabric Assist definition zone, LSAN zone. Cisco:
Port WWN zoning, Domain and port zone, FC address zone, Fabric port WWN zone,
iSCSI Symbolic node name zone, Interface zone, Domain and interface zone, IPv4
Address zone, IPv6 Address zone, Device Alias zone.
Required Fabric/VSAN
The fabric/VSAN in which the zone is configured. If the Type field specifies Routing
Zone (applicable only to Cisco IVR and Brocade FCR), the row corresponds to the
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routing-zone member. In this case, this field displays the WWN or name of a switch in the
fabric of SAN-routing-enabled switches. The VSAN ID as reported by the routing-zone
member.
WWN
The World Wide Name (WWN) for the zone member.
Related tasks

Analyzing mismatched zones and masks on page 74

Insight Java UI icons
Insight provides icons that represent the various Java UI views. In a main view, you can display data
or detail views by clicking icons for data and detail at the bottom of the main view.
The following table displays the most common icons:
Name

Icon

Description

Backend
Volumes

Displays the virtual volumes whose data exist on a backend storage
device.

Changes

Displays environment changes that might impact your SAN or NAS
resources.

Data Sources

Displays the data sources that collect storage data to help identify
hosts (FC only) or IP-based devices.

Datastores

Displays information about virtual machine data stores.

Disks

Displays storage array disk drives associated with a device.

FC Identify

Displays any unidentified Fibre Channel device ports in your
environment. Use this view to identify FC-based unidentified devices,
called generic devices.

FC Ports

Displays identified Fibre Channel ports.

Generic
Devices

Displays any unidentified devices in your environment.

Hosts

Displays the hosts that Insight detects in your environment.

Internal
Volumes

Displays information about volumes that are used internally in storage
devices.

IP Identify

Displays a list of unidentified host HBA ports, disk storage ports, tape
device ports, and switch ports. Use this view to identify IP-based
devices (for iSCSI and NFS) that are not yet identified.

iSCSI

Displays information about active sessions formed between an iSCSI
initiator node and an iSCSI target node.

NPV
Switches

Represents a proxy switch that multiplexes Fibre Channel port. A
proxy switch is also referred to as an NPV switch or Access Gateway
by other vendors.

Paths

Displays access paths between devices.

Qtrees

Displays the qtrees that Insight detects in your environment.

OnCommand Insight views | 179

Name

Icon

Description

Quotas

Displays quotas set on qtrees.

Storage
Arrays

Displays the storage arrays that Insight detects in your environment.

Storage
Arrays,
ClusterMode

Displays the storage arrays configured in clusters that Insight detects
in your environment.

Storage Pools

Represents a storage pool, which is a logical layer used by a storage
array to map the resources (volume and shares) to the storage (for
example, disks and backend volumes).

Switches

Displays the switches that Insight detects in your environment and the
configuration of the switch itself, based on the manufacturer's
configuration procedures.

Tapes

Displays the tapes that Insight detects in your environment.

Virtual
Machines

Displays the virtual machines that Insight detects in your
environment.

Virtual
Storage

Displays information about the relationship between frontend (virtual)
and backend storage created by a storage virtualizer.

Volumes

Displays information about volumes configured on a storage array or
for a host for access through SAN protocols. You can also see LUNs
configured on the device.

Zones

Displays information about zones within each fabric of your
environment.

Related tasks

Reviewing storage inventory on page 26
Registering a host on page 31
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Insight Glossary
The following terms are useful to understand when working with Insight.

A on page B on page C on page D on page E on page
180
181
181
184
185

F on page
185

I on page
187

N on page O on page P on page
188
189
189

J on page
187

K on page L on page
188
188

Q on page R on page S on page
189
190
190

T on page
191

M on
page 188

G on page H on page
186
187

U on page V on page W on
191
192
page 193

X on page
193

Y on page Z on page
193
193
A
access time
The time that it takes to access the physical hardware of the device. This value is based on
fixed speed specifications of the disk devices.
active/active configuration
•

In the Data ONTAP 7.2 and 7.3 release families, a pair of storage systems or V-Series
systems (sometimes called nodes) configured to serve data for each other if one of the
two systems stops functioning. Also sometimes referred to as active/active pairs.

•

In the Data ONTAP 8.x release family, this functionality is referred to as a highavailability (HA) configuration or an HA pair.

•

In the Data ONTAP 7.1 release family and earlier releases, this functionality is referred
to as a cluster.

active/passive configuration
A configuration in a Data ONTAP HA pair in which the passive node has only a root
volume, while the active node has all the remaining storage and services all data requests
during normal operation. The passive node responds to data requests only if it has taken
over the active node.
aggregate
A collection of disks used to define a storage pool on a NetApp storage device.
aggregate
A set of multiple RAID (Redundant Array of Inexpensive Disks or Redundant Array of
Independent Disks) groups that can be managed as a single unit for protection and
provisioning purposes.
alert
An alarm indicating that a device or path state has changed in a way that violates a policy
or exceeds a threshold.
annotation
A tag or additional piece of information that can be assigned to a device or resource to use
for grouping or filtering devices in a view or a report.
acquisition
The process that detects logical and physical storage resources in the storage environment
along with their interconnections, also referred to as topology. Insight also collects
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attributes of storage resources, such as zoning information, storage data volumes, and
capacity and utilization measurements. Discovery includes the detection of changes in
network topology, including the addition or deletion of nodes or interfaces.
Acquisition Units
Components of Insight that communicate with the storage devices and provide device
information to the Insight server. There are two types of Acquisition Units: Local and
Remote. See also Local Acquisition Unit (LAU) and Remote Acquisition Unit (RAU).
applications
In Insight, applications are a means by which you can track the storage that programs and
indirectly, business entities, are consuming. When applications are assigned to hosts, the
system can report on what and how much storage is consumed by an application, business
unit, or project.
audit
The process by which Insight monitors user activities that affect the storage environment.
Insight monitors user logins, path management activities, policy activities, data source
additions or deletions, cluster configurations, and host identifications. You can view audit
history in the Audit view.
automatic resolution (AR)
The process by which Insight identifies hosts in your environment, determines the type of
device, and associates the device with a host.
B
block-accessed storage
Storage that is accessed by direct I/O operations (SCSI protocol) from the host systems.
The host operating system is responsible for the file system used to manage the contents
of the storage. The SAN FC and iSCSI protocols provide access to block-accessed
storage, exposed as SCSI LUNs. Compare file-accessed storage.
backend volume
The volumes of the backend storage array. A backend volume is a volume on a backend
storage device that houses data for a virtualized volume. This allows the administrators of
virtualized volumes to add or remove capacity on the backend volume without affecting
the users of the virtualized volume.
business continuity
The ability of an organization to continue to function even after a disastrous event,
accomplished through the deployment of redundant hardware and software, use of fault
tolerant systems, and solid backup and recovery strategies.
C
capacity
Capacity available for use, if known. In the Storage Arrays main view, this is the size of
the storage array. In the Paths main view, this is the size of the volume. In the Array
Virtualization detail view, this is the size of the backend volume. In the Disks detail view,
this is the size of the disk. In the Internal Volumes detail view, this is the capacity of the
internal volume. In the Masking detail view, this is the size of the volume that is
accessible to host applications.
capacity, accessed
The capacity for which an access path exists (excluding Snapshot copies and replicated
volumes).
capacity, allocated
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Usable capacity of a device dedicated for a specific purpose. For example, snapshot
allocated capacity indicates used and free capacity of a device dedicated for the Snapshot.
capacity, available
The free, usable capacity available for storing user data on the device. This excludes
capacity reserved for Snapshot copies or data. Capacity Unused does not take into
consideration additional capacity overhead that is not included in the OnCommand Insight
storage model.
capacity, backend
Total capacity of backend LUNs. Relevant for virtual arrays only.
capacity, clone shared
When the Internal Volume is a clone of another Internal Volume, this value shows the
amount of capacity that is shared between the Source and Target clones (If no changes
have been made to the source and target Internal Volumes since the clone operation
occurred, all capacity will be shared. Modifications made to either of the Internal Volumes
will decrease the shared capacity).
capacity, data store
The configured size of the data store. Storage capacity allocated to the data store
(provided by the SDK). For RDM, this is blank.
capacity, data store provisioned
The amount of total capacity that has been set aside for potential use, based on the virtual
machines using this data store. Includes space set aside for virtual machine files of all
types.
capacity, data store unused
Data store capacity that is not allocated to virtual machines (provided by the SDK). For
RDM, this is blank.
capacity, data store used
The amount of capacity holding actual data in the data store. Includes usage based on all
file types.
capacity, managed
The volume capacity that is used.
capacity, masked
The volume capacity that has been masked (excluding Snapshot copies and replicated
volumes).
capacity, orphaned
Volume capacity that has been masked, but for which no access paths exist.
capacity, over-committed
The amount of capacity, in gigabytes, that has been over-committed from the storage pool.
When thin provisioning is in use, the total size of volumes and internal volumes that are
created from a storage pool can exceed the total capacity of the storage pool. This value
displays the difference between the total size of the capacity committed to volumes and
internal volumes versus the total capacity of the storage pool. If there is no overcommitment on the storage pool, the value is 0.
When internal volumes support thin provisioning and the committed capacity of the
volumes created from the internal volume exceeds the capacity of the internal volume, the
committed capacity of the volumes will be used for the calculation of the over-committed
capacity of the storage pool.
capacity, physical
Capacity actually present on the storage device.
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capacity, provisioned
Capacity promised to storage initiators. Often used for chargeback.
For example, suppose you have the following resources:
•

A 100 GB volume allocated on a thin-provisioning storage pool

•

A host that uses 50 GB on the volume

•

A storage pool that is on top of a RAID 5 group with a 20% overhead ratio

The following table displays the example's capacity concepts and how they relate to each
other:
Type

Usable

Raw

Physical

50 GB

60 GB

Provisioned

100 GB

120 GB

capacity, raw
Physical capacity actually present on the device, in gigabytes. At the storage pool level,
this differs from usable capacity when technologies such as RAID-5 are used, where some
of the raw capacity is used for protection purposes. Capacity that is presented before
RAID.
capacity, raw allocated
The volume capacity masked usage and/or designated for replication storage taking into
account use of technologies such as RAID-5, where some of the raw capacity is used for
protection purposes.
capacity, Snapshot overflow
The capacity that was used for Snapshot copies, but exceeded what was reserved for
Snapshot copies.
capacity, Snapshot reserved
The capacity reserved for Snapshot copies.
capacity, Snapshot unused
The capacity remaining after some capacity that was reserved for Snapshot copies was
actually used.
capacity, Snapshot used
The capacity that has been used for Snapshot copies.
capacity, unused
The free, usable capacity available for storing user data on the device. This excludes
capacity reserved for Snapshot copies or data. Capacity Unused does not take into
consideration additional capacity overhead that is not included in the Insight storage
model.
capacity, usable
Capacity available for use, excluding capacity used by technologies such as RAID.
capacity, used
The sum of all internal volumes' consumed capacity, including reserved capacity,
Snapshot used capacity, Snapshot reserved capacity, and storage efficiency technology
overhead. If no internal volumes are present, Capacity Used is the sum of all volumes
consumed capacity, including reserved capacity, Snapshot used capacity, Snapshot
reserved capacity, and storage efficiency technology overhead.
capacity, virtual disk
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The configured capacity of the virtual disk. Relates to the actual VMDK files for this
virtual disk in the datastore. For VMware thin provisioning, this is the maximum size that
the file can reach, not its current size. If the disk is not thin provisioned, this is the size of
the VMDK file.
This size counts against the provisioned capacity taken from the datastore. These files or
disks represent only a subset of the provisioned capacity.
capacity, virtual disk used
The actual size of the VMDK file for this virtual disk. For thin disks, this is a percentage
of the capacity. For thick disks, this is the same as the capacity.
Note: This is not related to the term virtual disk, which pertains to storage
virtualization.

capacity, VM
The sum of virtual disk capacity values. Represents the amount of usable space for the
guest operating system and applications.
capacity, VM provisioned
The amount of capacity that a virtual machine can use from its data stores, in aggregate.
This includes the basic VM capacity from its virtual disks (VMDK), but also other items,
such as memory swap files, Snapshot files, configuration files, and log files.
capacity, VM used
The amount of capacity actually currently used by the virtual machine from its data stores,
in aggregate. This includes used disk capacity across all types of files, such as virtual
disks, swap files, Snapshot files, configuration files, and log files.
Client
The legacy Insight interface used to display the data about your environment and work
with the different types of views. Since the release of Insight 7.0, this interface is called
the Java UI to distinguish it from the new web UI. (See also main view and detail view.)
cluster
A group of servers that together act as a single unit, enabling load balancing and high
availability. Clustering can be housed in the same physical location (basic cluster) or can
be distributed across multiple sites (geo-dispersed clusters) for disaster recovery.
clustered Data ONTAP
A storage solution that delivers nondisruptive operations and supports large scale
environment. Clustered Data ONTAP accommodates mixed workloads and multiple SLAs
on a shared infrastructure, with support for high-speed applications as well as large
content repositories.
Common Internet File System (CIFS) share
A service exposed from a NAS device to provide file-based storage via the CIFS protocol.
CIFS is mostly used for Microsoft Windows clients, but many other operating systems can
access CIFS shares as well.
community name or string
The part of an SNMP message that represents a password-like name and is used to
authenticate the SNMP message.
D
Data ONTAP
The operating system software running on NetApp storage devices.
datastore
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A storage location for virtual machines, such as a VMFS volume, a directory on a NAS
server, or a local file system path. A datastore is platform-independent and hostindependent; therefore, it does not change when a virtual machine it contains moves to
another host.
data store utilization %
The ratio of used capacity divided by total capacity. This shows how much capacity is
being used on the data store.
deduplication
In OnCommand Insight (formerly SANscreen suite), the Data ONTAP process that detects
blocks with identical content and replaces subsequent identical blocks with a reference to
a single copy of the block. This process reduces the amount of space used to store active
data, and enables users to store more bytes of data than the capacity of the available
physical storage.
detail view
One type of view displayed in the Insight Client showing details of the device selected in a
main view. A detail view appears at the center or bottom of the Client window, while
another type of view, the main view, appears at the top of the Client window. There are
many detail views, including the Volumes, Backend Volumes, Storage Pool, and Disks
views.
delimiter
A character that marks the beginning or end of a data element. By default, Insight uses
two common delimiters: the dash ( - ) or underscore ( _ ). Insight uses delimiter
algorithms as a way to extract host names from zone names to help match those names to
the WWN of their HBAs. The host name is determined from the names of all zones in
which the generic device is a member.
discovery
The process of finding physical and logical resources within the storage environment. In
Insight, the process is also called acquisition. See also "acquisition."
disaster recovery
A set of failover operations that enable you to continue to provide data access to your
users, even in the event of a mishap or disaster that disables or destroys the storage
systems in your primary node.
domain name server (DNS)
A resource that resolves domain names to their equivalent IP addresses so that IP traffic
can be transported to the correct destination. Each domain name is associated with, at a
minimum, with a primary and a secondary DNS.
E
ESX server
A VMware term describing a server that abstracts server processor, memory, storage, and
networking resources into multiple virtual machines.
efficiency return
The effective capacity return of NetApp efficiencies when compared to traditional storage
techniques. Calculated by the capacity saved by cloning + deduplication + Snapshot copy
+ thin replication + RAID-DP.
F
fabric
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The interconnection of one or more FC switches in such a manner that data can be
physically transmitted in one port and out another. In FC topologies, the host and the
storage system communicate across the fabric.
failover
A process that reroutes data immediately to an alternate path so that services remain
uninterrupted, if a physical disruption to a network component occurs. Failover applies to
clustering and to multiple paths to storage. In the case of clustering, one or more services,
such as the Exchange service, is moved to a standby server. In the case of multiple paths
to storage, a path failure results in data being rerouted to a different physical connection to
the storage.
FC
Fibre Channel.
Fibre Channel over Ethernet (FCoE)
A protocol defined by the T11 standards body. FCoE provides FC services over a lossless
10-gigabit Ethernet network while preserving the FC protocol.
file-accessed storage
Storage that is accessed using file operations from the host systems. The storage device is
responsible for the file system used to manage the contents of the storage. The NAS NFS
and CIFS protocols provide access to file-accessed storage, exposed as NFS exports and
CIFS shares. Contrast with "block-accessed storage."
file system
A method of storing and organizing computer files and the data that they contain to make
it easy to find them. File systems make use of an underlying data storage device that offers
access to an array of fixed-size blocks, for example, a local hard drive or SAN LUN (SAN
volume).
Flash Cache module
A PCIe-based, solid state memory module that optimizes the performance of random readintensive workloads by functioning as an intelligent external read cache. The Flash Cache
2 module is the successor of the Flash Cache module, which is the successor of the
Performance Acceleration Module (PAM). This hardware works in tandem with the
WAFL External Cache software component of Data ONTAP.
FlexClone
A NetApp software technology that allows instant replication of data files, LUNs, and
volumes without requiring additional storage space. Each cloned file, LUN, or volume is a
virtual copy of the original data.
FlexVol
A NetApp storage-virtualization technology pools physical storage, so you can create and
resize virtual volumes as your application needs change.
G
generic device
An unidentified device (such as a host, storage, or tape) that can have multiple ports,
including ports for HBAs, hosts, disk storage controllers, tapes, or switches. Switch and
storage devices are identified as soon as the correct data source is configured and the
devices are successfully acquired. Tape ports require manual identification as tapes. Hosts
represent the vast majority of generic devices and can typically be identified automatically
through the Insight auto resolution process. The hosts that cannot be identified
automatically appear as generic devices and can be identified manually.
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H
HBA (host bus adapter)
An I/O expansion card in the host that serves as the FC or iSCSI initiator to connect to the
storage system.
hop count
The number of Inter-switch links (ISLs) that a frame must traverse to get from its source
to its destination.
host
A computer that is connected to the storage environment. Depending on the environment,
a host can provide centralized control of the network. A host can be a client, a server, both
a client and a server, a manager, or a managed host.
I
in-band
A type of Fibre Channel management protocol. The most prevalent in-band protocol over
Fibre Channel is SCSI Enclosure Services (SES).
initiator
The system component that originates an I/O command over an I/O bus or network. The
target is the component that receives this command.
inter-switch link (ISL)
A connection between two switches using the E-port.
internal volume
The name used in Insight to represent logical layers in storage devices that are not
externally accessible as SAN volumes or NAS shares. Internal volumes might act as
logical layers underlying both storage services, but are above the storage pool layer.
Internal volumes are carved from storage pools and exposed to hosts as shares or LUNs.
Insight represents Data ONTAP volumes as internal volumes.
IOPS
The rate at which input and output operations are occurring on the storage device. These
are the individual read or write requests that the storage consumer makes to the storage
provider. Each operation might have a large or small amount of data transferred for it. This
is measured in I/O operations per second (IOPS).
iSCSI
Internet Small Computer Systems Interface (iSCSI) protocol. A licensed service on the
storage system that enables you to export LUNs to hosts using the SCSI protocol over
TCP/IP.
iSCSI direct-attached topology
A topology in which the hosts are directly attached to the storage controller. Directattached systems do not use networks or Ethernet switches.
iSCSI network-attached topology
A topology in which the hosts are attached to storage controllers through Ethernet
switches. Networks can contain multiple Ethernet switches in any configuration.
J
JBOD
Just a Bunch Of Disks. An array of disks without any redundancy; that is, without RAID
configuration.
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K
Kbps
Kilobits per second. A digital transmission speed.
L
load balancing
The act of redistributing load (the read and write requests) to an alternate path between the
server and the storage device. Load balancing helps to maintain high performance
networking.
LUN (Logical Unit Number)
A logical unit of storage identified by a number. A LUN identifies a SCSI logical unit of
storage to a host. Some vendors use this term as a general term for SAN end point service.
In Insight, a LUN is volume. See also "volume."
LUN masking
A method to restrict server access to storage not specifically allocated to that server. LUN
masking is similar to zoning, but is implemented in the storage array, not the switch.
M
main view
One type of view displayed in the Insight Client that displays information about a set of
devices in your storage network. A main view appears at the top of the Client window,
while another type of view, the detail view, appears at the center or bottom of the Client
window. There are several main views, including the Hosts view, Switches view, Tapes
view, Generic Devices view, Changes view, Paths view, and Storage Arrays view.
mapping
The process of creating a disk resource and defining its external access paths using a
LUN. A LUN number is assigned to a volume. The LUN number can then be presented to
a host.
masking
The process of setting access control permissions that results in making a volume visible
to some hosts and not to others.
multipathing
The use of redundant storage network components responsible for the transfer of data
between the server and storage. These components include cabling, adapters, and
switches. In the SAN environment, multipathing indicates that the host accesses the same
volume (LUN) over two different fabrics.
N
N_port
A type of Fibre Channel port on a node used in a fabric or other point-to-point (P2P)
connection, residing on a host or storage. An N_port uses both FC-P2P or FC-SW (Fibre
Channel Switched) technologies. N_port is not considered a switch port. Also known as a
Node port.
Network File System (NFS) export
A service exposed from a NAS device to provide file-based storage via the NFS protocol.
NFS is mostly used for UNIX-like operating systems, but other operating systems can
access NFS exports as well.
Network Interface Connector or Card (NIC)
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A device that connects network computers to each other either by using cables or
wirelessly.
O
OCI
OnCommand Insight software.
out-of-band discovery
The process of discovering storage information used by Insight, including topology and
device data, without interfering with the Fibre Channel data paths. A common mechanism
for out-of-band discovery is the use of SNMP MIB queries, which are invoked over a
TCP/IP network. Contrast this with in-band discovery.
P
path
A logical access relationship between an application on a given server and its data on a
storage device (disk volume or tape). Each logical path is identified by these two end
points: the host on one end and the storage device on the other. A logical access path
consists of a sequence of physically connected components, each of which is configured
to allow data flow along that path (assuming proper zoning and masking).
performance policy
The level for the performance policy (Global or Volume) set on this resource. For
example, maximum IOPS, response time, or throughput thresholds might be set. This
appears only if an Insight Perform license is installed.
policy
A rule that governs the protection of data or the requirements of a path's availability,
performance, and security. Insight ensures that properties of a path conform to configured
policies. For example, a global storage policy automatically authorizes new paths to all
storage volumes that did not match the volume type or volume capacity criteria. Policies
can be set to ensure connectivity. For example, one could set a policy stating that there
must be a at least two paths between a host and a storage device. Policies can also be set to
ensure performance. For example, a policy can be set that requires at most 2 hops between
a host and a storage device. The result of a policy can be a violation or an alert.
point-to-point
A dedicated Fibre Channel connection between two devices.
port
A physical connection point on computers, switches, storage arrays, etc., which is used to
connect to other devices on a network. Ports on a Fibre Channel network are identified by
their Worldwide Port Name (WWPN) IDs. TCP/IP ports are used as virtual addresses
assigned to each IP address.
Q
QoS
Quality of Service.
qtree
A special subdirectory of the root of a volume that acts as a virtual subvolume (or as a
special case it can be the entire volume) to which a quota can be applied to limit its size. A
qtree is similar in concept to a partition, but it is more flexible than a partition because its
size can be changed at any time.
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R
raw disk mapping (RDM)
A VMware feature that exposes SCSI targets (or LUNs) directly to a virtual machine.
RDM is an alternative to using VMFS. RDMs are special files in a VMFS volume that act
as a proxy for a raw device.
redundancy
The duplication of information or hardware components to ensure that should a primary
resource fail, a secondary resource can take over its function.
remote storage
The storage that is accessible to the local node, but is at the location of the remote node.
replication
A process of duplicating data from one highly available storage resource to another. The
replication process can be synchronous or asynchronous. Duplicates are known as clones,
point-in-time copies, or Snapshots, depending on the type of copy being made.
response time
The time it takes from the moment a request for information is sent until the information
starts arriving. Response time can be measured in different locations in the network. In
Insight, response times are measured from within the storage array. This value is measured
in milliseconds (ms).
S
sample
A collection of data at any one point in time. Insight collects performance information
from devices at a user-configurable rate. The performance information reported in a
sample is usually an average of the given metric for the duration of time since the last
sample was reported.
share
The logical NAS entity that provides hosts with access to storage resources by name.
Includes both CIFS shares and NFS exports. Shares represent services or end points of
NAS paths.
spare disk
An unused physical disk that is part of a storage device that is the same technology type
(FC, SATA), size, and speed as the disks in use (or better). A spare disk is automatically
used if one of the currently used disks malfunctions.
storage area network (SAN)
A specialized network that provides access to high performance and highly available
storage subsystems using block storage protocols. A SAN is made up of devices, such as
host bus adapters (HBAs) in the host servers, switches that help route storage traffic, and
disk storage subsystems. The main characteristic of a SAN is that storage subsystems are
generally available to multiple hosts at the same time, which makes them scalable and
flexible. Compare with NAS.
storage array
A system that provides storage services to hosts or to other storage systems when using
storage virtualization or replication.
storage controller
The component of a storage system that runs the operating system and controls its disk
subsystem. Storage controllers are also sometimes called controllers, storage appliances,
appliances, storage engines, heads, CPU modules, or controller modules.
storage efficiency quotient or rating
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A value indicating how efficiently the storage is able to manage space requests while
consuming the least amount of physical space on the disk. The formula for this is:
Efficiency = (Total Array Capacity + Gained Capacity - Lost
Capacity) /Total Array Capacity

Gained capacity refers to the amount of capacity gained by using technologies such as
deduplication and thin provisioning. Lost capacity is the capacity taken up by technologies
such as RAID.
storage pool
The physical layer of storage that consists of the disks within a RAID group that provide
thin provisioning capabilities. An aggregation of storage from which space for volumes or
shares can be created. See also "aggregate."
Storage Virtual Machine (SVM)
In clustered Data ONTAP, a virtual storage server (logical storage container) that provides
network access through unique network addresses, which might serve data out of a distinct
namespace, and that is separately administrable from the rest of the cluster. There are
three types of SVMs - admin, node, and data - but unless there is a specific need to
identify the type of SVM, SVM usually refers to the data SVM. Formerly referred to as
“Vserver”.
switch
An intelligent device residing on the network responsible for high-speed routing of data
from the source (such as a server) to a target device (such as a storage device) using linklevel addressing.
T
thin provisioning (TP)
A method of optimizing the efficiency with which the available space is used in storage.
When many applications share access to the same storage array, thin provisioning allows
administrators to maintain a single free space buffer pool to service the data requirements
of all applications. This is done by allocating disk storage space in a flexible manner
among multiple consumers, based on the minimum space required by each at any given
time. This avoids poor utilization that occurs on traditional storage arrays where large
pools of storage capacity are allocated to individual applications, but much remains
unused.
throughput
The rate at which data is transferred to or from the storage device. This is measured in
megabytes per second (MB/s).
tiered storage
The strategy of categorizing storage devices based on their performance characteristics.
Applications can then request storage based on the quality of service of that storage. For
example, data needed for critical business applications is stored at a high availability,
higher cost tier. Data needed to be retained for regulatory purposes can be archived to a
lower cost tier.
topology
The physical and logical arrangement of devices in a storage environment.
U
unauthorized path
A path between a server or host and a specific storage volume or tape system that has not
been authorized, meaning that no policy has been defined for it. This is considered a
violation in Insight.
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V
violation
Insight has the following types of violations:
•

A SAN configuration that does not adhere to an assurance policy
Assurance policies are specified in the Java client.

•

A performance measure that is outside the band of allowable values specified in a
performance policy.
Performance policies are managed in the web UI.

•

Inconsistencies between environment paths and their defined policies in Insight
For planned tasks, violations are the same, but are based on planned activities instead
of actual existing paths. Each violation identifies a physical connection that does not
comply with its policy. To correct a violation, either modify the physical or logical
connections or edit the policy.

virtual machine disk (VMDK)
A VMDK in Insight is either of the following:
•

A file that represents a disk of a virtual machine
The VMDK presents the virtual disk to its operating system as a hard drive. In a
VMware implementation, this could be the VMDK file name (relative to the data
store). In a VMware implementation, this could be the VMDK file name (relative to
the data store).

•

The virtualizer plays the role of a storage initiator, like a host, to the backend storage
target
Just as a host uses a LUN to access a DAS disk or SAN volume, the virtualizer uses a
Virtual Disk LUN to access a backend volume.

virtualized volume
A virtualized volume is an exposed volume whose data exists on a backend storage
device. A backend volume is a volume on a backend storage device that houses data for a
virtualized volume. This allows the administrators of virtualized volumes to add or
remove capacity on the backend volume without affecting the users of the virtualized
volume.
vFiler unit
An isolated software container that behaves exactly like a physical storage array. A vFiler
unit shares the physical resources of the array, but abstracts the client access from the
physical array into virtual arrays. This allows the administrators of virtualized filers to add
or remove capacity on the backend volume without affecting the users of the virtualized
tier.
VMFS
A type of file system used only by VMware ESX hosts for implementing data stores. See
also "raw disk mapping (RDMs)."
volume
A logical storage unit presented by a storage system (storage array) to a host or other
storage system. A volume represents a service or an end point of SAN paths. The entity
represented by a volume in Insight is storage-device specific. For example, EMC
Symmetrix refers to this as a "device" while NetApp refers to this as a "LUN."
Insight represents NetApp clustered Data ONTAP volumes as internal volumes.
Note: To view NetApp volume information, use the Internal Volumes view.
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W
World Wide Name (WWN)
A 64-bit unique identifier for nodes and ports in a fabric.
X
Y
Z
zone
A segment of a SAN fabric composed of selected storage device nodes and server nodes.
Only the members of a zone have access to one another. This is also referred to as switch
zoning, when the zone consists of switch ports, not node ports.
zoning
A method used to restrict access to storage resources that are not allocated to that server.
This allows segmentation of a node by physical port, name, or address. Zoning is similar
to LUN masking, but is implemented in the switch and operates on the basis of port
identification (either port numbers on a switch or by WWPN of the attached initiators and
targets).
zone set
A group of zones that function together on the fabric. Each zone set can accommodate up
to 256 zones. All devices in a zone see only devices assigned to that zone, but any device
in that zone can be a member of other zones in the zone set.
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How to send comments about documentation and
receive update notifications
You can help us to improve the quality of our documentation by sending us your feedback. You can
receive automatic notification when production-level (GA/FCS) documentation is initially released or
important changes are made to existing production-level documents.
If you have suggestions for improving this document, send us your comments by email.

doccomments@netapp.com
To help us direct your comments to the correct division, include in the subject line the product name,
version, and operating system.
If you want to be notified automatically when production-level documentation is released or
important changes are made to existing production-level documents, follow Twitter account
@NetAppDoc.
You can also contact us in the following ways:
•

NetApp, Inc., 495 East Java Drive, Sunnyvale, CA 94089 U.S.

•

Telephone: +1 (408) 822-6000

•

Fax: +1 (408) 822-4501

•

Support telephone: +1 (888) 463-8277
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